aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-11 22:41:20 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-11 22:41:20 +0000
commit1405eaecafa968dedeecdded6674207b91d365f0 (patch)
tree92c1323c67df6c4e059e1ff4547346e20bb3991b /print
parent4ad28101f360ec0afdcf0e3581e2a088977e0bdf (diff)
downloadports-1405eaecafa968dedeecdded6674207b91d365f0.tar.gz
ports-1405eaecafa968dedeecdded6674207b91d365f0.zip
- Update to 1.5.6 (also change to qt4)
PR: 126428 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=218440
Diffstat (limited to 'print')
-rw-r--r--print/lyx15/Makefile108
-rw-r--r--print/lyx15/distinfo6
-rw-r--r--print/lyx15/pkg-plist62
3 files changed, 71 insertions, 105 deletions
diff --git a/print/lyx15/Makefile b/print/lyx15/Makefile
index 75025521baa3..466f7b23001a 100644
--- a/print/lyx15/Makefile
+++ b/print/lyx15/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= lyx
-PORTVERSION= 1.5.5
-PORTREVISION= 2
+PORTVERSION= 1.5.6
CATEGORIES= print
MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/ \
ftp://ftp.planetmirror.com/pub/lyx/stable/ \
@@ -21,112 +20,77 @@ MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Document processor interfaced with LaTeX (nearly WYSIWYG) (stable)
-BUILD_DEPENDS= latex:${PORTSDIR}/print/teTeX
-RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX \
+BUILD_DEPENDS= latex:${PORTSDIR}/print/teTeX-base
+LIB_DEPENDS= boost_regex.4:${PORTSDIR}/devel/boost
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base \
${LOCALBASE}/share/texmf/tex/latex/prettyref/prettyref.sty:${PORTSDIR}/print/latex-prettyref \
${LOCALBASE}/lib/X11/fonts/texcm-ttf/cmex10.ttf:${PORTSDIR}/x11-fonts/texcm-ttf
-LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost
-LATEST_LINK= lyx15
-CFLAGS+= ${PTHREAD_CFLAGS}
-CONFIGURE_ENV+= LDFLAGS=${PTHREAD_LIBS}
+OPTIONS= ASPELL "Utilize Aspell library" on \
+ AIKSAUR "Build Aiksaurus support (English thesaurus)" on \
+ NLS "Native language support" on
-OPTIONS= ASPELL "Utilize ASPELL library" on \
- AIKSAUR "Build Aiksaurus support (English thesaurus)" on \
- NLS "Native language support" On
+CONFLICTS= lyx-1.4.*
-ALL_TARGET= -j`${SYSCTL} -n hw.ncpu`
USE_BZIP2= yes
-USE_GNOME= gnometarget lthack
+USE_QT_VER= 4
+QT_COMPONENTS= gui corelib moc_build uic_build
+USE_GNOME= gnometarget
USE_PERL5= yes
USE_PYTHON= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_QT_VER= 4
-QT_COMPONENTS= gui corelib moc_build uic_build
-
-CONFLICTS= lyx-1.4.*
-
-EXTRACT_AFTER_ARGS=| ${TAR} -xf - --exclude ${PORTNAME}-${PORTVERSION}/intl/*.[ch] \
- --exclude ${PORTNAME}-${PORTVERSION}/boost --exclude ${PORTNAME}-${PORTVERSION}/intl
+CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
CONFIGURE_ARGS= --with-frontend=qt4 \
--without-included-boost \
--without-included-gettext \
--with-libiconv-prefix=${LOCALBASE} \
--with-extra-prefix=${LOCALBASE}
-
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
-MAN1= lyx.1 tex2lyx.1 lyxclient.1
-
-post-patch:
- # Removing mention of the bundled boost
- ${REINPLACE_CMD} -e 's, boost/[^ ]*Makefile,,g' -e 's, intl/Makefile,,g' \
- ${WRKSRC}/configure
- ${REINPLACE_CMD} -e 's, intl , ,' ${WRKSRC}/Makefile.in
- ${REINPLACE_CMD} -e 's,detail/nullstream,utils/nullstream,' \
- ${WRKSRC}/src/pch.h ${WRKSRC}/src/support/pch.h \
- ${WRKSRC}/src/support/debugstream.h
- ${REINPLACE_CMD} -e 's,boost/regex\.hpp,boost/cregex.hpp,' \
- ${WRKSRC}/src/support/filetools.cpp
-
-pre-configure:
- # If the installed Boost is 1.34 or later, we must compile
- # with exceptions enabled:
- ${AWK} '/#define BOOST_VERSION / {exit($$NF >= 103400)}' \
- ${LOCALBASE}/include/boost/version.hpp || \
- ${REINPLACE_CMD} -e 's,\(AM_CXXFLAGS="\)-fno-exceptions,\1,' \
- ${WRKSRC}/${CONFIGURE_SCRIPT}
-
-post-configure:
- # Removing explicit linking with -lc
- ${REINPLACE_CMD} -e 's,-lc ,,' ${WRKSRC}/*/Makefile
+ALL_TARGET= -j`${SYSCTL} -n hw.ncpu`
-check test:
- # Running vendor's self-tests (currently known to fail):
- ${GMAKE} -C ${WRKSRC} check
+MAN1= lyx.1 tex2lyx.1 lyxclient.1
-post-install:
- ${LN} -sf ${DATADIR}/images/lyx.xpm ${PREFIX}/share/pixmaps/lyx.xpm
- ${MKDIR} ${PREFIX}/share/applications
- ${INSTALL_DATA} ${FILESDIR}/lyx.desktop \
- ${PREFIX}/share/applications
+LATEST_LINK= lyx15
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/bin/makepsres)
-PLIST_SUB+= PSRES=
-.else
-PLIST_SUB+= PSRES='@comment '
-.endif
-
.if !defined(WITHOUT_AIKSAUR)
LIB_DEPENDS+= Aiksaurus:${PORTSDIR}/textproc/aiksaurus
.else
-CONFIGURE_ARGS+=--without-aiksaurus
+CONFIGURE_ARGS+= --without-aiksaurus
.endif
-.if !defined(WITHOUT_ASPELL)
+.if defined(WITHOUT_ASPELL)
+CONFIGURE_ARGS+= --without-aspell --without-pspell
+.else
LIB_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
CONFIGURE_ARGS+= --with-pspell \
--with-pspell-lib="${LOCALBASE}/lib" \
--with-pspell-include="${LOCALBASE}/include"
-.else
-CONFIGURE_ARGS+=--without-aspell --without-pspell
.endif
-.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
-.else
+.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
.endif
-# includes of qt4 must be found earlier than those of qt3
-CONFIGURE_ENV+= QT4_CORE_CFLAGS="-DQT_SHARED -I${QT_INCDIR}/QtCore \
- -I${QT_INCDIR}" \
- QT4_FRONTEND_CFLAGS="-DQT_SHARED -I${QT_INCDIR}/QtCore \
- -I${QT_INCDIR}/QtGui -I${QT_INCDIR}"
+post-patch:
+ ${REINPLACE_CMD} -e 's|boost/regex\.hpp|boost/cregex.hpp|' \
+ ${WRKSRC}/src/support/filetools.cpp
+
+check test:
+ # Running vendor's self-tests (currently known to fail):
+ ${GMAKE} -C ${WRKSRC} check
+
+post-install:
+ ${LN} -sf ${DATADIR}/images/lyx.xpm ${PREFIX}/share/pixmaps/lyx.xpm
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${FILESDIR}/lyx.desktop \
+ ${PREFIX}/share/applications
.include <bsd.port.post.mk>
diff --git a/print/lyx15/distinfo b/print/lyx15/distinfo
index 0851887d3d9f..dd187ee8d756 100644
--- a/print/lyx15/distinfo
+++ b/print/lyx15/distinfo
@@ -1,3 +1,3 @@
-MD5 (lyx-1.5.5.tar.bz2) = 310bf760e8fdf85c7ad3a19b90ddc91c
-SHA256 (lyx-1.5.5.tar.bz2) = 051e952d206a9b0ca7a4584821ecaa88b6ed5f88a241767d97370932258c7539
-SIZE (lyx-1.5.5.tar.bz2) = 9082787
+MD5 (lyx-1.5.6.tar.bz2) = 69f2eecba80b143554911c8b3d814a0e
+SHA256 (lyx-1.5.6.tar.bz2) = 386c4f3232142386579d48c638a7611301552a59574b2a19a7ab5ee725817d32
+SIZE (lyx-1.5.6.tar.bz2) = 9294565
diff --git a/print/lyx15/pkg-plist b/print/lyx15/pkg-plist
index d39c759f9227..1e60db4a0c35 100644
--- a/print/lyx15/pkg-plist
+++ b/print/lyx15/pkg-plist
@@ -2,29 +2,29 @@ bin/lyx
bin/lyxclient
bin/tex2lyx
share/applications/lyx.desktop
-share/locale/ca/LC_MESSAGES/lyx.mo
-share/locale/cs/LC_MESSAGES/lyx.mo
-share/locale/de/LC_MESSAGES/lyx.mo
-share/locale/es/LC_MESSAGES/lyx.mo
-share/locale/eu/LC_MESSAGES/lyx.mo
-share/locale/fi/LC_MESSAGES/lyx.mo
-share/locale/fr/LC_MESSAGES/lyx.mo
-share/locale/gl/LC_MESSAGES/lyx.mo
-share/locale/he/LC_MESSAGES/lyx.mo
-share/locale/hu/LC_MESSAGES/lyx.mo
-share/locale/it/LC_MESSAGES/lyx.mo
-share/locale/ja/LC_MESSAGES/lyx.mo
-share/locale/ko/LC_MESSAGES/lyx.mo
-share/locale/nb/LC_MESSAGES/lyx.mo
-share/locale/nn/LC_MESSAGES/lyx.mo
-share/locale/pl/LC_MESSAGES/lyx.mo
-share/locale/pt/LC_MESSAGES/lyx.mo
-share/locale/ro/LC_MESSAGES/lyx.mo
-share/locale/ru/LC_MESSAGES/lyx.mo
-share/locale/tr/LC_MESSAGES/lyx.mo
-share/locale/zh_CN/LC_MESSAGES/lyx.mo
-share/locale/zh_TW/LC_MESSAGES/lyx.mo
-share/pixmaps/lyx.xpm
+%%NLS%%share/locale/ca/LC_MESSAGES/lyx.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/lyx.mo
+%%NLS%%share/locale/de/LC_MESSAGES/lyx.mo
+%%NLS%%share/locale/es/LC_MESSAGES/lyx.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/lyx.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/lyx.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/lyx.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/lyx.mo
+%%NLS%%share/locale/he/LC_MESSAGES/lyx.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/lyx.mo
+%%NLS%%share/locale/it/LC_MESSAGES/lyx.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/lyx.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/lyx.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/lyx.mo
+%%NLS%%share/locale/nn/LC_MESSAGES/lyx.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/lyx.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/lyx.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/lyx.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/lyx.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/lyx.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/lyx.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/lyx.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/lyx.mo
%%DATADIR%%/CREDITS
%%DATADIR%%/bind/aqua.bind
%%DATADIR%%/bind/broadway.bind
@@ -270,7 +270,6 @@ share/pixmaps/lyx.xpm
%%DATADIR%%/examples/es/ItemizeBullets.lyx
%%DATADIR%%/examples/es/ejemplo_con_lyx.lyx
%%DATADIR%%/examples/es/ejemplo_sin_lyx.lyx
-%%DATADIR%%/examples/es/mathed.lyx
%%DATADIR%%/examples/es/splash.lyx
%%DATADIR%%/examples/eu/adibide_gordina.lyx
%%DATADIR%%/examples/eu/adibide_lyx-atua.lyx
@@ -415,11 +414,6 @@ share/pixmaps/lyx.xpm
%%DATADIR%%/images/lyx-quit.xpm
%%DATADIR%%/images/lyx.xpm
%%DATADIR%%/images/marginalnote-insert.xpm
-%%DATADIR%%/images/math-display.xpm
-%%DATADIR%%/images/math-matrix.xpm
-%%DATADIR%%/images/math-mode.xpm
-%%DATADIR%%/images/math-subscript.xpm
-%%DATADIR%%/images/math-superscript.xpm
%%DATADIR%%/images/math/Bbbk.xpm
%%DATADIR%%/images/math/Finv.xpm
%%DATADIR%%/images/math/Game.xpm
@@ -912,6 +906,11 @@ share/pixmaps/lyx.xpm
%%DATADIR%%/images/math/xi.xpm
%%DATADIR%%/images/math/xi2.xpm
%%DATADIR%%/images/math/zeta.xpm
+%%DATADIR%%/images/math-display.xpm
+%%DATADIR%%/images/math-matrix.xpm
+%%DATADIR%%/images/math-mode.xpm
+%%DATADIR%%/images/math-subscript.xpm
+%%DATADIR%%/images/math-superscript.xpm
%%DATADIR%%/images/nomencl-insert.xpm
%%DATADIR%%/images/note-insert.xpm
%%DATADIR%%/images/note-next.xpm
@@ -1019,8 +1018,8 @@ share/pixmaps/lyx.xpm
%%DATADIR%%/layouts/apa.layout
%%DATADIR%%/layouts/arab-article.layout
%%DATADIR%%/layouts/armenian-article.layout
-%%DATADIR%%/layouts/article.layout
%%DATADIR%%/layouts/article-beamer.layout
+%%DATADIR%%/layouts/article.layout
%%DATADIR%%/layouts/beamer.layout
%%DATADIR%%/layouts/book.layout
%%DATADIR%%/layouts/broadway.layout
@@ -1062,6 +1061,7 @@ share/pixmaps/lyx.xpm
%%DATADIR%%/layouts/iopart.layout
%%DATADIR%%/layouts/isprs.layout
%%DATADIR%%/layouts/jgrga.layout
+%%DATADIR%%/layouts/jss.layout
%%DATADIR%%/layouts/kluwer.layout
%%DATADIR%%/layouts/latex8.layout
%%DATADIR%%/layouts/letter.layout
@@ -1222,6 +1222,7 @@ share/pixmaps/lyx.xpm
%%DATADIR%%/symbols
%%DATADIR%%/syntax.default
%%DATADIR%%/templates/IEEEtran.lyx
+%%DATADIR%%/templates/JSS-article.lyx
%%DATADIR%%/templates/README.new_templates
%%DATADIR%%/templates/aa.lyx
%%DATADIR%%/templates/aastex.lyx
@@ -1257,6 +1258,7 @@ share/pixmaps/lyx.xpm
%%DATADIR%%/ui/stdmenus.inc
%%DATADIR%%/ui/stdtoolbars.inc
%%DATADIR%%/unicodesymbols
+share/pixmaps/lyx.xpm
@dirrmtry share/applications
@dirrm %%DATADIR%%/ui
@dirrm %%DATADIR%%/tex