aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-03-25 16:42:56 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-03-25 16:42:56 +0000
commit208b451f015054eef703d52f14ca9eeee1c87fde (patch)
treeb0f73d45a8d690da1d72a654a70ce8e3729f561a /print
parentc933ea3d401c06bd857cd6d706e365eb614c7944 (diff)
downloadports-208b451f015054eef703d52f14ca9eeee1c87fde.tar.gz
ports-208b451f015054eef703d52f14ca9eeee1c87fde.zip
- Fix probing HP PS 8250 printer
PR: ports/127810 Submitted by: Torfinn Ingolfsen <torfinn.ingolfsen@broadpark.no> Approved by: maintainer timeout (5 months)
Notes
Notes: svn path=/head/; revision=230987
Diffstat (limited to 'print')
-rw-r--r--print/hplip/Makefile3
-rw-r--r--print/hplip/files/patch-io-hpmud-musb.c15
-rw-r--r--print/hplip/pkg-descr2
-rw-r--r--print/hplip3/Makefile3
-rw-r--r--print/hplip3/files/patch-io-hpmud-musb.c15
-rw-r--r--print/hplip3/pkg-descr2
6 files changed, 36 insertions, 4 deletions
diff --git a/print/hplip/Makefile b/print/hplip/Makefile
index 6078d44e9e0b..0cea557f6d03 100644
--- a/print/hplip/Makefile
+++ b/print/hplip/Makefile
@@ -7,7 +7,7 @@
PORTNAME= hplip
PORTVERSION= 2.8.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= hplip
@@ -38,6 +38,7 @@ USE_LDCONFIG= yes
USE_GHOSTSCRIPT_RUN= yes
USE_PYTHON= yes
USE_RC_SUBR= hpssd.sh
+MAKE_JOBS_SAFE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
diff --git a/print/hplip/files/patch-io-hpmud-musb.c b/print/hplip/files/patch-io-hpmud-musb.c
new file mode 100644
index 000000000000..0333cdaa0372
--- /dev/null
+++ b/print/hplip/files/patch-io-hpmud-musb.c
@@ -0,0 +1,15 @@
+--- io/hpmud/musb.c.orig 2008-01-23 01:27:15.000000000 +0100
++++ io/hpmud/musb.c 2009-03-25 17:01:30.000000000 +0100
+@@ -123,8 +123,10 @@
+ 0x409, tbuf, sizeof(tbuf), LIBUSB_CONTROL_REQ_TIMEOUT);
+ if (ret==0)
+ {
+- /* This retry is necessary for lj1000 and lj1005. des 12/12/07 */
+- BUG("get_string_descriptor zero result, retrying...");
++ /* This retry is necessary for lj1000 and lj1005. des 12/12/07
++ Also HP Photosmart 42xx seems to suffer transient errors with serial id */
++ BUG("get_string_descriptor error result %d, retrying in 2 secs...", ret);
++ sleep(2);
+ continue;
+ }
+ break;
diff --git a/print/hplip/pkg-descr b/print/hplip/pkg-descr
index 8e13ae2ee74b..3769a3df175a 100644
--- a/print/hplip/pkg-descr
+++ b/print/hplip/pkg-descr
@@ -5,4 +5,4 @@ The HP driver project provides printing support for nearly
1000 printer models, including Deskjet, Officejet, Photosmart,
PSC (Print Scan Copy), Business Inkjet, LaserJet, and LaserJet MFP.
-WWW: http://hplip.sourceforge.net/
+WWW: http://hplipopensource.com/hplip-web/index.html
diff --git a/print/hplip3/Makefile b/print/hplip3/Makefile
index 6078d44e9e0b..0cea557f6d03 100644
--- a/print/hplip3/Makefile
+++ b/print/hplip3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= hplip
PORTVERSION= 2.8.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= hplip
@@ -38,6 +38,7 @@ USE_LDCONFIG= yes
USE_GHOSTSCRIPT_RUN= yes
USE_PYTHON= yes
USE_RC_SUBR= hpssd.sh
+MAKE_JOBS_SAFE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
diff --git a/print/hplip3/files/patch-io-hpmud-musb.c b/print/hplip3/files/patch-io-hpmud-musb.c
new file mode 100644
index 000000000000..0333cdaa0372
--- /dev/null
+++ b/print/hplip3/files/patch-io-hpmud-musb.c
@@ -0,0 +1,15 @@
+--- io/hpmud/musb.c.orig 2008-01-23 01:27:15.000000000 +0100
++++ io/hpmud/musb.c 2009-03-25 17:01:30.000000000 +0100
+@@ -123,8 +123,10 @@
+ 0x409, tbuf, sizeof(tbuf), LIBUSB_CONTROL_REQ_TIMEOUT);
+ if (ret==0)
+ {
+- /* This retry is necessary for lj1000 and lj1005. des 12/12/07 */
+- BUG("get_string_descriptor zero result, retrying...");
++ /* This retry is necessary for lj1000 and lj1005. des 12/12/07
++ Also HP Photosmart 42xx seems to suffer transient errors with serial id */
++ BUG("get_string_descriptor error result %d, retrying in 2 secs...", ret);
++ sleep(2);
+ continue;
+ }
+ break;
diff --git a/print/hplip3/pkg-descr b/print/hplip3/pkg-descr
index 8e13ae2ee74b..3769a3df175a 100644
--- a/print/hplip3/pkg-descr
+++ b/print/hplip3/pkg-descr
@@ -5,4 +5,4 @@ The HP driver project provides printing support for nearly
1000 printer models, including Deskjet, Officejet, Photosmart,
PSC (Print Scan Copy), Business Inkjet, LaserJet, and LaserJet MFP.
-WWW: http://hplip.sourceforge.net/
+WWW: http://hplipopensource.com/hplip-web/index.html