aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-04-10 08:30:54 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-04-10 08:30:54 +0000
commit66a8eb459a493bb76aa62d81129f88cc9743fc1a (patch)
treea75e081c90c5a146865367c1ced0742f06765112 /print
parentc062e6bbdc01a3f5e3ae633ac3af54f9ebe34ece (diff)
downloadports-66a8eb459a493bb76aa62d81129f88cc9743fc1a.tar.gz
ports-66a8eb459a493bb76aa62d81129f88cc9743fc1a.zip
- Fix build by linking to a shared lcms library instead of static one.
- Link with the shared version of jbig library. Reported by: pav
Notes
Notes: svn path=/head/; revision=231998
Diffstat (limited to 'print')
-rw-r--r--print/cups-magicolor/files/patch-configure.in28
1 files changed, 26 insertions, 2 deletions
diff --git a/print/cups-magicolor/files/patch-configure.in b/print/cups-magicolor/files/patch-configure.in
index bf241fcd7bc6..a0840917e01f 100644
--- a/print/cups-magicolor/files/patch-configure.in
+++ b/print/cups-magicolor/files/patch-configure.in
@@ -1,5 +1,5 @@
---- configure.in.orig Tue May 31 15:46:41 2005
-+++ configure.in Tue Dec 5 09:28:21 2006
+--- configure.in.orig 2005-06-01 02:46:41.000000000 +0400
++++ configure.in 2009-04-10 12:28:59.000000000 +0400
@@ -35,7 +35,7 @@
#filterdir=/usr/lib/cups/filter
@@ -9,3 +9,27 @@
AC_SUBST(KM_PPDDIR)
UNAME=`(uname) 2>/dev/null || echo unknown`
+@@ -74,20 +74,12 @@
+ AC_CHECK_LIB(cups, ppdOpenFile)
+ AC_CHECK_LIB([cupsimage], [cupsRasterReadHeader])
+ AC_CHECK_LIB([jbig], [jbg_enc_init],
+-if test -f "/usr/lib/libjbig.a"; then
+- LIBJBIG="/usr/lib/libjbig.a"
+-else
+- LIBJBIG="/usr/local/lib/libjbig.a"
+-fi,
++LIBJBIG="-ljbig",
+ [AC_MSG_ERROR([Could not find libjbig.a])])
+ AC_SUBST(LIBJBIG)
+ AC_CHECK_LIB([lcms], [cmsCreateTransform],
+-if test -f "/usr/lib/liblcms.a"; then
+- LIBLCMS="/usr/lib/liblcms.a"
+-else
+- LIBLCMS="/usr/local/lib/liblcms.a"
+-fi,
+-[AC_MSG_ERROR([Could not find liblcms.a])])
++LIBLCMS="-llcms",
++[AC_MSG_ERROR([Could not find liblcms])])
+ AC_SUBST(LIBLCMS)
+
+ # Checks for header files.