aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2007-09-08 01:12:10 +0000
committerMark Linimon <linimon@FreeBSD.org>2007-09-08 01:12:10 +0000
commit9839011ec3910790376ce9ace5e2a1c5bcb2781f (patch)
tree41c61966bf1404bd3cfce06493a35d6a1a4acfc6 /print
parent41a56135d1e8a68844e4c575702cdbad451d7322 (diff)
downloadports-9839011ec3910790376ce9ace5e2a1c5bcb2781f.tar.gz
ports-9839011ec3910790376ce9ace5e2a1c5bcb2781f.zip
Welcome bsd.perl.mk. Add support for constructs such as USE_PERL5=5.8.0+.
Drop support for antique perl. Work done by: gabor Sponsored by: Google Summer of Code 2007 Hat: portmgr
Notes
Notes: svn path=/head/; revision=199069
Diffstat (limited to 'print')
-rw-r--r--print/a2pdf/Makefile1
-rw-r--r--print/axpoint/Makefile1
-rw-r--r--print/latexdiff/Makefile8
-rw-r--r--print/muttprint/Makefile2
-rw-r--r--print/p5-Net-Printer/Makefile8
-rw-r--r--print/p5-PDFLib/Makefile9
-rw-r--r--print/p5-XML-ApacheFOP/Makefile8
7 files changed, 6 insertions, 31 deletions
diff --git a/print/a2pdf/Makefile b/print/a2pdf/Makefile
index 6e34488ab2c3..cd73db165442 100644
--- a/print/a2pdf/Makefile
+++ b/print/a2pdf/Makefile
@@ -19,7 +19,6 @@ BUILD_DEPENDS= p5-PDF-API2>=0:${PORTSDIR}/textproc/p5-PDF-API2 \
p5-File-Type>=0:${PORTSDIR}/devel/p5-File-Type
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PERL5= yes
PERL_CONFIGURE= yes
MAN1= ${PORTNAME}.1
diff --git a/print/axpoint/Makefile b/print/axpoint/Makefile
index 691f6b09961d..830b7b212123 100644
--- a/print/axpoint/Makefile
+++ b/print/axpoint/Makefile
@@ -24,7 +24,6 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Text/Iconv.pm:${PORTSDIR}/converters/p5
p5-PDFLib>=0.14:${PORTSDIR}/print/p5-PDFLib
RUN_DEPENDS= ${BUILD_DEPENDS}
-USE_PERL5= yes
PERL_CONFIGURE= yes
MAN3= XML::Handler::AxPoint.3
diff --git a/print/latexdiff/Makefile b/print/latexdiff/Makefile
index 582fbab8c0a9..323f90796212 100644
--- a/print/latexdiff/Makefile
+++ b/print/latexdiff/Makefile
@@ -28,13 +28,7 @@ PLIST_FILES= bin/latexdiff \
bin/latexdiff-so \
bin/latexrevise
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.6 or above. Please use the lang/perl port to install it
-.endif
-
do-build:
# empty
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/muttprint/Makefile b/print/muttprint/Makefile
index 803d0a90e01e..0915525bb8e8 100644
--- a/print/muttprint/Makefile
+++ b/print/muttprint/Makefile
@@ -15,6 +15,8 @@ MASTER_SITE_SUBDIR= muttprint
MAINTAINER?= obraun@FreeBSD.org
COMMENT?= Utility to print mail for most any mail client
+USE_PERL5= yes
+
.if !defined(PAPERSIZE)
PAPERSIZE= letter
.endif
diff --git a/print/p5-Net-Printer/Makefile b/print/p5-Net-Printer/Makefile
index a31c9f847c9e..66e57fedba48 100644
--- a/print/p5-Net-Printer/Makefile
+++ b/print/p5-Net-Printer/Makefile
@@ -19,10 +19,4 @@ PERL_CONFIGURE= yes
MAN3= Net::Printer.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.6.x or later. Install lang/perl5 then try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/p5-PDFLib/Makefile b/print/p5-PDFLib/Makefile
index babb714159bf..74c569954569 100644
--- a/print/p5-PDFLib/Makefile
+++ b/print/p5-PDFLib/Makefile
@@ -19,16 +19,9 @@ COMMENT= More OO interface to pdflib_pl.pm
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/pdflib_pl.pm:${PORTSDIR}/print/pdflib-perl
RUN_DEPENDS= ${BUILD_DEPENDS}
-USE_PERL5= yes
PERL_CONFIGURE= yes
NO_BUILD= yes
MAN3= PDFLib.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/p5-XML-ApacheFOP/Makefile b/print/p5-XML-ApacheFOP/Makefile
index afdbc498d644..89487310f04e 100644
--- a/print/p5-XML-ApacheFOP/Makefile
+++ b/print/p5-XML-ApacheFOP/Makefile
@@ -24,11 +24,5 @@ PERL_CONFIGURE= yes
MAN3= XML::ApacheFOP.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>