aboutsummaryrefslogtreecommitdiff
path: root/russian/apache13-modssl/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-07-16 20:09:51 +0000
committerSteve Price <steve@FreeBSD.org>2000-07-16 20:09:51 +0000
commit676d035daf3b9477890ecfddd6ec343c7e7afab2 (patch)
tree0df285a008e667fd0acc6e7d611fd6b3c5166be7 /russian/apache13-modssl/Makefile
parent6ec75e7f8e2bf00adf3334c7c84b7c9572f7526b (diff)
downloadports-676d035daf3b9477890ecfddd6ec343c7e7afab2.tar.gz
ports-676d035daf3b9477890ecfddd6ec343c7e7afab2.zip
Adding ru-apache13 with modssl support.
PR: 19752 Submitted by: Dmitry S. Sivachenko <dima@Chg.RU>
Notes
Notes: svn path=/head/; revision=30721
Diffstat (limited to 'russian/apache13-modssl/Makefile')
-rw-r--r--russian/apache13-modssl/Makefile120
1 files changed, 120 insertions, 0 deletions
diff --git a/russian/apache13-modssl/Makefile b/russian/apache13-modssl/Makefile
new file mode 100644
index 000000000000..7826a97c8e2e
--- /dev/null
+++ b/russian/apache13-modssl/Makefile
@@ -0,0 +1,120 @@
+# New ports collection makefile for: Russian Apache + mod_ssl
+# Date created: 7 July 2000 1:05 MSD
+# Whom: Dmitry Sivachenko <dima@Chg.RU>
+#
+# $FreeBSD$
+#
+
+PORTNAME= apache+mod_ssl
+PORTVERSION= ${VERSION_APACHE}+${RA_VERSION}+${VERSION_MODSSL}
+CATEGORIES= russian www security
+MASTER_SITES= ftp://ftp.lexa.ru/pub/apache-rus/ \
+ ftp://ftp.lexa.ru/pub/apache-rus/old-versions/ \
+ http://www.modssl.org/source/ \
+ ftp://ftp.modssl.org/source/ \
+ ftp://ftp.pca.dfn.de/pub/tools/net/mod_ssl/ \
+ ftp://ftp.ecrc.net/pub/security/mod_ssl/ \
+ ftp://ftp.nvg.ntnu.no/pub/unix/mod_ssl/ \
+ ftp://ftp.ulpgc.es/pub/mod_ssl/ \
+ ftp://glock.missouri.edu/pub/mod_ssl/ \
+ ftp://ftp.fu-berlin.de/unix/security/mod_ssl/ \
+ ftp://ftp.ntrl.net/pub/mirror/ralfsw/mod_ssl/
+DISTNAME= apache_${VERSION_APACHE}rusPL${RA_VERSION}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ mod_ssl-${VERSION_MODSSL}-${VERSION_APACHE}${EXTRACT_SUFX}
+
+MAINTAINER= dima@Chg.RU
+
+BUILD_DEPENDS= mm-config:${PORTSDIR}/devel/mm \
+ ${LOCALBASE}/lib/libmm.a:${PORTSDIR}/devel/mm
+
+USE_OPENSSL= RSA
+
+.include <bsd.port.pre.mk>
+
+VERSION_APACHE= 1.3.12
+VERSION_MODSSL= 2.6.5
+RA_VERSION= 29.4
+
+USE_PERL5= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --server-gid=nogroup \
+ --with-perl=${PERL} \
+ --with-layout=${FILESDIR}/FreeBSD.layout:FreeBSD \
+ --without-confadjust \
+ --enable-module=ssl \
+ --enable-module=most \
+ --enable-module=auth_db \
+ --disable-module=auth_dbm \
+ --enable-shared=max
+
+OPTIM= -DHARD_SERVER_LIMIT=512 \
+ -DDOCUMENT_LOCATION=\\"${PREFIX}/www/data/\\" \
+ -DDEFAULT_PATH=\\"/bin:/usr/bin:${PREFIX}/bin\\"
+
+pre-extract:
+.if defined(WITH_SUEXEC)
+ @${ECHO} "Be sure to edit suexec specific arguments to configure in the Makefile."
+CONFIGURE_ARGS+=--enable-suexec \
+ --suexec-caller=nobody \
+ --suexec-docroot=${PREFIX}/www/data \
+ --suexec-logfile=/var/log/suexec.log \
+ --suexec-uidmin=50000 \
+ --suexec-gidmin=60000
+MAN8+= suexec.8
+PLIST_SUB= SUEXEC=sbin/suexec
+.else
+ @${ECHO} "Define WITH_SUEXEC to build with suexec support."
+PLIST_SUB= SUEXEC=
+.endif
+
+.if defined(APACHE_PERF_TUNING) && ${APACHE_PERF_TUNING} == YES
+OPTIM+= -DBUFFERED_LOGS -DFD_SETSIZE=1024
+CFLAGS+= -O6 -funroll-loops -fstrength-reduce -fomit-frame-pointer \
+ -fexpensive-optimizations -ffast-math
+.endif
+
+CONFIGURE_ENV= CFLAGS='${CFLAGS}' \
+ OPTIM='${OPTIM}' \
+ SSL_BASE='SYSTEM' \
+ EAPI_MM='SYSTEM' \
+ PATH="${PREFIX}/bin:${PATH}"
+
+INSTALL_TARGET= install-quiet
+
+MAN1= dbmmanage.1 htdigest.1 htpasswd.1
+MAN8+= ab.8 apachectl.8 apxs.8 httpd.8 logresolve.8 rotatelogs.8
+
+TYPE= test
+CRT=
+KEY=
+
+pre-patch:
+ @cd ${WRKDIR}/mod_ssl-${VERSION_MODSSL}-${VERSION_APACHE} \
+ && ${ECHO_MSG} "===> Applying mod_ssl-${VERSION_MODSSL} extension" \
+ && ./configure --with-apache=../${DISTNAME} --expert
+
+post-patch:
+ @cd ${WRKSRC} \
+ && find . -type f -name "*.orig" -print | xargs ${RM} -f
+
+post-build:
+ @cd ${WRKSRC} \
+ && ${ECHO_MSG} "===> Creating Dummy Certificate for Server (SnakeOil)" \
+ && ${ECHO_MSG} " [use 'make certificate' to create a real one]" \
+ && ${MAKE} certificate TYPE=dummy >/dev/null 2>&1
+
+certificate:
+ @cd ${WRKSRC} \
+ && ${ECHO_MSG} "===> Creating Test Certificate for Server" \
+ && ${MAKE} certificate TYPE=${TYPE} CRT=${CRT} KEY=${KEY}
+
+post-install:
+ @if [ ! -f ${PREFIX}/etc/rc.d/apache.sh ]; then \
+ ${ECHO} "Installing ${PREFIX}/etc/rc.d/apache.sh startup file."; \
+ ${SED} -e "s#!!PREFIX!!#${PREFIX}#g" < ${FILESDIR}/rc.apache.sh > ${PREFIX}/etc/rc.d/apache.sh; \
+ ${CHMOD} 751 ${PREFIX}/etc/rc.d/apache.sh; \
+ fi
+
+.include <bsd.port.post.mk>