aboutsummaryrefslogtreecommitdiff
path: root/science/cdo
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-07-16 06:12:30 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-07-16 06:12:30 +0000
commitfc8fecf250052e2b00458c4b676027f1f9da4db0 (patch)
treef4f547cd73bafaad1dc1dbb278073d3262ab4ef3 /science/cdo
parent44e3305c58e6c6f3305611e8dc41204a2e28e9c8 (diff)
downloadports-fc8fecf250052e2b00458c4b676027f1f9da4db0.tar.gz
ports-fc8fecf250052e2b00458c4b676027f1f9da4db0.zip
- Update to 1.5.1
- Use CFLAGS instead of CPPFLAGS - Remove out-dated OSVERSION check and pkg-message - Make portlint happier - Cosmetic change Changes: https://code.zmaw.de/news/68
Notes
Notes: svn path=/head/; revision=277794
Diffstat (limited to 'science/cdo')
-rw-r--r--science/cdo/Makefile58
-rw-r--r--science/cdo/distinfo4
-rw-r--r--science/cdo/pkg-message8
-rw-r--r--science/cdo/pkg-plist10
4 files changed, 41 insertions, 39 deletions
diff --git a/science/cdo/Makefile b/science/cdo/Makefile
index 4f843c56770a..75282dfbf412 100644
--- a/science/cdo/Makefile
+++ b/science/cdo/Makefile
@@ -6,39 +6,34 @@
#
PORTNAME= cdo
-PORTVERSION= 1.5.0
-PORTREVISION= 1
+PORTVERSION= 1.5.1
CATEGORIES= science
-MASTER_SITES= https://code.zmaw.de/attachments/download/898/ \
+MASTER_SITES= https://code.zmaw.de/attachments/download/1531/ \
LOCAL/sunpoet
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Climate Data Operators
-GNU_CONFIGURE= yes
-
-CONFIGURE_ARGS= --program-transform-name=""
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-
-PLIST_FILES= bin/cdo
-
-NETCDF_VER?= 4
-HDF5_VER?= 18
-
OPTIONS= HDF5 "HDF5 support" on \
JASPER "Japser support" off \
NETCDF "NetCDF support" on \
PROJ "PROJ support" on \
SZIP "SZIP support" on
-.include <bsd.port.pre.mk>
+CFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+CONFIGURE_ARGS= --enable-cdi-lib --program-transform-name="" --with-zlib=/usr
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
+GNU_CONFIGURE= yes
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+USE_GNOME= gnomehack
+USE_LDCONFIG= yes
-.if (${OSVERSION} >= 700000) || (${ARCH} != "sparc64")
-CONFIGURE_ENV+= CFLAGS="${CFLAGS} -DPTHREAD_MUTEXATTR_CONDATTR"
-.endif
+NETCDF_VER?= 4
+HDF5_VER?= 18
+
+.include <bsd.port.options.mk>
-.if (!defined(WITHOUT_NETCDF) && !defined(WITHOUT_HDF5) && (${NETCDF_VER} == 4) && (${HDF5_VER} == 16))
+.if !defined(WITHOUT_NETCDF) && !defined(WITHOUT_HDF5) && ${NETCDF_VER} == 4 && ${HDF5_VER} == 16
IGNORE= netCDF 4 requires HDF5 1.8
.endif
@@ -48,7 +43,7 @@ WITH_HDF5= yes
.endif
.if !defined(WITHOUT_HDF5)
-CONFIGURE_ARGS+=--with-hdf5=${LOCALBASE} --with-zlib=/usr
+CONFIGURE_ARGS+=--with-hdf5=${LOCALBASE}
WITH_SZIP= yes
.if (${HDF5_VER} == 18)
LIB_DEPENDS+= hdf5.7:${PORTSDIR}/science/hdf5-18
@@ -69,7 +64,9 @@ LIB_DEPENDS+= netcdf.7:${PORTSDIR}/science/netcdf4
.else
LIB_DEPENDS+= netcdf.4:${PORTSDIR}/science/netcdf
.endif
-PLIST_FILES+= bin/cdotest
+PLIST_SUB= NETCDF=""
+.else
+PLIST_SUB= NETCDF="@comment "
.endif
.if !defined(WITHOUT_PROJ)
@@ -82,23 +79,26 @@ CONFIGURE_ARGS+=--with-szlib=${LOCALBASE}
LIB_DEPENDS+= sz.2:${PORTSDIR}/science/szip
.endif
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "sparc64"
+CFLAGS+= -DPTHREAD_MUTEXATTR_CONDATTR
+.endif
+
post-patch:
.if !defined(WITHOUT_NETCDF)
- ${REINPLACE_CMD} \
- -e '/bin_PROGRAMS = / s|$$| cdotest$$(EXEEXT)|' \
- -e '/noinst_PROGRAMS = / s| cdotest$$(EXEEXT)||' \
+ @${REINPLACE_CMD} \
+ -e '/bin_PROGRAMS = / s|$$| cdotest|' \
+ -e '/noinst_PROGRAMS = / s| cdotest||' \
${WRKSRC}/src/Makefile.in
.endif
post-build:
.if !defined(WITHOUT_NETCDF)
- @cd "${WRKSRC}/src" && ${SETENV} CDO_PATH="${WRKSRC}/src/cdo" "${WRKSRC}/src/cdotest"
+ @cd ${WRKSRC}/src/ && ${SETENV} CDO_PATH=${WRKSRC}/src/cdo ${WRKSRC}/src/cdotest
.endif
-post-install:
- @${CAT} ${PKGMESSAGE}
-
regression-test:
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
+ @cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE} check
.include <bsd.port.post.mk>
diff --git a/science/cdo/distinfo b/science/cdo/distinfo
index 5199479fb6c0..716e5db173b5 100644
--- a/science/cdo/distinfo
+++ b/science/cdo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cdo-1.5.0.tar.gz) = efcb78a5f9f171a86715fee28da99882c2547bbef4cfc4bffa11b257708ad4be
-SIZE (cdo-1.5.0.tar.gz) = 5211816
+SHA256 (cdo-1.5.1.tar.gz) = 07da9b78cef381e73abb4841a8df5dab4691fa26616a1910f1e56273ce0a184e
+SIZE (cdo-1.5.1.tar.gz) = 5380011
diff --git a/science/cdo/pkg-message b/science/cdo/pkg-message
deleted file mode 100644
index 3b9ecf0c250f..000000000000
--- a/science/cdo/pkg-message
+++ /dev/null
@@ -1,8 +0,0 @@
-Since CDO version 1.0.6, three new environment variables were introduced:
-- CDO_DISABLE_HISTORY:
- If set to 1, the netCDF history attribute of input datasets is not used.
-- CDO_DISABLE_FILESUFFIX:
- If set to 1, file suffix (.grb, .nc, ...) will not be added to the output
- file name of split*.
-- IGNORE_ATT_COORDINATES:
- If set to 1, netCDF variable attribute "coordinates" will be ignored.
diff --git a/science/cdo/pkg-plist b/science/cdo/pkg-plist
new file mode 100644
index 000000000000..ddcb58794328
--- /dev/null
+++ b/science/cdo/pkg-plist
@@ -0,0 +1,10 @@
+bin/cdi
+bin/cdo
+%%NETCDF%%bin/cdotest
+include/cdi.h
+include/cdi.inc
+lib/libcdi.a
+lib/libcdi.la
+lib/libcdi.so
+lib/libcdi.so.0
+libdata/pkgconfig/cdi.pc