aboutsummaryrefslogtreecommitdiff
path: root/science/felt/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-09-19 21:47:27 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-09-19 21:47:27 +0000
commitf1362de1246505d02eb38a2903fdf09c6fa3f0ba (patch)
tree0b191469dbfb3621a446a2c00d67eb94f8807664 /science/felt/Makefile
parent7b9865c0ea1b7475e9a44b60d4d94d789681cfbd (diff)
downloadports-f1362de1246505d02eb38a2903fdf09c6fa3f0ba.tar.gz
ports-f1362de1246505d02eb38a2903fdf09c6fa3f0ba.zip
Remove superfluous dependencies.
Since I"m there, pet portlint and respect NOPORTDOCS. PR: 84746 Submitted by: Carlos A M dos Santos <casantos (at) urisan.tche.br>
Notes
Notes: svn path=/head/; revision=143180
Diffstat (limited to 'science/felt/Makefile')
-rw-r--r--science/felt/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/science/felt/Makefile b/science/felt/Makefile
index 4d9c311561dd..612690b090e9 100644
--- a/science/felt/Makefile
+++ b/science/felt/Makefile
@@ -7,6 +7,7 @@
PORTNAME= felt
PORTVERSION= 3.06
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= felt
@@ -15,9 +16,6 @@ EXTRACT_SUFX= -devel.src.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= A system for Finite Element Analysis
-LIB_DEPENDS= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d \
- Xm.3:${PORTSDIR}/x11-toolkits/open-motif
-
USE_X_PREFIX= yes
USE_GL= yes
USE_REINPLACE= yes
@@ -28,6 +26,9 @@ MAN1= burlap.1 corduroy.1 felt.1 patchwork.1 velvet.1 yardstick.1
MAN3= Drawing.3
MAN4= corduroy.4 felt.4
+DOCSDIR= ${PREFIX}/share/doc/FElt
+EXAMPLESDIR= ${PREFIX}/share/examples/FElt
+
post-patch:
@${REINPLACE_CMD} -e 's,<malloc.h>,<stdlib.h>, ; s,"malloc.h",<stdlib.h>,' \
${WRKSRC}/lib/Felt/parser.c \
@@ -41,9 +42,11 @@ post-patch:
${WRKSRC}/src/Patchwork/util.c
post-install:
- ${MKDIR} ${PREFIX}/share/examples/FElt
- ${CP} ${WRKSRC}/examples/* ${PREFIX}/share/examples/FElt
- ${MKDIR} ${PREFIX}/share/doc/FElt
- ${CP} ${WRKSRC}/*.html ${PREFIX}/share/doc/FElt
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${CP} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+ ${MKDIR} ${DOCSDIR}
+ ${CP} ${WRKSRC}/*.html ${DOCSDIR}
+.endif
.include <bsd.port.mk>