aboutsummaryrefslogtreecommitdiff
path: root/science/hs-bio/Makefile
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2010-05-12 16:33:59 +0000
committerGabor Pali <pgj@FreeBSD.org>2010-05-12 16:33:59 +0000
commitec29a59ec3d0472e808e9907b2f18dce2e9fe68c (patch)
treebd2ff04188a74e09a51bfecae86236b3684491e5 /science/hs-bio/Makefile
parentba00ef6b8cc071eb53bf9287bfbc328da82f7eb8 (diff)
downloadports-ec29a59ec3d0472e808e9907b2f18dce2e9fe68c.tar.gz
ports-ec29a59ec3d0472e808e9907b2f18dce2e9fe68c.zip
Introduce a new (and hopefully better) ports infrastructure for Haskell Cabal
ports which makes possible the direct translation of Cabal package descriptions to FreeBSD ports. It promises both easier addition and maintenance for Cabal-based ports.
Notes
Notes: svn path=/head/; revision=254209
Diffstat (limited to 'science/hs-bio/Makefile')
-rw-r--r--science/hs-bio/Makefile72
1 files changed, 3 insertions, 69 deletions
diff --git a/science/hs-bio/Makefile b/science/hs-bio/Makefile
index 5544cfabd58f..bab8f9f710f5 100644
--- a/science/hs-bio/Makefile
+++ b/science/hs-bio/Makefile
@@ -8,80 +8,14 @@
PORTNAME= bio
PORTVERSION= 0.4
CATEGORIES= science haskell
-MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
-PKGNAMEPREFIX= hs-
MAINTAINER= jacula@gmail.com
COMMENT= A Haskell bioinformatics library
-BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
- hs-tagsoup>=0.4:${PORTSDIR}/textproc/hs-tagsoup \
- hs-binary-ghc>=0.5.0.2:${PORTSDIR}/devel/hs-binary-ghc
-RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
- hs-tagsoup>=0.4:${PORTSDIR}/textproc/hs-tagsoup \
- hs-binary-ghc>=0.5.0.2:${PORTSDIR}/devel/hs-binary-ghc
+CABAL_SETUP= Setup.hs
+USE_HACKAGE= binary tagsoup>=0.4
-GHC_VERSION= 6.10.4
-BIO_VERSION= ${PORTVERSION}
-
-GHC_CMD= ${LOCALBASE}/bin/ghc
-SETUP_CMD= ./setup
-
-DATADIR= ${PREFIX}/share/${DISTNAME}
PORTDATA= *
-DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
-BIO_LIBDIR_REL= lib/${DISTNAME}
-
-PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
- BIO_VERSION=${BIO_VERSION} \
- BIO_LIBDIR_REL=${BIO_LIBDIR_REL}
-
-.if defined(NOPORTDOCS)
-PLIST_SUB+= NOPORTDOCS=""
-.else
-PLIST_SUB+= NOPORTDOCS="@comment "
-.endif
-
-.if !defined(NOPORTDOCS)
-
-PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
-.if !empty(PORT_HADDOCK:M?0)
-BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
-.endif
-BUILD_DEPENDS+= HsColour:${PORTSDIR}/print/hs-hscolour
-
-HSCOLOUR_VERSION= 1.15
-HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
-
-PORTDOCS= *
-.endif
-
-.SILENT:
-
-do-configure:
- cd ${WRKSRC} && ${GHC_CMD} --make Setup.hs -o setup -package Cabal
-.if !defined(NOPORTDATA)
- cd ${WRKSRC} && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX}
-.else
- cd ${WRKSRC} && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX} \
- --datadir='' --datasubdir='' --docdir='${DOCSDIR}'
-.endif
-
-do-build:
- cd ${WRKSRC} && ${SETUP_CMD} build \
- && ${SETUP_CMD} register --gen-script
-
-.if !defined(NOPORTDOCS)
- cd ${WRKSRC} && ${SETUP_CMD} haddock --hyperlink-source \
- --hscolour-css=${HSCOLOUR_DATADIR}/hscolour.css
-.endif
-
-do-install:
- cd ${WRKSRC} && ${SETUP_CMD} install \
- && ${INSTALL_SCRIPT} register.sh ${PREFIX}/${BIO_LIBDIR_REL}/register.sh
-
-post-install:
- ${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
-
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>