aboutsummaryrefslogtreecommitdiff
path: root/science/liblinear
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-07-28 07:09:40 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-07-28 07:09:40 +0000
commita649a6476d929144d73b7618e1a61e83330ffdd0 (patch)
tree3389607cd7db0f0a08223f593778f9ba8ba3d7dc /science/liblinear
parentabc16cfaf60b8e69cd676b7163f66924d3aaea35 (diff)
downloadports-a649a6476d929144d73b7618e1a61e83330ffdd0.tar.gz
ports-a649a6476d929144d73b7618e1a61e83330ffdd0.zip
- Update to 1.1
- LIBLR is renamed to LIBLINEAR - Update pkg-descr - Drop deprecated TARGETDIR variable
Notes
Notes: svn path=/head/; revision=196440
Diffstat (limited to 'science/liblinear')
-rw-r--r--science/liblinear/Makefile19
-rw-r--r--science/liblinear/distinfo6
-rw-r--r--science/liblinear/pkg-descr11
3 files changed, 19 insertions, 17 deletions
diff --git a/science/liblinear/Makefile b/science/liblinear/Makefile
index 5b83bd02b798..9caeb09f5885 100644
--- a/science/liblinear/Makefile
+++ b/science/liblinear/Makefile
@@ -5,20 +5,21 @@
# $FreeBSD$
#
-PORTNAME= liblr
-PORTVERSION= 1.00
+PORTNAME= liblinear
+PORTVERSION= 1.10
CATEGORIES= science math
-MASTER_SITES= http://www.csie.ntu.edu.tw/~cjlin/liblinear/oldfiles/
+MASTER_SITES= http://www.csie.ntu.edu.tw/~cjlin/liblinear/ \
+ http://www.csie.ntu.edu.tw/~cjlin/liblinear/oldfiles/
DISTNAME= ${PORTNAME}-${PORTVERSION:C/0$//}
MAINTAINER= rafan@FreeBSD.org
-COMMENT= A library for Large Regularized Logistic Regression
+COMMENT= A library for Large Linear Classification
OPTIONS= OCFLAGS "Use optimized CFLAGS" On
USE_ZIP= yes
-MAKE_ENV= CC="${CC}" CXXC="${CXX}"
+MAKE_ENV= CC="${CC}" CXX="${CXX}"
TXT_DOCS= COPYRIGHT README
@@ -26,18 +27,18 @@ TXT_DOCS= COPYRIGHT README
PORTDOCS= ${TXT_DOCS}
.endif
-PLIST_FILES= bin/lr-train bin/lr-predict
+PLIST_FILES= bin/train bin/predict
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_OCFLAGS)
-# same as LIBIR itself
+# same as LIBLINEAR itself
CFLAGS= -Wall -O3
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/lr-train ${TARGETDIR}/bin/
- ${INSTALL_PROGRAM} ${WRKSRC}/lr-predict ${TARGETDIR}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/train ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/predict ${PREFIX}/bin
post-install:
.if !defined(NOPORTDOCS)
diff --git a/science/liblinear/distinfo b/science/liblinear/distinfo
index 6f6dff9396e7..db96c5b49ded 100644
--- a/science/liblinear/distinfo
+++ b/science/liblinear/distinfo
@@ -1,3 +1,3 @@
-MD5 (liblr-1.0.zip) = 6407b44f889c1465df341d5242f30480
-SHA256 (liblr-1.0.zip) = 1435e9dd96f9723872dc624d0ea3a12b0b6ab5d7240f41765c3fd69677bcbed3
-SIZE (liblr-1.0.zip) = 153199
+MD5 (liblinear-1.1.zip) = 72d650983942c19b53e0ee683da4da64
+SHA256 (liblinear-1.1.zip) = 6a2e221befad0f16b32971144fb243373cf4614689aeefd8c83765039b3e0e1d
+SIZE (liblinear-1.1.zip) = 183990
diff --git a/science/liblinear/pkg-descr b/science/liblinear/pkg-descr
index 572349efc4bf..e9f2edc6176d 100644
--- a/science/liblinear/pkg-descr
+++ b/science/liblinear/pkg-descr
@@ -1,16 +1,17 @@
-LIBLR is a linear classifier for data with millions of instances and
-features. It implement a trust region Newton method in
+LIBLINEAR is a linear classifier for data with millions of instances and
+features. It supports both logistic regression and L2-loss linear SVM using a
+trust region Newton method in
C.-J. Lin, R. C. Weng, and S. S. Keerthi. Trust region Newton method
for large-scale regularized logistic regression. Technical report, 2007.
A short version appears in ICML 2007.
-Main features of LIBLR include
+Main features of LIBLINEAR include
Same data format as LIBSVM and similar usage
One-vs-the rest multi-class classification
Cross validation for model selection
-Probability estimates
+Probability estimates (logistic regression only)
Weights for unbalanced data
-WWW: http://www.csie.ntu.edu.tw/~cjlin/liblr/
+WWW: http://www.csie.ntu.edu.tw/~cjlin/liblinear/