aboutsummaryrefslogtreecommitdiff
path: root/science/mpqc/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-16 06:44:55 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-16 06:44:55 +0000
commit5be21f25be9b67c709c2ba9ef94cbbf7c19f530e (patch)
treee97b98006d9c140432015dff518ee037345cfcd7 /science/mpqc/Makefile
parenta8b169aebc03a5d32143d554ef1aff9a02e48adf (diff)
downloadports-5be21f25be9b67c709c2ba9ef94cbbf7c19f530e.tar.gz
ports-5be21f25be9b67c709c2ba9ef94cbbf7c19f530e.zip
fix broken and make some enhancement
1. using math/atlas(added lapack, blas flags for other choices of lapack, blas package) It improves the performance for few percent. 2. override CFLAGS, FFLAGS for C++, C, FORTRAN compiler 3. override CC, F77, C++ for other choices of C++, C, FORTRAN compiler 4. support for parallel computing using MPI. pass maintainership to submitter PR: 40631 Submitted by: Nakata Maho <chat95@mbox.kyoto-inet.or.jp> (new maintainer) No Response from: original maintainer (mail bounce)
Notes
Notes: svn path=/head/; revision=63070
Diffstat (limited to 'science/mpqc/Makefile')
-rw-r--r--science/mpqc/Makefile21
1 files changed, 14 insertions, 7 deletions
diff --git a/science/mpqc/Makefile b/science/mpqc/Makefile
index 0280e5c08764..b1124e3d2ccd 100644
--- a/science/mpqc/Makefile
+++ b/science/mpqc/Makefile
@@ -10,19 +10,26 @@ PORTVERSION= 2.1.1
CATEGORIES= science
MASTER_SITES= http://aros.ca.sandia.gov/~cljanss/mpqc/distrib/
-MAINTAINER= batman@udel.edu
+MAINTAINER= chat95@mbox.kyoto-inet.or.jp
-LIB_DEPENDS= blas:${PORTSDIR}/math/blas \
- lapack:${PORTSDIR}/math/lapack
+LIB_DEPENDS= lapack:${PORTSDIR}/math/lapack \
+ atlas:${PORTSDIR}/math/atlas
USE_BISON= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libdirs=-L${LOCALBASE}/lib
+USE_AUTOCONF= yes
+CONFIGURE_ARGS= --with-libdirs=-L${PREFIX}/lib \
+ --with-blas="-lf77blas -latlas" \
+ --with-lapack="-lalapack -lcblas" \
+ --with-coptflags="${CFLAGS}" \
+ --with-cxxoptflags="${CFLAGS}" \
+ --with-f77optflags="${FFLAGS}"
USE_PERL5= yes
USE_GMAKE= yes
ALL_TARGET= # empty
-post-patch:
- @${PERL} -pi -e "s,-lpthreads,${PTHREAD_LIBS},g" ${WRKSRC}/configure
+pre-configure:
+ @${ECHO} "You can override and CFLAGS on the command line."
+ @${ECHO} "Following is a recommended one."
+ @${ECHO} "make CFLAGS=\"-malign-double -fexpensive-optimizations -O4 -ffast-math -funroll-loops\""
.include <bsd.port.mk>