aboutsummaryrefslogtreecommitdiff
path: root/science/step
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-10-17 00:03:42 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-10-17 00:03:42 +0000
commita2d3b5a4bc5047210b788a128596ec34749ffa11 (patch)
treec3c20b47c3435ddcaf02b8570db6aab5b70011af /science/step
parentda6ade2349d0bdc372133d4d97bc6988aee94238 (diff)
downloadports-a2d3b5a4bc5047210b788a128596ec34749ffa11.tar.gz
ports-a2d3b5a4bc5047210b788a128596ec34749ffa11.zip
The KDE/FreeBSD team is pleased to announce KDE Software Compilation
4.7.2. The official release notes can be found at: http://kde.org/announcements/announce-4.7.2.php This release ships with many improvements. Read more about them here: http://FreeBSD.kde.org/news.php#itemKDESC472availableinports We'd like to say thanks to all testers and contributors, especially to lwhsu@ for his effort on hosting our test packages. PR: 156293 [1] 159219 [2] 160164 [3] Submitted by: Oleg Sidorkin <osidorkin@gmail.com> [1] Alvaro Castillo <gobledb@gmail.com> [2] dkeav04@gmail.com [3] Tested by: exp-run via pav
Notes
Notes: svn path=/head/; revision=283641
Diffstat (limited to 'science/step')
-rw-r--r--science/step/Makefile41
-rw-r--r--science/step/distinfo2
-rw-r--r--science/step/pkg-descr9
-rw-r--r--science/step/pkg-plist97
4 files changed, 149 insertions, 0 deletions
diff --git a/science/step/Makefile b/science/step/Makefile
new file mode 100644
index 000000000000..1dff3485c416
--- /dev/null
+++ b/science/step/Makefile
@@ -0,0 +1,41 @@
+# New ports collection Makefile for: step
+# Date created: 6 September 2011
+# Whom: Alberto Villa <avilla@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= step
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= science kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE 4 interactive physics simulator
+
+LIB_DEPENDS= qalculate.5:${PORTSDIR}/math/libqalculate \
+ gsl.16:${PORTSDIR}/math/gsl
+
+BUILD_DEPENDS= eigen>=2.0.b3:${PORTSDIR}/math/eigen2
+
+CONFLICTS= kdeedu-4.[0-6].*
+
+USE_KDE4= kdehier kdelibs kdeprefix automoc4
+KDE4_BUILDENV= yes
+USE_QT_VER= 4
+QT_COMPONENTS= opengl xml moc_build qmake_build rcc_build uic_build
+USE_BZIP2= yes
+MAKE_JOBS_SAFE= yes
+
+pre-configure:
+ # Fix GSL_INCLUDE_DIR.
+ ${REINPLACE_CMD} -e 's|gsl_|gsl/gsl_|g' \
+ ${WRKSRC}/cmake/modules/FindGSL.cmake
+ # Avoid building translations, should the user pass
+ # CURRENT_LANG to CMake.
+ ${REINPLACE_CMD} -e '/set(STEP_BUILD_TRANSLATIONS 1)/ d' \
+ ${WRKSRC}/${PORTNAME}/data/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/science/step/distinfo b/science/step/distinfo
new file mode 100644
index 000000000000..291653b9a72f
--- /dev/null
+++ b/science/step/distinfo
@@ -0,0 +1,2 @@
+SHA256 (KDE/step-4.7.2.tar.bz2) = c16334583fc52858ec6d08933c5a6d466fcd975526d9d09f2e4a347d7ea00d06
+SIZE (KDE/step-4.7.2.tar.bz2) = 398371
diff --git a/science/step/pkg-descr b/science/step/pkg-descr
new file mode 100644
index 000000000000..af664ea528f4
--- /dev/null
+++ b/science/step/pkg-descr
@@ -0,0 +1,9 @@
+Step is an interactive physics simulator. It works like this: you
+place some bodies on the scene, add some forces such as gravity or
+springs, then click "Simulate" and Step shows you how your scene will
+evolve according to the laws of physics. You can change every property
+of bodies/forces in your experiment (even during simulation) and see
+how this will change the outcome of the experiment. With Step you can
+not only learn but feel how physics works!
+
+WWW: http://edu.kde.org/step
diff --git a/science/step/pkg-plist b/science/step/pkg-plist
new file mode 100644
index 000000000000..3052b8da03cd
--- /dev/null
+++ b/science/step/pkg-plist
@@ -0,0 +1,97 @@
+bin/step
+share/applications/kde4/step.desktop
+share/apps/step/examples/brownian.step
+share/apps/step/examples/doublependulum.step
+share/apps/step/examples/eightpendula.step
+share/apps/step/examples/first.step
+share/apps/step/examples/fourpendula.step
+share/apps/step/examples/gas.step
+share/apps/step/examples/graph.step
+share/apps/step/examples/liquid.step
+share/apps/step/examples/lissajous.step
+share/apps/step/examples/motor.step
+share/apps/step/examples/motor1.step
+share/apps/step/examples/note.step
+share/apps/step/examples/resonance.step
+share/apps/step/examples/softbody.step
+share/apps/step/examples/solar.step
+share/apps/step/examples/springs.step
+share/apps/step/examples/wave.step
+share/apps/step/icons/hicolor/22x22/actions/pointer.png
+share/apps/step/icons/hicolor/22x22/actions/step_object_Anchor.png
+share/apps/step/icons/hicolor/22x22/actions/step_object_Box.png
+share/apps/step/icons/hicolor/22x22/actions/step_object_ChargedParticle.png
+share/apps/step/icons/hicolor/22x22/actions/step_object_CircularMotor.png
+share/apps/step/icons/hicolor/22x22/actions/step_object_Controller.png
+share/apps/step/icons/hicolor/22x22/actions/step_object_CoulombForce.png
+share/apps/step/icons/hicolor/22x22/actions/step_object_Disk.png
+share/apps/step/icons/hicolor/22x22/actions/step_object_Gas.png
+share/apps/step/icons/hicolor/22x22/actions/step_object_GasParticle.png
+share/apps/step/icons/hicolor/22x22/actions/step_object_Graph.png
+share/apps/step/icons/hicolor/22x22/actions/step_object_GravitationForce.png
+share/apps/step/icons/hicolor/22x22/actions/step_object_LinearMotor.png
+share/apps/step/icons/hicolor/22x22/actions/step_object_Meter.png
+share/apps/step/icons/hicolor/22x22/actions/step_object_Note.png
+share/apps/step/icons/hicolor/22x22/actions/step_object_Particle.png
+share/apps/step/icons/hicolor/22x22/actions/step_object_Pin.png
+share/apps/step/icons/hicolor/22x22/actions/step_object_Polygon.png
+share/apps/step/icons/hicolor/22x22/actions/step_object_Rope.png
+share/apps/step/icons/hicolor/22x22/actions/step_object_SoftBody.png
+share/apps/step/icons/hicolor/22x22/actions/step_object_Spring.png
+share/apps/step/icons/hicolor/22x22/actions/step_object_Stick.png
+share/apps/step/icons/hicolor/22x22/actions/step_object_Tracer.png
+share/apps/step/icons/hicolor/22x22/actions/step_object_WeightForce.png
+share/apps/step/objinfo/Anchor.html
+share/apps/step/objinfo/Box.html
+share/apps/step/objinfo/ChargedParticle.html
+share/apps/step/objinfo/CoulombForce.html
+share/apps/step/objinfo/Disk.html
+share/apps/step/objinfo/Gas.html
+share/apps/step/objinfo/GasLJForce.html
+share/apps/step/objinfo/GasParticle.html
+share/apps/step/objinfo/GravitationForce.html
+share/apps/step/objinfo/LinearMotor.html
+share/apps/step/objinfo/Meter.html
+share/apps/step/objinfo/Note.html
+share/apps/step/objinfo/Particle.html
+share/apps/step/objinfo/Pin.html
+share/apps/step/objinfo/Polygon.html
+share/apps/step/objinfo/Spring.html
+share/apps/step/objinfo/WeightForce.html
+share/apps/step/objinfo/World.html
+share/apps/step/stepui.rc
+share/apps/step/tutorials/tutorial1.step
+share/apps/step/tutorials/tutorial2.step
+share/apps/step/tutorials/tutorial3.step
+share/apps/step/tutorials/tutorial4.step
+share/apps/step/tutorials/tutorial5.step
+share/config.kcfg/step.kcfg
+share/config/step.knsrc
+share/doc/HTML/en/step/circular-motor.png
+share/doc/HTML/en/step/common
+share/doc/HTML/en/step/disk-properties.png
+share/doc/HTML/en/step/examples.docbook
+share/doc/HTML/en/step/index.cache.bz2
+share/doc/HTML/en/step/index.docbook
+share/doc/HTML/en/step/mainwindow.png
+share/doc/HTML/en/step/tutorial1.png
+share/doc/HTML/en/step/tutorial2.png
+share/doc/HTML/en/step/tutorial3.png
+share/doc/HTML/en/step/tutorial4.png
+share/doc/HTML/en/step/tutorial5.png
+share/doc/HTML/en/step/tutorials.docbook
+share/icons/hicolor/128x128/apps/step.png
+share/icons/hicolor/16x16/apps/step.png
+share/icons/hicolor/22x22/apps/step.png
+share/icons/hicolor/32x32/apps/step.png
+share/icons/hicolor/48x48/apps/step.png
+share/icons/hicolor/64x64/apps/step.png
+@dirrm share/doc/HTML/en/step
+@dirrm share/apps/step/tutorials
+@dirrm share/apps/step/objinfo
+@dirrm share/apps/step/icons/hicolor/22x22/actions
+@dirrm share/apps/step/icons/hicolor/22x22
+@dirrm share/apps/step/icons/hicolor
+@dirrm share/apps/step/icons
+@dirrm share/apps/step/examples
+@dirrm share/apps/step