aboutsummaryrefslogtreecommitdiff
path: root/science/step
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-02-18 14:23:03 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-02-18 14:23:03 +0000
commite9c34f4c34b0640b3613f03cd96e9f19730b2a07 (patch)
treeef2b2b24dfacf6def95c54d3379c421565b1fe2b /science/step
parent4dc7ccc95d370549c7c9c7c9c253d64aa92881ae (diff)
downloadports-e9c34f4c34b0640b3613f03cd96e9f19730b2a07.tar.gz
ports-e9c34f4c34b0640b3613f03cd96e9f19730b2a07.zip
KDE/FreeBSD team presents KDE SC 4.12.2 and KDE Workspace 4.11.6!
Among changes: - Switch KDE4_PREFIX to ${LOCALBASE} - Remove now needless misc/kde4-shared-mime-info port - Add stage support - Remove ancient CONFLICTS (KDE 4.9 and less) and LATEST_LINK - Squeeze MASTER_SITES/MASTER_SITE_SUBDIR - Convert LIB_DEPENDS to new style - Use options helpers - Drop support for FreeBSD 7.x - Remove Qt/KDE 3 related workarounds - Remove local patches and use upstream version scheme for libraries - sysutils/kdeadmin4, net/kdenetwork4, devel/kdesdk4, and x11-clocks/kdetoys4 ports have been split. - devel/kcachegrind is now a part of KDE SC [1] - more logs in area51 repo... New ports: devel/kde-dev-scripts: KDE development scripts devel/kde-dev-utils: KDE development utilities games/klickety: Tetris themed solitaire games/picmi: Single player logic-based puzzle game textproc/libkomparediff2: Library to compare files and strings The area51 repository features commits by Schaich Alonso, avilla, rakuco and myself. PR: ports/186491 Exp-run: by bdrewery Approved by: beat (former maintainer) [1]
Notes
Notes: svn path=/head/; revision=344893
Diffstat (limited to 'science/step')
-rw-r--r--science/step/Makefile15
-rw-r--r--science/step/distinfo4
-rw-r--r--science/step/files/patch-git_b0b45d050
3 files changed, 7 insertions, 62 deletions
diff --git a/science/step/Makefile b/science/step/Makefile
index b785e133b903..fbb446f0c403 100644
--- a/science/step/Makefile
+++ b/science/step/Makefile
@@ -2,31 +2,26 @@
PORTNAME= step
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
CATEGORIES= science kde
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE 4 interactive physics simulator
-LIB_DEPENDS= qalculate.5:${PORTSDIR}/math/libqalculate \
- gsl:${PORTSDIR}/math/gsl
+LIB_DEPENDS= libqalculate.so:${PORTSDIR}/math/libqalculate \
+ libgsl.so:${PORTSDIR}/math/gsl
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen2.pc:${PORTSDIR}/math/eigen2
-CONFLICTS= kdeedu-4.[0-6].*
-
USE_KDE4= kdehier kdelibs kdeprefix automoc4
USES= cmake:outsource
USE_QT4= opengl moc_build qmake_build rcc_build uic_build
USE_XZ= yes
-NO_STAGE= yes
pre-configure:
- # Avoid building translations, should the user pass
- # CURRENT_LANG to CMake.
+# Avoid building translations, should the user pass
+# CURRENT_LANG to CMake.
${REINPLACE_CMD} -e '/set(STEP_BUILD_TRANSLATIONS 1)/ d' \
${WRKSRC}/${PORTNAME}/data/CMakeLists.txt
diff --git a/science/step/distinfo b/science/step/distinfo
index 5e9154f05961..6b378fdaabcf 100644
--- a/science/step/distinfo
+++ b/science/step/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/4.10.5/step-4.10.5.tar.xz) = ea19672626b228c06b17ec917b0ec45da4f3067a628e430e0ee9ff6ac2b23217
-SIZE (KDE/4.10.5/step-4.10.5.tar.xz) = 376380
+SHA256 (KDE/4.12.2/step-4.12.2.tar.xz) = 861a15106a61525f6bdd3c0904cb6e404c075acc31858f06f8cb26344da549c0
+SIZE (KDE/4.12.2/step-4.12.2.tar.xz) = 361632
diff --git a/science/step/files/patch-git_b0b45d0 b/science/step/files/patch-git_b0b45d0
deleted file mode 100644
index 2c030b5fb9b5..000000000000
--- a/science/step/files/patch-git_b0b45d0
+++ /dev/null
@@ -1,50 +0,0 @@
-commit b0b45d0b871c4cdcd714de29f1d587a26366fbca
-Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
-Date: Mon Nov 4 00:07:22 2013 +0200
-
- Use Eigen2's newer StdVector implementation if it is available.
-
- This should fix the build with libc++ (ie. recent versions of FreeBSD and OS
- X at least), as Eigen2's default StdVector implementation reimplements
- std::vector in an incompatible way.
-
- Defining EIGEN_USE_NEW_STDVECTOR makes Eigen >= 2.0.6 use the new
- implementation that does not have these problems and is the default in
- Eigen3.
-
-diff --git a/stepcore/collisionsolver.cc b/stepcore/collisionsolver.cc
-index a5d2f90..9a263a8 100644
---- stepcore/collisionsolver.cc
-+++ stepcore/collisionsolver.cc
-@@ -23,6 +23,7 @@
- #include <algorithm>
- #include <QtGlobal>
-
-+#define EIGEN_USE_NEW_STDVECTOR
- #include <Eigen/StdVector>
-
- namespace StepCore {
-diff --git a/stepcore/collisionsolver.h b/stepcore/collisionsolver.h
-index c136d9a..d67d1d0 100644
---- stepcore/collisionsolver.h
-+++ stepcore/collisionsolver.h
-@@ -28,6 +28,7 @@
- #include "vector.h"
- #include "solver.h"
-
-+#define EIGEN_USE_NEW_STDVECTOR
- #include <Eigen/StdVector>
-
- namespace StepCore
-diff --git a/stepcore/types.h b/stepcore/types.h
-index 05dbd9d..b1259a6 100644
---- stepcore/types.h
-+++ stepcore/types.h
-@@ -25,6 +25,7 @@
-
- #include "object.h"
- #include "vector.h"
-+#define EIGEN_USE_NEW_STDVECTOR
- #include <Eigen/StdVector>
- #include <QByteArray>
- #include <Eigen/Sparse>