aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-02-05 19:01:34 +0000
committerJohn Marino <marino@FreeBSD.org>2014-02-05 19:01:34 +0000
commit037ccfbe9773eaf1140a85a16a7a721c64e27b5b (patch)
tree82896e383a304b183d4f113db8cda7332bf111f3 /science
parentd2b1ce3d17f8e51bdb5bb96883d5bd82649fc065 (diff)
downloadports-037ccfbe9773eaf1140a85a16a7a721c64e27b5b.tar.gz
ports-037ccfbe9773eaf1140a85a16a7a721c64e27b5b.zip
science/avogadro: Specify libGL explicitly with associated CFLAG
Notes
Notes: svn path=/head/; revision=342817
Diffstat (limited to 'science')
-rw-r--r--science/avogadro/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/science/avogadro/Makefile b/science/avogadro/Makefile
index 5168656fde0a..4637ed86cc34 100644
--- a/science/avogadro/Makefile
+++ b/science/avogadro/Makefile
@@ -20,7 +20,7 @@ OPTIONS_SUB= yes
USE_BZIP2= yes
USES= cmake desktop-file-utils pkgconfig
-USE_GL= glu
+USE_GL= glu gl
USE_QT4= gui network opengl \
linguist_build moc_build qmake_build rcc_build uic_build
CMAKE_ARGS= -DENABLE_GLSL=OFF \
@@ -28,7 +28,8 @@ CMAKE_ARGS= -DENABLE_GLSL=OFF \
USE_LDCONFIG= yes
CFLAGS+= -idirafter ${LOCALBASE}/include/eigen2 \
- -idirafter ${LOCALBASE}/include
+ -idirafter ${LOCALBASE}/include \
+ -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.options.mk>