aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-09 10:29:48 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-09 10:29:48 +0000
commit67a015afbcff48cb22a287a9e346bc70d8752ac5 (patch)
tree85d81b83d23ab7b2efc21a25ff0ceebc8c0906d3 /science
parent412cfda55239f149fe77a5bc41fa2a072f935321 (diff)
downloadports-67a015afbcff48cb22a287a9e346bc70d8752ac5.tar.gz
ports-67a015afbcff48cb22a287a9e346bc70d8752ac5.zip
Convert from USE_GECKO to USES=gecko
While here stagify what was not staged yet Convert to USES=webplugin where needed and add desktop-file-utils dependency to icedtea-web
Notes
Notes: svn path=/head/; revision=350678
Diffstat (limited to 'science')
-rw-r--r--science/gchemutils/Makefile19
1 files changed, 7 insertions, 12 deletions
diff --git a/science/gchemutils/Makefile b/science/gchemutils/Makefile
index 35629c531b0d..c036a90f6561 100644
--- a/science/gchemutils/Makefile
+++ b/science/gchemutils/Makefile
@@ -21,11 +21,10 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/bodr.pc:${PORTSDIR}/science/bodr \
PORTSCOUT= limitw:1,even
-USE_XZ= yes
USE_XORG= x11
USE_GNOME= gnomedocutils gtk30 intlhack libgsf libxml2
USES= desktop-file-utils gettext gmake libtool pathfix pkgconfig \
- shared-mime-info
+ shared-mime-info tar:xz
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -42,20 +41,16 @@ VER= ${PORTVERSION:R}
PLIST_SUB= VER=${VER} GOFFICE=0.10 VERSION=${PORTVERSION}
OPTIONS_DEFINE= GNUMERIC XUL
+OPTIONS_SUB= yes
GNUMERIC_DESC= Build gnumeric plugin
XUL_DESC= Build browser plugin (requires libxul)
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MXUL}
-USE_GECKO= libxul
-CONFIGURE_ARGS+=--enable-mozilla-plugin \
+XUL_USES= gecko
+XUL_CONFIGURE_ON=--enable-mozilla-plugin \
--with-mozilla-libdir=${PREFIX}/lib/xulrunner
-PLIST_SUB+= XUL=""
-.else
-CONFIGURE_ARGS+=--disable-mozilla-plugin
-PLIST_SUB+= XUL="@comment "
-.endif
+XUL_CONFIGURE_OFF=--disable-mozilla-plugin
+
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGNUMERIC} || exists(${LOCALBASE}/lib/libspreadsheet.so)
LIB_DEPENDS+= libspreadsheet.so:${PORTSDIR}/math/gnumeric