aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /science
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'science')
-rw-r--r--science/afni/Makefile2
-rw-r--r--science/afni/files/Makefile.FreeBSD_PORT10
-rw-r--r--science/buddy/Makefile2
-rw-r--r--science/dtiquery/files/patch-Makefile.definitions4
-rw-r--r--science/felt/Makefile2
-rw-r--r--science/flounder/Makefile4
-rw-r--r--science/gnudatalanguage/Makefile4
-rw-r--r--science/gromacs/Makefile2
-rw-r--r--science/gsystem/Makefile2
-rw-r--r--science/kmovisto/Makefile4
-rw-r--r--science/medit/files/patch-makefile4
-rw-r--r--science/minc/Makefile2
-rw-r--r--science/ncs/Makefile2
-rw-r--r--science/oases/Makefile2
-rw-r--r--science/oases/files/patch-aa4
-rw-r--r--science/omnetpp/Makefile6
-rw-r--r--science/oof/Makefile8
-rw-r--r--science/openfoam/Makefile8
-rw-r--r--science/paraview/Makefile6
-rw-r--r--science/ruby-dcl/Makefile2
-rw-r--r--science/szip/Makefile2
-rw-r--r--science/v_sim/Makefile2
-rw-r--r--science/vis5d+/Makefile4
-rw-r--r--science/vmd/Makefile6
24 files changed, 46 insertions, 48 deletions
diff --git a/science/afni/Makefile b/science/afni/Makefile
index d1fef2283320..435110c25e54 100644
--- a/science/afni/Makefile
+++ b/science/afni/Makefile
@@ -74,7 +74,7 @@ X11R6_FILES= coxplot/Makefile \
post-extract:
@${CP} -f ${FILESDIR}/Makefile.FreeBSD_PORT ${WRKSRC}
.for f in ${X11R6_FILES}
- @${REINPLACE_CMD} -e 's|/usr/X11R6|$${X11BASE}|g' ${WRKSRC}/${f}
+ @${REINPLACE_CMD} -e 's|/usr/X11R6|$${LOCALBASE}|g' ${WRKSRC}/${f}
.endfor
@${REINPLACE_CMD} -e 's|AFNI_2007_05_29_1644|${PORTVERSION}|g' ${WRKSRC}/AFNI_label.h
@${CP} ${DISTDIR}/${DIST_SUBDIR}/afni.1 ${WRKDIR}
diff --git a/science/afni/files/Makefile.FreeBSD_PORT b/science/afni/files/Makefile.FreeBSD_PORT
index fbd29dd9a198..55f96ce90860 100644
--- a/science/afni/files/Makefile.FreeBSD_PORT
+++ b/science/afni/files/Makefile.FreeBSD_PORT
@@ -62,15 +62,15 @@ CCMIN = ${CC}
CCD = ${CC} ${CCDEBS}
CCSVD = ${CC} -O0
-IFLAGS = -I. -I${X11BASE}/include -I/usr/local/include
-LFLAGS = -s -L. -L${X11BASE}/lib
+IFLAGS = -I. -I${LOCALBASE}/include -I/usr/local/include
+LFLAGS = -s -L. -L${LOCALBASE}/lib
MAKE = gmake
PLUGIN_SUFFIX = so
PLUGIN_LFLAGS = -shared
PLUGIN_CC = ${CC}
-PLFLAGS = -s -rdynamic -L. -L${X11BASE}/lib
+PLFLAGS = -s -rdynamic -L. -L${LOCALBASE}/lib
AR = /usr/bin/ar
RANLIB = /usr/bin/ranlib
@@ -94,8 +94,8 @@ LLIBS = -lmri -lXm -lXp -lXpm -lXext -lXmu -lXt -lX11 -lm $(LZLIB)
# vvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvv
# For suma (NO STATIC LINKING OF GL libs)
-SUMA_INCLUDE_PATH = -I${X11BASE}/include -I/usr/local/include -I./ -I../ -I../niml/ -Igts/src
-SUMA_LINK_PATH = -L/usr/lib -L${X11BASE}/lib -L../
+SUMA_INCLUDE_PATH = -I${LOCALBASE}/include -I/usr/local/include -I./ -I../ -I../niml/ -Igts/src
+SUMA_LINK_PATH = -L/usr/lib -L${LOCALBASE}/lib -L../
#use -lGLw if you have libGLw.a or libGLw.so* or
# -lMesaGLw if you have Mesa's version (libMesaGLw*) of libGLw
SUMA_LINK_LIB = -lXm -lGLw -lGLU -lGL -lXmu -lXp -lXt -lXext -lX11 -lm $(LZLIB)
diff --git a/science/buddy/Makefile b/science/buddy/Makefile
index f909f6138523..2f2d235f3b04 100644
--- a/science/buddy/Makefile
+++ b/science/buddy/Makefile
@@ -19,7 +19,7 @@ USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
DOCS= doc/bddnotes.ps doc/buddy.ps doc/tech.txt README AUTHORS
diff --git a/science/dtiquery/files/patch-Makefile.definitions b/science/dtiquery/files/patch-Makefile.definitions
index 593cefc32b3f..80334a3527fc 100644
--- a/science/dtiquery/files/patch-Makefile.definitions
+++ b/science/dtiquery/files/patch-Makefile.definitions
@@ -14,7 +14,7 @@
ifdef FreeBSD
-WX_CONFIG_BIN ?= /usr/X11R6/bin/wxgtk2-2.8-config
-+WX_CONFIG_BIN ?= ${X11BASE}/bin/wxgtk2-2.8-config
++WX_CONFIG_BIN ?= ${LOCALBASE}/bin/wxgtk2-2.8-config
VTK_INCLUDE_PATHS ?= -I/usr/local/include/vtk-5.0/
VTK_LIB_PATHS ?= -L/usr/local/lib/vtk-5.0/
WX_INCLUDE_PATHS ?= `$(WX_CONFIG_BIN) --cxxflags`
@@ -27,7 +27,7 @@
JAMA_INCLUDE_PATH ?= -I/usr/local/include/
ZLIB_INCLUDE_PATH ?= -I/usr/include
-SYS_INCLUDE_PATHS ?= -I/usr/include -I/usr/X11R6/include -I/usr/local/include/gtk-2.0 -I/usr/X11R6/include/gtk-2.0 -I/usr/local/include/glib-2.0 -I/usr/local/include/cairo -I/usr/local/include/pango-1.0 -I/usr/X11R6/include/pango-1.0 -I/usr/local/include/atk-1.0
-+SYS_INCLUDE_PATHS ?= -I/usr/include -I${X11BASE}/include -I/usr/local/include/gtk-2.0 -I${X11BASE}/include/gtk-2.0 -I/usr/local/include/glib-2.0 -I/usr/local/include/cairo -I/usr/local/include/pango-1.0 -I${X11BASE}/include/pango-1.0 -I/usr/local/include/atk-1.0
++SYS_INCLUDE_PATHS ?= -I/usr/include -I${LOCALBASE}/include -I/usr/local/include/gtk-2.0 -I${LOCALBASE}/include/gtk-2.0 -I/usr/local/include/glib-2.0 -I/usr/local/include/cairo -I/usr/local/include/pango-1.0 -I${LOCALBASE}/include/pango-1.0 -I/usr/local/include/atk-1.0
+SYS_CXXFLAGS ?= -g
SYS_LIBS ?= -L/usr/local/lib -lXt -lGL -lpng
diff --git a/science/felt/Makefile b/science/felt/Makefile
index 6c0fd074c7b1..3052f371a1d9 100644
--- a/science/felt/Makefile
+++ b/science/felt/Makefile
@@ -22,7 +22,7 @@ WRKSRC= ${WRKDIR}/FElt-${PORTVERSION}
USE_MOTIF= yes
USE_GL= glu
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --x-defaults=${X11BASE}/lib/X11/app-defaults
+CONFIGURE_ARGS= --x-defaults=${LOCALBASE}/lib/X11/app-defaults
CFLAGS+= -D__GLX_MOTIF
MAN1= burlap.1 corduroy.1 felt.1 patchwork.1 velvet.1 yardstick.1
diff --git a/science/flounder/Makefile b/science/flounder/Makefile
index 4c7d453f403c..078f5a928eed 100644
--- a/science/flounder/Makefile
+++ b/science/flounder/Makefile
@@ -22,8 +22,8 @@ LIB_DEPENDS= fltk:${PORTSDIR}/x11-toolkits/fltk \
glut.4:${PORTSDIR}/graphics/libglut
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS} -lstdc++"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} -lstdc++"
USE_GMAKE= yes
.if !defined(WITHOUT_AVIFILE)
diff --git a/science/gnudatalanguage/Makefile b/science/gnudatalanguage/Makefile
index b01dda6c7125..df7af8c782f3 100644
--- a/science/gnudatalanguage/Makefile
+++ b/science/gnudatalanguage/Makefile
@@ -37,8 +37,8 @@ LIB_DEPENDS+= plplotd.11:${PORTSDIR}/math/plplot \
USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS} -L${LOCALBASE}/lib -L${X11BASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS} -L${LOCALBASE}/lib"
SLAVEDIRS= science/py-gnudatalanguage
diff --git a/science/gromacs/Makefile b/science/gromacs/Makefile
index d82139c702e8..ad4893927215 100644
--- a/science/gromacs/Makefile
+++ b/science/gromacs/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= ${LOCALBASE}/mpich/bin/mpicc:${PORTSDIR}/net/mpich
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
CONFIGURE_ARGS= --exec-prefix=${PREFIX}
diff --git a/science/gsystem/Makefile b/science/gsystem/Makefile
index 0a303e7ab1e0..0be1ed376605 100644
--- a/science/gsystem/Makefile
+++ b/science/gsystem/Makefile
@@ -21,7 +21,7 @@ USE_BZIP2= yes
USE_KDELIBS_VER= 3
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
QTDIR= ${QT_PREFIX}
QMAKESPEC= freebsd-g++
diff --git a/science/kmovisto/Makefile b/science/kmovisto/Makefile
index 61a0310321b1..b7333772f2a0 100644
--- a/science/kmovisto/Makefile
+++ b/science/kmovisto/Makefile
@@ -8,19 +8,19 @@
PORTNAME= kmovisto
PORTVERSION= 0.7.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science
MASTER_SITES= http://mitglied.lycos.de/pageofmh/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= A real 3-D molecule viewer
+USE_XORG= x11 ice xext
USE_QT_VER= 3
USE_GL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
diff --git a/science/medit/files/patch-makefile b/science/medit/files/patch-makefile
index 1feffe06e74f..0612fe6b02b8 100644
--- a/science/medit/files/patch-makefile
+++ b/science/medit/files/patch-makefile
@@ -16,8 +16,8 @@
+FreeBSD:
+ $(MAKE) $(MFLAGS) -f Makefile.arch \
+ "prog = medit" \
-+ "INCDIR = -I. -I$(WRKSRC)/sources -I$(X11BASE)/include" \
-+ "XLIBS = -L$(X11BASE)/lib -lXmu -lXext -lX11" \
++ "INCDIR = -I. -I$(WRKSRC)/sources -I$(LOCALBASE)/include" \
++ "XLIBS = -L$(LOCALBASE)/lib -lXmu -lXext -lX11" \
+ "GL_LIB = -lGL" \
+ "GLU_LIB = -lGLU" \
+ "GLUT_LIB = -lglut" \
diff --git a/science/minc/Makefile b/science/minc/Makefile
index 52a7497bd20b..770bc188f4ec 100644
--- a/science/minc/Makefile
+++ b/science/minc/Makefile
@@ -28,7 +28,7 @@ COMMENT= Medical Imaging NetCDF
LIB_DEPENDS= netcdf.4:${PORTSDIR}/science/netcdf
USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GCC= 3.2+
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/science/ncs/Makefile b/science/ncs/Makefile
index 992ae9c88edd..cdee469eb340 100644
--- a/science/ncs/Makefile
+++ b/science/ncs/Makefile
@@ -90,7 +90,7 @@ LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
BLAS_LIB= -lblas
.endif
-.if exists(${X11BASE}/bin/acroread)
+.if exists(${LOCALBASE}/bin/acroread)
RUN_DEPENDS+= acroread:${PORTSDIR}/print/acroreadwrapper
.else
RUN_DEPENDS+= xpdf:${PORTSDIR}/graphics/xpdf
diff --git a/science/oases/Makefile b/science/oases/Makefile
index 921c3f6f5004..9b5d2229fb0b 100644
--- a/science/oases/Makefile
+++ b/science/oases/Makefile
@@ -34,7 +34,7 @@ post-patch:
s|%%FFLAGS%%|${FFLAGS}|g ; \
s|%%CFLAGS%%|${CFLAGS}|g ; \
s|%%LDFLAGS%%|${LDFLAGS}|g ; \
- s|%%X11BASE%%|${X11BASE}|g' ${WRKSRC}/Makefile
+ s|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/FreeBSD-FreeBSD/* ${PREFIX}/bin
diff --git a/science/oases/files/patch-aa b/science/oases/files/patch-aa
index 95db14108d5c..2c1f3ccdd6d8 100644
--- a/science/oases/files/patch-aa
+++ b/science/oases/files/patch-aa
@@ -30,8 +30,8 @@
+FC.FreeBSD-FreeBSD = %%FC%%
+CC.FreeBSD-FreeBSD = %%CC%%
+FFLAGS.FreeBSD-FreeBSD = %%FFLAGS%%
-+CFLAGS.FreeBSD-FreeBSD = %%CFLAGS%% -I%%X11BASE%%/include
-+LFLAGS.FreeBSD-FreeBSD = %%LDFLAGS%% -L%%X11BASE%%/lib
++CFLAGS.FreeBSD-FreeBSD = %%CFLAGS%% -I%%LOCALBASE%%/include
++LFLAGS.FreeBSD-FreeBSD = %%LDFLAGS%% -L%%LOCALBASE%%/lib
+RANLIB.FreeBSD-FreeBSD = ranlib
+LIB_MISC.FreeBSD-FreeBSD =
+MISC.FreeBSD-FreeBSD =
diff --git a/science/omnetpp/Makefile b/science/omnetpp/Makefile
index 97c8258e38d6..f4d7b1b32a47 100644
--- a/science/omnetpp/Makefile
+++ b/science/omnetpp/Makefile
@@ -32,7 +32,7 @@ LIB_DEPENDS= ${TCL_NODOT}:${PORTSDIR}/lang/${TCL_NODOT} \
COMPONENTS= libs progs
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
HAS_CONFIGURE= yes
LIB_FILES= cmdenv envir nedxml sim_std tkenv
@@ -55,8 +55,8 @@ pre-configure:
@${ECHO} "OMNETPP_PLOVE_DIR=${DATADIR}/plove" >> ${CONFIGUREUSER}
@${ECHO} "OMNETPP_TKENV_DIR=${DATADIR}/tkenv" >> ${CONFIGUREUSER}
@${ECHO} "OMNETPP_BITMAP_PATH=${DATADIR}/bitmaps" >> ${CONFIGUREUSER}
- @${ECHO} "TK_CFLAGS=\"-I${X11BASE}/include -I${LOCALBASE}/include/${TCL_VERSION} -I${LOCALBASE}/include/${TK_VERSION}\"" >> ${CONFIGUREUSER}
- @${ECHO} "TK_LIBS=\"-L${X11BASE}/lib -L${LOCALBASE}/lib -lX11 -l${TCL_NODOT} -l${TK_NODOT}\"" >> ${CONFIGUREUSER}
+ @${ECHO} "TK_CFLAGS=\"-I${LOCALBASE}/include -I${LOCALBASE}/include/${TCL_VERSION} -I${LOCALBASE}/include/${TK_VERSION}\"" >> ${CONFIGUREUSER}
+ @${ECHO} "TK_LIBS=\"-L${LOCALBASE}/lib -L${LOCALBASE}/lib -lX11 -l${TCL_NODOT} -l${TK_NODOT}\"" >> ${CONFIGUREUSER}
@${ECHO} "EXPAT_CFLAGS=\"-I${LOCALBASE}/include\"" >> ${CONFIGUREUSER}
@${ECHO} "EXPAT_LIBS=\"-L${LOCALBASE}/lib -lexpat\"" >> ${CONFIGUREUSER}
@${ECHO} "WISH=wish${TK_VERSION}" | ${SED} 's,tk,,' >> ${CONFIGUREUSER}
diff --git a/science/oof/Makefile b/science/oof/Makefile
index db5d471b0898..6a46a390aba0 100644
--- a/science/oof/Makefile
+++ b/science/oof/Makefile
@@ -7,7 +7,7 @@
PORTNAME= oof
PORTVERSION= 1.037
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science
MASTER_SITES= http://www.ctcms.nist.gov/~langer/OOFdownload/SRC/
DISTNAME= ${PORTNAME}-dist${PORTVERSION}
@@ -40,10 +40,8 @@ CXXFLAGS+= -Wno-deprecated
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-cxxflags='${CXXFLAGS}' \
--with-libdirs=-L${LOCALBASE}/lib \
- --with-blas="-L${LOCALBASE}/lib ${BLAS_LIBS} -L/usr/local/lib -L${FORTRANLIBDIR} -L${FORTRANLIBDIR2} ${FORTRANLIBS}" \
- --x-includes=${X11BASE}/include \
- --x-libraries=${X11BASE}/lib
-USE_GCC= 3.2+
+ --with-blas="-L${LOCALBASE}/lib ${BLAS_LIBS} -L/usr/local/lib -L${FORTRANLIBDIR} -L${FORTRANLIBDIR2} ${FORTRANLIBS}"
+
ALL_TARGET= all
PLIST_FILES= bin/oof bin/ppm2oof
diff --git a/science/openfoam/Makefile b/science/openfoam/Makefile
index b4cf05a9226c..776dfbc0d38a 100644
--- a/science/openfoam/Makefile
+++ b/science/openfoam/Makefile
@@ -19,12 +19,12 @@ COMMENT= Open Field Operation and Manipulation - CFD Simulation Toolbox
BUILD_DEPENDS= micod:${PORTSDIR}/devel/mico \
bash:${PORTSDIR}/shells/bash \
cmake:${PORTSDIR}/devel/cmake \
- ${X11BASE}/lib/libode.a:${PORTSDIR}/devel/ode \
+ ${LOCALBASE}/lib/libode.a:${PORTSDIR}/devel/ode \
${PARAVIEW_LIB}/ParaViewConfig.cmake:${PORTSDIR}/science/paraview \
${LOCALBASE}/share/java/java3d/jar/j3dutils.jar:${PORTSDIR}/java/java3d \
${LOCALBASE}/include/libiberty/demangle.h:${PORTSDIR}/devel/gnulibiberty\
${LOCALBASE}/include/vtk/vtkDataSetSource.h:${PORTSDIR}/math/vtk-headers\
- ${X11BASE}/lib/X11/fonts/freefont-ttf/FreeSans.ttf:${PORTSDIR}/x11-fonts/freefont-ttf
+ ${LOCALBASE}/lib/X11/fonts/freefont-ttf/FreeSans.ttf:${PORTSDIR}/x11-fonts/freefont-ttf
# ${LOCALBASE}/lib/parmetis/libmetis.a:${PORTSDIR}/math/parmetis
LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo \
readline.5:${PORTSDIR}/devel/readline
@@ -201,7 +201,7 @@ pre-configure:
-e "s|\$$LAMHOME/platforms/\$$WM_OPTIONS|${LOCALBASE}|" \
-e "s|^SOURCE |source |" \
${BATCHRC:S|^|${WRKSRC}/|}
- ${REINPLACE_CMD} -e "s|-lGL|-L${X11BASE}/lib -lGL|" \
+ ${REINPLACE_CMD} -e "s|-lGL|-L${LOCALBASE}/lib -lGL|" \
${GL2FIX:S|^|${WRKSRC}/|}
${REINPLACE_CMD} -e "s|GCC_VERSION=4.1.1|GCC_VERSION=${GCC_VER:S/_//}|" \
-e "s|JAVA_VERSION=1.4.2+|JAVA_VERSION=${JAVA_PORT_VERSION}|" \
@@ -218,7 +218,7 @@ pre-configure:
-e "s|-lpthread|${PTHREAD_LIBS}|" \
${WRKSRC}/wmake/rules/${OPSYS}/${f}
.endfor
- ${REINPLACE_CMD} -e "s|/usr/X11R6|${X11BASE}|" \
+ ${REINPLACE_CMD} -e "s|/usr/X11R6|${LOCALBASE}|" \
${WRKSRC}/wmake/rules/${OPSYS}/X
.for f in ${VER2FIX}
${REINPLACE_CMD} -e "s|%%ARCH%%|${ARCH}|" \
diff --git a/science/paraview/Makefile b/science/paraview/Makefile
index 8926a7ac5943..e91faf12a1e9 100644
--- a/science/paraview/Makefile
+++ b/science/paraview/Makefile
@@ -40,7 +40,7 @@ pre-patch:
${WRKDIR}/paraview-${PORTVERSION}/GUI/Widgets/CMakeLists.txt
post-patch:
- @${REINPLACE_CMD} -e 's,/usr/X11R6,${X11BASE},g' \
+ @${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},g' \
${WRKDIR}/paraview-${PORTVERSION}/Utilities/TclTk/tk*/unix/configure
do-configure:
@@ -48,8 +48,8 @@ do-configure:
cd ${WRKSRC} && \
${LOCALBASE}/bin/cmake ../${DISTNAME} \
-DCMAKE_INSTALL_PREFIX:PATH=${PREFIX} \
- -DCMAKE_C_FLAGS="${CFLAGS} -I${X11BASE}/include -I${LOCALBASE}/include" \
- -DCMAKE_CXX_FLAGS="${CXXFLAGS} -I${X11BASE}/include -I${LOCALBASE}/include" \
+ -DCMAKE_C_FLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ -DCMAKE_CXX_FLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
-DPARAVIEW_USE_SYSTEM_HDF5=1 \
-DBUILD_SHARED_LIBS="ON" \
-DVTK_USE_SYSTEM_PNG="ON" \
diff --git a/science/ruby-dcl/Makefile b/science/ruby-dcl/Makefile
index b6c1fe894b54..614419d85eea 100644
--- a/science/ruby-dcl/Makefile
+++ b/science/ruby-dcl/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= murakami@ahs.scitec.kobe-u.ac.jp
COMMENT= A Ruby interface to the scientific graphic library DCL
BUILD_DEPENDS= ${RUBY_SITEARCHLIBDIR}/narray.so:${PORTSDIR}/math/ruby-narray \
- ${X11BASE}/lib/libcdcl.a:${PORTSDIR}/science/cdcl
+ ${LOCALBASE}/lib/libcdcl.a:${PORTSDIR}/science/cdcl
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/narray.so:${PORTSDIR}/math/ruby-narray
.if defined(WITHOUT_GTK)
diff --git a/science/szip/Makefile b/science/szip/Makefile
index cec796895e95..b6e959d86a2b 100644
--- a/science/szip/Makefile
+++ b/science/szip/Makefile
@@ -20,7 +20,7 @@ COMMENT= Lossless compression library for scientific data
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
DOCFILE= Release_notes_2_0.pdf
post-install:
diff --git a/science/v_sim/Makefile b/science/v_sim/Makefile
index 854adcdfc0f0..e0c9f6fbc470 100644
--- a/science/v_sim/Makefile
+++ b/science/v_sim/Makefile
@@ -18,7 +18,7 @@ USE_GL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-gtk-doc
-CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${X11BASE}/include -I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
MAN1= v_sim.1
diff --git a/science/vis5d+/Makefile b/science/vis5d+/Makefile
index f0ce912f8d71..a156076130c3 100644
--- a/science/vis5d+/Makefile
+++ b/science/vis5d+/Makefile
@@ -33,8 +33,8 @@ CONFIGURE_ARGS= --enable-gtk --enable-threads --with-netcdf \
--with-mixkit=${LOCALBASE}/lib/libmix.a --with-x
USE_LDCONFIG= yes
-CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CFLAGS+= -DMIX_ANSI_IOSTREAMS -fpermissive
diff --git a/science/vmd/Makefile b/science/vmd/Makefile
index 2ebc6e378aab..aadc89825068 100644
--- a/science/vmd/Makefile
+++ b/science/vmd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vmd
PORTVERSION= 1.8.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science graphics python tcl tk
MASTER_SITES= http://jedi.ks.uiuc.edu/~johns/raytracer/files/0.97/:tachyon \
ftp://ftp.ebi.ac.uk/pub/software/unix/stride/src/:stride
@@ -18,7 +18,7 @@ DISTFILES= ${VMD_DIST} \
MAINTAINER= sangwoos@gmail.com
COMMENT= A molecular visualization program
-BUILD_DEPENDS= makedepend:${X_IMAKE_PORT} \
+BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend \
${PYNUMERIC}
LIB_DEPENDS= tcl84:${PORTSDIR}/lang/tcl84 \
tk84:${PORTSDIR}/x11-toolkits/tk84 \
@@ -27,7 +27,7 @@ RUN_DEPENDS= ${PYNUMERIC}
USE_PERL5_BUILD= yes
USE_GMAKE= yes
-USE_GL= yes
+USE_GL= glu
USE_PYTHON= yes
RESTRICTED= "License has restrictions"