aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2008-05-01 21:04:57 +0000
committerHerve Quiroz <hq@FreeBSD.org>2008-05-01 21:04:57 +0000
commit881aeda37bfd5d7ba3c03281489c3532ff775aec (patch)
tree5a43890984e99ea11c222cb42ab1d249dd7b759f /science
parent68ddaf05b5f2fe9a4e00f8b679605a781e2464a4 (diff)
downloadports-881aeda37bfd5d7ba3c03281489c3532ff775aec.tar.gz
ports-881aeda37bfd5d7ba3c03281489c3532ff775aec.zip
Colt is a package for scalable scientific and technical computing in Java. It
consists of several free Java libraries, for user convenience bundled under one single uniform umbrella. Namely the Colt library, the Jet library, the CoreJava library, and the Concurrent library. The Colt library provides fundamental general-purpose data structures optimized for numerical data, such as resizable arrays, dense and sparse matrices (multi-dimensional arrays), linear algebra, associative containers and buffer management. WWW: http://dsd.lbl.gov/~hoschek/colt/ PR: 122913 Submitted by: Wen heping <wenheping@gmail.com>
Notes
Notes: svn path=/head/; revision=212438
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/colt/Makefile56
-rw-r--r--science/colt/distinfo3
-rw-r--r--science/colt/pkg-descr11
4 files changed, 71 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index ebe08e4306c6..66fe71d6530b 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -20,6 +20,7 @@
SUBDIR += chemtool
SUBDIR += chemtool-devel
SUBDIR += clhep
+ SUBDIR += colt
SUBDIR += crf++
SUBDIR += dcl
SUBDIR += devisor
diff --git a/science/colt/Makefile b/science/colt/Makefile
new file mode 100644
index 000000000000..c20595d28392
--- /dev/null
+++ b/science/colt/Makefile
@@ -0,0 +1,56 @@
+# Ports collection makefile for: colt
+# Date created: April 19, 2008
+# Whom: Wen heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= colt
+PORTVERSION= 1.2.0
+CATEGORIES= science java
+MASTER_SITES= http://dsd.lbl.gov/~hoschek/colt-download/releases/
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Java package for scalable scientific and technical computing
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.if !defined(WITHOUT_COMPILE)
+USE_ANT= yes
+ALL_TARGET= build
+.if !defined(NOPORTDOCS)
+ALL_TARGET+= javadoc
+.endif
+.else
+NO_BUILD= yes
+.endif
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+PLIST_FILES= %%JAVAJARDIR%%/colt.jar
+
+.include <bsd.port.pre.mk>
+
+pre-fetch:
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You may use the following build options:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WITHOUT_COMPILE=yes Install the pre-compiled .jar file"
+ @${ECHO_MSG} ""
+
+do-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
+ @cd ${WRKSRC}/doc && ${FIND} . -type d -exec ${MKDIR} ${DOCSDIR}/{} \;
+ @cd ${WRKSRC}/doc && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
+ @${ECHO_MSG} " [DONE]"
+.endif
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/lib/colt.jar ${JAVAJARDIR}
+
+.include <bsd.port.post.mk>
diff --git a/science/colt/distinfo b/science/colt/distinfo
new file mode 100644
index 000000000000..95abb9931295
--- /dev/null
+++ b/science/colt/distinfo
@@ -0,0 +1,3 @@
+MD5 (colt-1.2.0.tar.gz) = 9a64a845a09338709589f6ef00b06fad
+SHA256 (colt-1.2.0.tar.gz) = da26942314a4ab7ab6dc449460970b4ada464b6594f69cba1b88268effbdddbb
+SIZE (colt-1.2.0.tar.gz) = 2545695
diff --git a/science/colt/pkg-descr b/science/colt/pkg-descr
new file mode 100644
index 000000000000..4d49eef3228b
--- /dev/null
+++ b/science/colt/pkg-descr
@@ -0,0 +1,11 @@
+Colt is a package for scalable scientific and technical computing in Java. It
+consists of several free Java libraries, for user convenience bundled under one
+single uniform umbrella. Namely the Colt library, the Jet library, the CoreJava
+library, and the Concurrent library.
+
+The Colt library provides fundamental general-purpose data structures optimized
+for numerical data, such as resizable arrays, dense and sparse matrices
+(multi-dimensional arrays), linear algebra, associative containers and buffer
+management.
+
+WWW: http://dsd.lbl.gov/~hoschek/colt/