aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2008-04-18 01:05:19 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2008-04-18 01:05:19 +0000
commit911f2f68355307571c94bb36f9727fd46a52dc6d (patch)
tree2f2b0c02ea1746d305dc3010b197539ca4f0011f /science
parentc68b78ff7611eb03c9c8f5f653a5dea031a0d156 (diff)
downloadports-911f2f68355307571c94bb36f9727fd46a52dc6d.tar.gz
ports-911f2f68355307571c94bb36f9727fd46a52dc6d.zip
- Update to 1.6
PR: ports/122656 Submitted by: EelVex <mplekos physics.upatras.gr> (maintainer)
Notes
Notes: svn path=/head/; revision=211482
Diffstat (limited to 'science')
-rw-r--r--science/xmds/Makefile20
-rw-r--r--science/xmds/distinfo6
-rw-r--r--science/xmds/files/patch-Makefile.am16
-rw-r--r--science/xmds/pkg-descr4
-rw-r--r--science/xmds/pkg-plist55
5 files changed, 85 insertions, 16 deletions
diff --git a/science/xmds/Makefile b/science/xmds/Makefile
index 3a0228c6d7d6..c09edff7f391 100644
--- a/science/xmds/Makefile
+++ b/science/xmds/Makefile
@@ -6,20 +6,28 @@
#
PORTNAME= xmds
-DISTVERSION= 1.5-2
+PORTVERSION= 1.6
CATEGORIES= science
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
+DISTNAME= xmds-1.6.5
MAINTAINER= mplekos@physics.upatras.gr
COMMENT= XMDS is a code generator that integrates equations;
-BUILD_DEPENDS= ${LOCALBASE}/include/fftw.h:${PORTSDIR}/math/fftw
-
MAN1= loadxsil.1 xmds.1 xsil2graphics.1
+OPTIONS= FFTW3 "Use fftw3 instead of fftw2" Off
HAS_CONFIGURE= YES
+USE_AUTOTOOLS= automake:16
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_FFTW3)
+BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
+CONFIGURE_ARGS= --enable-fftw3 --with-fftw3-path=${LOCALBASE}
+.else
+BUILD_DEPENDS= ${LOCALBASE}/include/fftw.h:${PORTSDIR}/math/fftw
CONFIGURE_ARGS= --with-fftw-path=${LOCALBASE}
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/science/xmds/distinfo b/science/xmds/distinfo
index b054ac9f195a..5f25ee4ae6ef 100644
--- a/science/xmds/distinfo
+++ b/science/xmds/distinfo
@@ -1,3 +1,3 @@
-MD5 (xmds-1.5-2.tar.gz) = 23f4378f5a787be941e632ddc4bf3f2b
-SHA256 (xmds-1.5-2.tar.gz) = 259a3cb2d7e2dd7128e2f5fa8c41f1eb9693ca04e9ed409e0bdd7f0f0531bc47
-SIZE (xmds-1.5-2.tar.gz) = 415729
+MD5 (xmds-1.6.5.tar.gz) = 4273d1698c1c9ad0a6117ae4300f1eae
+SHA256 (xmds-1.6.5.tar.gz) = f7128c7c847bafd3a5ed582415cbddd1f31234278d62231faaeb9bec04d6b5ff
+SIZE (xmds-1.6.5.tar.gz) = 528593
diff --git a/science/xmds/files/patch-Makefile.am b/science/xmds/files/patch-Makefile.am
new file mode 100644
index 000000000000..df9d50658cfd
--- /dev/null
+++ b/science/xmds/files/patch-Makefile.am
@@ -0,0 +1,16 @@
+Index: Makefile.am
+===================================================================
+--- Makefile.am (revision 1829)
++++ Makefile.am (working copy)
+@@ -55,8 +55,9 @@
+ m4files = acx_mpi.m4 acx_pthread.m4
+
+ EXTRA_DIST = $(example_files) $(m4files) $(manfiles) MANIFEST README.Windows source/loadxsil.m
+-dist_doc_data = AUTHORS NEWS COPYING README README.Windows source/loadxsil.m
+-doc_examplesdir = ${docdir}/examples
++xmdsdocdir = ${datadir}/doc/xmds-${VERSION}
++dist_xmdsdoc_DATA = AUTHORS NEWS COPYING README README.Windows source/loadxsil.m
++doc_examplesdir = ${xmdsdocdir}/examples
+ dist_doc_examples_DATA = $(example_files)
+
+ api:
diff --git a/science/xmds/pkg-descr b/science/xmds/pkg-descr
index d39d4e296685..0a8222ed52ff 100644
--- a/science/xmds/pkg-descr
+++ b/science/xmds/pkg-descr
@@ -18,7 +18,7 @@ human readable form in an XML file, and it goes away and writes and compiles a
C++ program that integrates those equations as fast as it can possibly be done
in your architecture.
-Authr: Paul Cochrane (principal developer) cochrane@physics.uq.edu.au
+Author: Paul Cochrane (principal developer) cochrane@physics.uq.edu.au
Joseph Hope (second author) Joseph.Hope@anu.edu.au
Peter Drummond (xmds project leader) drummond@physics.uq.edu.au
-WWW: http://www.physics.uq.edu.au/xmds/index.html
+WWW: http://www.xmds.org/
diff --git a/science/xmds/pkg-plist b/science/xmds/pkg-plist
index 67bb08219f02..f2c5c0c2b526 100644
--- a/science/xmds/pkg-plist
+++ b/science/xmds/pkg-plist
@@ -1,7 +1,52 @@
-include/getopt_xmds.h
-lib/libxmds.a
-bin/loadxsil.m
bin/xmds
-include/xmdscomplex.h
-include/xmdsconfig.h
bin/xsil2graphics
+include/getopt_xmds.h
+include/xmds_complex.h
+include/xmds_config.h
+lib/libxmds.a
+share/doc/xmds-1.6.5/AUTHORS
+share/doc/xmds-1.6.5/COPYING
+share/doc/xmds-1.6.5/NEWS
+share/doc/xmds-1.6.5/README
+share/doc/xmds-1.6.5/README.Windows
+share/doc/xmds-1.6.5/examples/HighdimPlotExample.nb
+share/doc/xmds-1.6.5/examples/atomlaser.xmds
+share/doc/xmds-1.6.5/examples/branch.xmds
+share/doc/xmds-1.6.5/examples/brusselator.xmds
+share/doc/xmds-1.6.5/examples/catcycle.xmds
+share/doc/xmds-1.6.5/examples/chain.xmds
+share/doc/xmds-1.6.5/examples/chemkin.xmds
+share/doc/xmds-1.6.5/examples/diffusion.xmds
+share/doc/xmds-1.6.5/examples/duffing.xmds
+share/doc/xmds-1.6.5/examples/fibre.xmds
+share/doc/xmds-1.6.5/examples/fisher_reaction_diffusion.xmds
+share/doc/xmds-1.6.5/examples/fullpos3D.xmds
+share/doc/xmds-1.6.5/examples/gaugeatomlaser.xmds
+share/doc/xmds-1.6.5/examples/groundstate.xmds
+share/doc/xmds-1.6.5/examples/highdim.xmds
+share/doc/xmds-1.6.5/examples/highdim_vector_version.xmds
+share/doc/xmds-1.6.5/examples/hires.xmds
+share/doc/xmds-1.6.5/examples/krebs.xmds
+share/doc/xmds-1.6.5/examples/kubo.xmds
+share/doc/xmds-1.6.5/examples/lane_emden.xmds
+share/doc/xmds-1.6.5/examples/lorenz.xmds
+share/doc/xmds-1.6.5/examples/lorenzInput.dat
+share/doc/xmds-1.6.5/examples/lotka_volterra.xmds
+share/doc/xmds-1.6.5/examples/nan.xmds
+share/doc/xmds-1.6.5/examples/ndparamp.xmds
+share/doc/xmds-1.6.5/examples/nlse.xmds
+share/doc/xmds-1.6.5/examples/oregonator.xmds
+share/doc/xmds-1.6.5/examples/paraxial_wave.xmds
+share/doc/xmds-1.6.5/examples/pendulum.xmds
+share/doc/xmds-1.6.5/examples/ring_modulator.xmds
+share/doc/xmds-1.6.5/examples/sech_soliton.xmds
+share/doc/xmds-1.6.5/examples/sech_soliton_tdepk.xmds
+share/doc/xmds-1.6.5/examples/sine.xmds
+share/doc/xmds-1.6.5/examples/soliton.xmds
+share/doc/xmds-1.6.5/examples/thermkin.xmds
+share/doc/xmds-1.6.5/examples/tla.xmds
+share/doc/xmds-1.6.5/examples/van_der_pol.xmds
+share/doc/xmds-1.6.5/examples/vibstring.xmds
+share/doc/xmds-1.6.5/loadxsil.m
+@dirrm share/doc/xmds-1.6.5/examples
+@dirrm share/doc/xmds-1.6.5