aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-07-31 23:22:41 +0000
committerJohn Marino <marino@FreeBSD.org>2014-07-31 23:22:41 +0000
commited72c673ab81fe75e8e44a569ca4f4b8463d7231 (patch)
treea6b14a5ce9ba1acf4cd600a148ff4ffb2c669f16 /science
parent0733c8c2af212a2e9f40591cb6e94e24dbb642e4 (diff)
downloadports-ed72c673ab81fe75e8e44a569ca4f4b8463d7231.tar.gz
ports-ed72c673ab81fe75e8e44a569ca4f4b8463d7231.zip
Add new port: science/pulseview
PR: 179854 Submitted by: uffe (uffe.org) Major QA: marino ================================================================== The sigrok project aims at creating a portable, cross-platform, Free/Libre/Open-Source signal analysis software suite that supports various device types, such as logic analyzers, MSOs, oscilloscopes, multimeters, LCR meters, sound level meters, thermometers, hygrometers, anemometers, light meters, DAQs, dataloggers, function generators, spectrum analyzers, power supplies, GPIB interfaces, and more. WWW: http://sigrok.org/
Notes
Notes: svn path=/head/; revision=363683
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/pulseview/Makefile25
-rw-r--r--science/pulseview/distinfo2
-rw-r--r--science/pulseview/files/patch-pv_data_signaldata.cpp13
-rw-r--r--science/pulseview/files/patch-pv_data_signaldata.h10
-rw-r--r--science/pulseview/pkg-descr8
6 files changed, 59 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 607a3ec27fd0..ef9a72e5114a 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -142,6 +142,7 @@
SUBDIR += pnetcdf
SUBDIR += psi3
SUBDIR += psychopy
+ SUBDIR += pulseview
SUBDIR += py-DendroPy
SUBDIR += py-coards
SUBDIR += py-h5py
diff --git a/science/pulseview/Makefile b/science/pulseview/Makefile
new file mode 100644
index 000000000000..bd5144b428a4
--- /dev/null
+++ b/science/pulseview/Makefile
@@ -0,0 +1,25 @@
+# Created by: Uffe Jakobsen <uffe@uffe.org>
+# $FreeBSD$
+
+PORTNAME= pulseview
+PORTVERSION= 0.2.0
+CATEGORIES= science cad
+MASTER_SITES= http://sigrok.org/download/source/pulseview/
+
+MAINTAINER= uffe@uffe.org
+COMMENT= GUI client that supports various hardware logic analyzers
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libsigrok.so:${PORTSDIR}/devel/libsigrok \
+ libsigrokdecode.so:${PORTSDIR}/devel/libsigrokdecode
+
+USES= cmake gmake pkgconfig
+USE_QT4= corelib gui moc qmake rcc uic
+CMAKE_ARGS+= -DCMAKE_INSTALL_MANDIR:PATH=${MANPREFIX}/man
+PLIST_FILES= bin/pulseview man/man1/pulseview.1.gz
+
+MAKE_JOBS_UNSAFE=yes
+
+.include <bsd.port.mk>
diff --git a/science/pulseview/distinfo b/science/pulseview/distinfo
new file mode 100644
index 000000000000..c4bd77e5a98a
--- /dev/null
+++ b/science/pulseview/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pulseview-0.2.0.tar.gz) = feb5d33a0a91c989bfc39fa758195755e78e87c3cf445bb135a8c8d4f86bc1dd
+SIZE (pulseview-0.2.0.tar.gz) = 148799
diff --git a/science/pulseview/files/patch-pv_data_signaldata.cpp b/science/pulseview/files/patch-pv_data_signaldata.cpp
new file mode 100644
index 000000000000..174fa0894a7e
--- /dev/null
+++ b/science/pulseview/files/patch-pv_data_signaldata.cpp
@@ -0,0 +1,13 @@
+--- pv/data/signaldata.cpp.orig 2014-05-06 21:43:51.000000000 +0000
++++ pv/data/signaldata.cpp
+@@ -29,6 +29,10 @@ SignalData::SignalData() :
+ {
+ }
+
++SignalData::~SignalData()
++{
++}
++
+ double SignalData::samplerate() const
+ {
+ return _samplerate;
diff --git a/science/pulseview/files/patch-pv_data_signaldata.h b/science/pulseview/files/patch-pv_data_signaldata.h
new file mode 100644
index 000000000000..e08a85ff062e
--- /dev/null
+++ b/science/pulseview/files/patch-pv_data_signaldata.h
@@ -0,0 +1,10 @@
+--- pv/data/signaldata.h.orig 2014-05-06 21:43:51.000000000 +0000
++++ pv/data/signaldata.h
+@@ -30,6 +30,7 @@ class SignalData
+ {
+ public:
+ SignalData();
++ virtual ~SignalData();
+
+ public:
+ double samplerate() const;
diff --git a/science/pulseview/pkg-descr b/science/pulseview/pkg-descr
new file mode 100644
index 000000000000..b3ba6bf01088
--- /dev/null
+++ b/science/pulseview/pkg-descr
@@ -0,0 +1,8 @@
+The sigrok project aims at creating a portable, cross-platform,
+Free/Libre/Open-Source signal analysis software suite that supports
+various device types, such as logic analyzers, MSOs, oscilloscopes,
+multimeters, LCR meters, sound level meters, thermometers, hygrometers,
+anemometers, light meters, DAQs, dataloggers, function generators,
+spectrum analyzers, power supplies, GPIB interfaces, and more.
+
+WWW: http://sigrok.org/