aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-09-25 12:45:46 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-09-25 12:45:46 +0000
commit8821bc7669a4873f0c3eeef5a1f955161c71551a (patch)
tree1dc2b1fda3d8443fdec6d17c8b0b4841838da2cf /science
parente33a0393c5f7182008147e6d49d50fcfaad7b0a9 (diff)
downloadports-8821bc7669a4873f0c3eeef5a1f955161c71551a.tar.gz
ports-8821bc7669a4873f0c3eeef5a1f955161c71551a.zip
Add gerris 0.6.0, a scientific CFD simulator.
Gerris is an Open Source Free Software library for the solution of partial differential equations describing fluid flow. Gerris is supported by NIWA (National Institute of Water and Atmospheric research) and by the Marsden Fund of the Royal Society of New Zealand. The code is written entirely in C and uses both the GLib Library and the GTS Library for geometrical functions and object-oriented programming. PR: 86297 Submitted by: Oliver Dunkl <odunkl (at) gmx.net>
Notes
Notes: svn path=/head/; revision=143520
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/gerris/Makefile62
-rw-r--r--science/gerris/distinfo6
-rw-r--r--science/gerris/pkg-descr8
-rw-r--r--science/gerris/pkg-plist75
5 files changed, 152 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 492ae357ebf1..4a834ab9fe47 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -22,6 +22,7 @@
SUBDIR += gchempaint
SUBDIR += gchemutils
SUBDIR += gdis
+ SUBDIR += gerris
SUBDIR += getdp
SUBDIR += ghemical
SUBDIR += glens
diff --git a/science/gerris/Makefile b/science/gerris/Makefile
new file mode 100644
index 000000000000..eebdacd470fb
--- /dev/null
+++ b/science/gerris/Makefile
@@ -0,0 +1,62 @@
+# ex:ts=8
+# New ports collection makefile for: gerris
+# Date created: Sun Sep 18 12:36:38 CEST 2005
+# Whom: Oliver Dunkl <odunkl@gmx.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gerris
+PORTVERSION= 0.6.0
+CATEGORIES= science math
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gfs
+
+PATCH_SITES= ${MASTER_SITE_SOURCEFORGE}gfs/ \
+ http://members.aon.at/odunkl/downloads/patches/
+PATCHFILES= gerris-0.6-patch-1.gz \
+ gerris-0.6-patch-2.gz
+PATCH_DIST_STRIP= -p1
+
+MAINTAINER= odunkl@gmx.net
+COMMENT= A scientific CFD simulator
+
+LIB_DEPENDS= gts.3:${PORTSDIR}/graphics/gts
+
+.if !defined(WITHOUT_DX)
+BUILD_DEPENDS+= dx:${PORTSDIR}/graphics/opendx
+RUN_DEPENDS+= dx:${PORTSDIR}/graphics/opendx
+.else
+CONFIGURE_ARGS+= --disable-dx
+.endif
+
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+INSTALLS_SHLIB= yes
+USE_GNOME= pkgconfig
+USE_GETOPT_LONG= yes
+USE_REINPLACE= yes
+
+MPIDIR= ${LOCALBASE}/mpich
+
+.include <bsd.port.pre.mk>
+
+# TODO: add support for MPI
+#.if exists(${MPIDIR}/bin/mpiCC)
+#WITH_MPI= yes
+#.endif
+#.if defined(WITH_MPI)
+#PKGNAMESUFFIX+= -mpich
+#BUILD_DEPENDS+= ${MPIDIR}/bin/mpiCC:${PORTSDIR}/net/mpich
+#CONFIGURE_ARGS+= --with-mpicc=${MPIDIR}/bin/mpiCC
+#MAKE_ARGS= LIBTOOL="${LIBTOOL} --tag=CC"
+#.else
+CONFIGURE_ARGS+= --disable-mpi
+#.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|' \
+ ${WRKSRC}/src/Makefile.in
+
+.include <bsd.port.post.mk>
diff --git a/science/gerris/distinfo b/science/gerris/distinfo
new file mode 100644
index 000000000000..4383928d0638
--- /dev/null
+++ b/science/gerris/distinfo
@@ -0,0 +1,6 @@
+MD5 (gerris-0.6.0.tar.gz) = c16d9d26bc4233eae416dea325ae3d36
+SIZE (gerris-0.6.0.tar.gz) = 4264414
+MD5 (gerris-0.6-patch-1.gz) = 71b271798a665d4fe057c8b19f079d86
+SIZE (gerris-0.6-patch-1.gz) = 17342
+MD5 (gerris-0.6-patch-2.gz) = ed07a997ddf15da034c585c55225ed27
+SIZE (gerris-0.6-patch-2.gz) = 191
diff --git a/science/gerris/pkg-descr b/science/gerris/pkg-descr
new file mode 100644
index 000000000000..a7f3708120d6
--- /dev/null
+++ b/science/gerris/pkg-descr
@@ -0,0 +1,8 @@
+Gerris is an Open Source Free Software library for the solution of partial
+differential equations describing fluid flow. Gerris is supported by NIWA
+(National Institute of Water and Atmospheric research) and by the
+Marsden Fund of the Royal Society of New Zealand. The code is written
+entirely in C and uses both the GLib Library and the GTS Library for
+geometrical functions and object-oriented programming.
+
+WWW: http://gfs.sourceforge.net/
diff --git a/science/gerris/pkg-plist b/science/gerris/pkg-plist
new file mode 100644
index 000000000000..40f2c31fb3fc
--- /dev/null
+++ b/science/gerris/pkg-plist
@@ -0,0 +1,75 @@
+bin/gerris2D
+bin/gerris2D3
+bin/gerris2D_dir
+bin/gerris3D
+bin/gerris3D_dir
+bin/gfs-config
+bin/gfs2oogl2D
+bin/gfs2oogl2D3
+bin/gfs2oogl3D
+bin/gfs2other2D
+bin/gfs2other3D
+bin/gfs2vtk2D
+bin/gfs2vtk3D
+bin/gfscompare2D
+bin/gfscompare2D3
+bin/gfscompare3D
+bin/ppmcombine
+bin/streamanime
+include/gerris/adaptive.h
+include/gerris/advection.h
+include/gerris/boundary.h
+include/gerris/domain.h
+include/gerris/event.h
+include/gerris/fluid.h
+include/gerris/ftt.h
+include/gerris/graphic.h
+include/gerris/init.h
+include/gerris/ocean.h
+include/gerris/output.h
+include/gerris/poisson.h
+include/gerris/refine.h
+include/gerris/simulation.h
+include/gerris/solid.h
+include/gerris/source.h
+include/gerris/tension.h
+include/gerris/timestep.h
+include/gerris/utils.h
+include/gerris/vof.h
+include/gfs.h
+include/gfsconfig.h
+lib/gerris/dx2D.mdf
+lib/gerris/dx3D.mdf
+lib/gerris/libdx2D-0.6.so
+lib/gerris/libdx2D-0.6.so.1
+lib/gerris/libdx2D.a
+lib/gerris/libdx2D.so
+lib/gerris/libdx3D-0.6.so
+lib/gerris/libdx3D-0.6.so.1
+lib/gerris/libdx3D.a
+lib/gerris/libdx3D.so
+lib/gerris/libperiodic_flow2D.a
+lib/gerris/libperiodic_flow2D.so
+lib/gerris/libperiodic_flow2D.so.0
+lib/gerris/libtesting2D.a
+lib/gerris/libtesting2D.so
+lib/gerris/libtesting2D.so.0
+lib/gerris/libvorticity_spectrum2D.a
+lib/gerris/libvorticity_spectrum2D.so
+lib/gerris/libvorticity_spectrum2D.so.0
+lib/libgfs2D-0.6.so
+lib/libgfs2D-0.6.so.1
+lib/libgfs2D.a
+lib/libgfs2D.so
+lib/libgfs2D3-0.6.so
+lib/libgfs2D3-0.6.so.1
+lib/libgfs2D3.a
+lib/libgfs2D3.so
+lib/libgfs3D-0.6.so
+lib/libgfs3D-0.6.so.1
+lib/libgfs3D.a
+lib/libgfs3D.so
+libdata/pkgconfig/gerris2D.pc
+libdata/pkgconfig/gerris3D.pc
+@dirrm lib/gerris
+@dirrm include/gerris