aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-07-01 10:46:10 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-07-01 10:46:10 +0000
commite3e9cab7901218dbeae36ffcf63b1a54203d4e46 (patch)
treeaf9e08d5ec8e6c64067c1c8a510efc98b0823e81 /science
parent8372dd4ab27931e14dab161be79e96997b63331d (diff)
downloadports-e3e9cab7901218dbeae36ffcf63b1a54203d4e46.tar.gz
ports-e3e9cab7901218dbeae36ffcf63b1a54203d4e46.zip
Update to 0.72, follow upstream name change, and clean up
Notes
Notes: svn path=/head/; revision=276778
Diffstat (limited to 'science')
-rw-r--r--science/bblimage/Makefile66
-rw-r--r--science/bblimage/distinfo5
-rw-r--r--science/bblimage/files/patch-src__parray.c76
-rw-r--r--science/bblimage/files/patch-src__pyvox.c20
-rw-r--r--science/bblimage/files/patch-src__tkphoto.c11
-rw-r--r--science/bblimage/pkg-descr22
-rw-r--r--science/bblimage/pkg-plist33
-rw-r--r--science/pyvox/Makefile66
-rw-r--r--science/pyvox/distinfo5
-rw-r--r--science/pyvox/files/patch-src__parray.c76
-rw-r--r--science/pyvox/files/patch-src__pyvox.c20
-rw-r--r--science/pyvox/files/patch-src__tkphoto.c11
-rw-r--r--science/pyvox/pkg-descr22
-rw-r--r--science/pyvox/pkg-plist33
14 files changed, 370 insertions, 96 deletions
diff --git a/science/bblimage/Makefile b/science/bblimage/Makefile
index 9aa1805ff657..221a9bf84d7a 100644
--- a/science/bblimage/Makefile
+++ b/science/bblimage/Makefile
@@ -6,35 +6,61 @@
# $FreeBSD$
#
-PORTNAME= bblimage
-PORTVERSION= 0.66
-PORTREVISION= 3
+PORTNAME= pyvox
+PORTVERSION= 0.72
CATEGORIES= science
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= miwi
+MASTER_SITES= http://www.med.upenn.edu/bbl/downloads/pyvox/
EXTRACT_SUFX= .src.tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A set of software tools for medical image processing
-DEPRECATED= No more upstream, looks like an abandonware
-EXPIRATION_DATE= 2011-08-01
+LICENSE= MIT
-LIB_DEPENDS= Xm.2:${PORTSDIR}/x11-toolkits/lesstif
+LIB_DEPENDS= lapack.4:${PORTSDIR}/math/lapack
-USE_XORG= x11
-USE_PYTHON= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-lapack --with-python
-USE_GMAKE= yes
-USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+LAPACK?= -llapack -lblas
+CONFIGURE_ARGS = --with-lapack="${LAPACK}" --with-python="${PYTHON_CMD}"
+CONFIGURE_ENV= ac_cv_header_tgmath_h=no
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+USE_PYTHON= 2.5+
-MAN1= anonbblanz.1 bblimage.1 binnseg.1 conseg.1 decomment.1 dumpbblanz.1 \
- imstack.1 inleav2.1 lovar.1 qdv.1 rpsamp.1 skmiv.1 swab.1 usb2uc.1 \
- vibihist.1 vihist.1
-MAN5= cdata.5 mri_data.5 param.5
+.if defined(WITHOUT_X11)
+CONFIGURE_ARGS+=--without-x
+PLIST_SUB+= X11="@comment "
+.else
+CONFIGURE_ARGS+=--with-x
+BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/Pmw/__init__.py:${PORTSDIR}/x11-toolkits/py-Pmw
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/Pmw/__init__.py:${PORTSDIR}/x11-toolkits/py-Pmw
+USE_MOTIF= yes
+USE_TK = 82+
+CFLAGS+= -DUSE_COMPOSITELESS_PHOTO_PUT_BLOCK -I${LOCALBASE}/include \
+ -I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR}
+PLIST_SUB+= X11=""
+.endif
+
+MAN1= affreg.1 anonavw.1 bredit.1 decomment.1 dumpavw.1 editavw.1 makeavw.1 pyvox.1 \
+ reged.1 regedit.1 qdv.1
+MAN5= cdata.5 param.5
+
+.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} -e "s|python1\.5|${PYTHON_VERSION}|g" ${WRKSRC}/configure ${WRKSRC}/Makefile.in
+.if defined(WITHOUT_X11)
+ @${REINPLACE_CMD} -e '\|pmw=yes|s|yes|no|' -e '\|tkinter=yes|s|yes|no|' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '\|#include "tk.h"|d' ${WRKSRC}/include/pyvox.h
+.else
+ @${REINPLACE_CMD} -e 's|-ltk|&${USE_TK}|' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+.if defined(MAINTAINER_MODE)
+check regress regression-test test: build
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
+ ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} regress)
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/science/bblimage/distinfo b/science/bblimage/distinfo
index 7da85ab0f456..62547d6b3ece 100644
--- a/science/bblimage/distinfo
+++ b/science/bblimage/distinfo
@@ -1,3 +1,2 @@
-MD5 (bblimage-0.66.src.tgz) = 9b01e8128c4009984300453ee00d601c
-SHA256 (bblimage-0.66.src.tgz) = d645cda214076dc9977b7ed099f3643b19fe5552eab4a2ea9ddae6cec5d37f11
-SIZE (bblimage-0.66.src.tgz) = 967079
+SHA256 (pyvox-0.72.src.tgz) = d7a733faa323d8cdca51e8244e9c50c91bccbb77543e546125f7b251a3c75a61
+SIZE (pyvox-0.72.src.tgz) = 1501027
diff --git a/science/bblimage/files/patch-src__parray.c b/science/bblimage/files/patch-src__parray.c
new file mode 100644
index 000000000000..a84acca50fdd
--- /dev/null
+++ b/science/bblimage/files/patch-src__parray.c
@@ -0,0 +1,76 @@
+--- ./src/parray.c.orig 2006-02-24 12:18:51.000000000 -0500
++++ ./src/parray.c 2011-07-01 02:32:12.000000000 -0400
+@@ -991,7 +991,7 @@
+ if (DEBUG_ALLOC) {
+ fprintf(stderr, "parray create: %p\n", self);
+ if (0)
+- fprintf(stderr, "...reference count = %d\n",
++ fprintf(stderr, "...reference count = %zd\n",
+ ((PyObject *)self)->ob_refcnt);
+ }
+
+@@ -1171,7 +1171,7 @@
+ if (DEBUG_ALLOC) {
+ fprintf(stderr, "parray alloc: %p\n", self);
+ if (0)
+- fprintf(stderr, "...reference count = %d\n",
++ fprintf(stderr, "...reference count = %zd\n",
+ ((PyObject *)self)->ob_refcnt);
+ }
+
+@@ -2074,7 +2074,7 @@
+
+ static PyMappingMethods
+ parray_as_mapping = {
+- (inquiry) parray_length, /* mp_length: len(x) */
++ (lenfunc) parray_length, /* mp_length: len(x) */
+ (binaryfunc) parray_getitem, /* mp_subscript: x[y] */
+ (objobjargproc) parray_setitem, /* mp_ass_subscript: x[y] = v */
+ };
+@@ -2204,13 +2204,13 @@
+
+ static PySequenceMethods
+ parray_as_sequence = {
+- (inquiry) 0, /* sq_length: len(x) */
++ (lenfunc) 0, /* sq_length: len(x) */
+ (binaryfunc) 0, /* sq_concat: x + y */
+- (intargfunc) 0, /* sq_repeat: n * x */
+- (intargfunc) 0, /* sq_item: x[i] */
+- (intintargfunc) parray_getslice, /* sq_slice: x[i:j] */
+- (intobjargproc) 0, /* sq_ass_item: x[i] = v */
+- (intintobjargproc) parray_setslice, /* sq_ass_slice: x[i:j] = v */
++ (ssizeargfunc) 0, /* sq_repeat: n * x */
++ (ssizeargfunc) 0, /* sq_item: x[i] */
++ (ssizessizeargfunc) parray_getslice, /* sq_slice: x[i:j] */
++ (ssizeobjargproc) 0, /* sq_ass_item: x[i] = v */
++ (ssizessizeobjargproc) parray_setslice, /* sq_ass_slice: x[i:j] = v */
+ };
+
+
+@@ -7386,7 +7386,7 @@
+
+ /* DEBUG: Print ref counts of arguments */
+ if (0) {
+- printf("Refcnts 1: %d, %d\n", self->ob_refcnt, filename->ob_refcnt);
++ printf("Refcnts 1: %zd, %zd\n", self->ob_refcnt, filename->ob_refcnt);
+ }
+
+ /* Paste self onto front of argument tuple. FIXME: This is really
+@@ -7400,7 +7400,7 @@
+
+ /* DEBUG: Print ref counts of arguments */
+ if (0) {
+- printf("Refcnts 2: %d, %d, %d\n", self->ob_refcnt, filename->ob_refcnt,
++ printf("Refcnts 2: %zd, %zd, %zd\n", self->ob_refcnt, filename->ob_refcnt,
+ newargs->ob_refcnt);
+ }
+
+@@ -7418,7 +7418,7 @@
+
+ /* DEBUG: Print ref counts of arguments */
+ if (0) {
+- printf("Refcnts 3: %d, %d, %d\n", self->ob_refcnt, filename->ob_refcnt,
++ printf("Refcnts 3: %zd, %zd, %zd\n", self->ob_refcnt, filename->ob_refcnt,
+ newargs->ob_refcnt);
+ }
+
diff --git a/science/bblimage/files/patch-src__pyvox.c b/science/bblimage/files/patch-src__pyvox.c
new file mode 100644
index 000000000000..07f056943e7d
--- /dev/null
+++ b/science/bblimage/files/patch-src__pyvox.c
@@ -0,0 +1,20 @@
+--- ./src/pyvox.c.orig 2006-02-24 16:33:41.000000000 -0500
++++ ./src/pyvox.c 2011-07-01 02:29:06.000000000 -0400
+@@ -1850,7 +1850,7 @@
+ if (0) {
+ fprintf(stderr, "Created new kernel object at %p\n", self);
+ if (0)
+- fprintf(stderr, "...reference count = %d\n",
++ fprintf(stderr, "...reference count = %zd\n",
+ ((PyObject *)self)->ob_refcnt);
+ }
+
+@@ -2273,7 +2273,7 @@
+
+ static PyMappingMethods
+ kernel_as_mapping = {
+- (inquiry) kernel_length, /* mp_length: len(x) */
++ (lenfunc) kernel_length, /* mp_length: len(x) */
+ (binaryfunc) kernel_getitem, /* mp_subscript: x[y] */
+ (objobjargproc) kernel_setitem, /* mp_ass_subscript: x[y] = v */
+ };
diff --git a/science/bblimage/files/patch-src__tkphoto.c b/science/bblimage/files/patch-src__tkphoto.c
new file mode 100644
index 000000000000..9be4a5503b5f
--- /dev/null
+++ b/science/bblimage/files/patch-src__tkphoto.c
@@ -0,0 +1,11 @@
+--- ./src/tkphoto.c.orig 2005-12-29 13:33:15.000000000 -0500
++++ ./src/tkphoto.c 2011-07-01 02:28:06.000000000 -0400
+@@ -632,7 +632,7 @@
+ if (0) {
+ fprintf(stderr, "Created new tkphoto object at %p\n", self);
+ if (0)
+- fprintf(stderr, "...reference count = %d\n",
++ fprintf(stderr, "...reference count = %zd\n",
+ ((PyObject *)pytk)->ob_refcnt);
+ }
+
diff --git a/science/bblimage/pkg-descr b/science/bblimage/pkg-descr
index 9753cc4f0d55..6daca94b72f2 100644
--- a/science/bblimage/pkg-descr
+++ b/science/bblimage/pkg-descr
@@ -1,10 +1,14 @@
-BBLimage is a set of software tools for medical image processing, particularly
-skull stripping and segmentation of MR brain images; tools to support other
-applications may be added later. These tools are intended to support
-researchers who need to prototype new image analysis algorithms or to develop
-automated image analysis tools for specific image analysis applications. The
-sequence of processing operations is specified through a scripting language
-which can be used interactively or in command files; the language used is an
-extension of Python.
+Pyvox (formerly known as BBLimage) is a set of software tools for medical
+image processing, particularly skull stripping and segmentation of MR brain
+images (tools to support other applications may be added later). These tools
+are intended to support researchers who need to prototype new image analysis
+algorithms or to develop automated image analysis tools for specific image
+analysis applications. The sequence of processing operations is specified
+through the scripting language Python, which can be used interactively or in
+command files.
-WWW: http://www.uphs.upenn.edu/bbl/software/bblimage/
+Pyvox scripts and date files are portable, easily extensible, and suitable
+both for rapid prototyping of new algorithms and analysis protocols, and also
+for efficient, automated processing of the finished analysis protocols.
+
+WWW: http://www.med.upenn.edu/bbl/downloads/pyvox/index.shtml
diff --git a/science/bblimage/pkg-plist b/science/bblimage/pkg-plist
index 114ca046c741..2d3ecb6c87dd 100644
--- a/science/bblimage/pkg-plist
+++ b/science/bblimage/pkg-plist
@@ -1,25 +1,26 @@
-bin/anonbblanz
-bin/binnseg
-bin/conseg
+bin/affreg
+bin/anonavw
+bin/bredit
bin/decomment
-bin/dumpbblanz
-bin/imstack
-bin/inleav2
-bin/lovar
-bin/qdv
-bin/rowcol
-bin/rpsamp
-bin/skmiv
-bin/swab
-bin/usb2uc
-bin/vibihist
-bin/vihist
-lib/libbbli.so
+bin/dumpavw
+bin/editavw
+bin/makeavw
+%%X11%%bin/qdv
+bin/regedit
+include/errm.h
+include/exim.h
+include/memm.h
+include/voxel.h
+lib/libpyvox.so
+lib/libvoxkit.so
%%PYTHON_SITELIBDIR%%/exim.so
%%PYTHON_SITELIBDIR%%/optim.py
%%PYTHON_SITELIBDIR%%/optim.pyc
%%PYTHON_SITELIBDIR%%/pyvox.py
%%PYTHON_SITELIBDIR%%/pyvox.pyc
%%PYTHON_SITELIBDIR%%/pyvoxC.so
+%%PYTHON_SITELIBDIR%%/reged.py
+%%PYTHON_SITELIBDIR%%/reged.pyc
%%PYTHON_SITELIBDIR%%/regis.py
%%PYTHON_SITELIBDIR%%/regis.pyc
+%%X11%%%%PYTHON_SITELIBDIR%%/tkphoto.so
diff --git a/science/pyvox/Makefile b/science/pyvox/Makefile
index 9aa1805ff657..221a9bf84d7a 100644
--- a/science/pyvox/Makefile
+++ b/science/pyvox/Makefile
@@ -6,35 +6,61 @@
# $FreeBSD$
#
-PORTNAME= bblimage
-PORTVERSION= 0.66
-PORTREVISION= 3
+PORTNAME= pyvox
+PORTVERSION= 0.72
CATEGORIES= science
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= miwi
+MASTER_SITES= http://www.med.upenn.edu/bbl/downloads/pyvox/
EXTRACT_SUFX= .src.tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A set of software tools for medical image processing
-DEPRECATED= No more upstream, looks like an abandonware
-EXPIRATION_DATE= 2011-08-01
+LICENSE= MIT
-LIB_DEPENDS= Xm.2:${PORTSDIR}/x11-toolkits/lesstif
+LIB_DEPENDS= lapack.4:${PORTSDIR}/math/lapack
-USE_XORG= x11
-USE_PYTHON= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-lapack --with-python
-USE_GMAKE= yes
-USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+LAPACK?= -llapack -lblas
+CONFIGURE_ARGS = --with-lapack="${LAPACK}" --with-python="${PYTHON_CMD}"
+CONFIGURE_ENV= ac_cv_header_tgmath_h=no
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+USE_PYTHON= 2.5+
-MAN1= anonbblanz.1 bblimage.1 binnseg.1 conseg.1 decomment.1 dumpbblanz.1 \
- imstack.1 inleav2.1 lovar.1 qdv.1 rpsamp.1 skmiv.1 swab.1 usb2uc.1 \
- vibihist.1 vihist.1
-MAN5= cdata.5 mri_data.5 param.5
+.if defined(WITHOUT_X11)
+CONFIGURE_ARGS+=--without-x
+PLIST_SUB+= X11="@comment "
+.else
+CONFIGURE_ARGS+=--with-x
+BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/Pmw/__init__.py:${PORTSDIR}/x11-toolkits/py-Pmw
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/Pmw/__init__.py:${PORTSDIR}/x11-toolkits/py-Pmw
+USE_MOTIF= yes
+USE_TK = 82+
+CFLAGS+= -DUSE_COMPOSITELESS_PHOTO_PUT_BLOCK -I${LOCALBASE}/include \
+ -I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR}
+PLIST_SUB+= X11=""
+.endif
+
+MAN1= affreg.1 anonavw.1 bredit.1 decomment.1 dumpavw.1 editavw.1 makeavw.1 pyvox.1 \
+ reged.1 regedit.1 qdv.1
+MAN5= cdata.5 param.5
+
+.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} -e "s|python1\.5|${PYTHON_VERSION}|g" ${WRKSRC}/configure ${WRKSRC}/Makefile.in
+.if defined(WITHOUT_X11)
+ @${REINPLACE_CMD} -e '\|pmw=yes|s|yes|no|' -e '\|tkinter=yes|s|yes|no|' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '\|#include "tk.h"|d' ${WRKSRC}/include/pyvox.h
+.else
+ @${REINPLACE_CMD} -e 's|-ltk|&${USE_TK}|' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+.if defined(MAINTAINER_MODE)
+check regress regression-test test: build
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
+ ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} regress)
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/science/pyvox/distinfo b/science/pyvox/distinfo
index 7da85ab0f456..62547d6b3ece 100644
--- a/science/pyvox/distinfo
+++ b/science/pyvox/distinfo
@@ -1,3 +1,2 @@
-MD5 (bblimage-0.66.src.tgz) = 9b01e8128c4009984300453ee00d601c
-SHA256 (bblimage-0.66.src.tgz) = d645cda214076dc9977b7ed099f3643b19fe5552eab4a2ea9ddae6cec5d37f11
-SIZE (bblimage-0.66.src.tgz) = 967079
+SHA256 (pyvox-0.72.src.tgz) = d7a733faa323d8cdca51e8244e9c50c91bccbb77543e546125f7b251a3c75a61
+SIZE (pyvox-0.72.src.tgz) = 1501027
diff --git a/science/pyvox/files/patch-src__parray.c b/science/pyvox/files/patch-src__parray.c
new file mode 100644
index 000000000000..a84acca50fdd
--- /dev/null
+++ b/science/pyvox/files/patch-src__parray.c
@@ -0,0 +1,76 @@
+--- ./src/parray.c.orig 2006-02-24 12:18:51.000000000 -0500
++++ ./src/parray.c 2011-07-01 02:32:12.000000000 -0400
+@@ -991,7 +991,7 @@
+ if (DEBUG_ALLOC) {
+ fprintf(stderr, "parray create: %p\n", self);
+ if (0)
+- fprintf(stderr, "...reference count = %d\n",
++ fprintf(stderr, "...reference count = %zd\n",
+ ((PyObject *)self)->ob_refcnt);
+ }
+
+@@ -1171,7 +1171,7 @@
+ if (DEBUG_ALLOC) {
+ fprintf(stderr, "parray alloc: %p\n", self);
+ if (0)
+- fprintf(stderr, "...reference count = %d\n",
++ fprintf(stderr, "...reference count = %zd\n",
+ ((PyObject *)self)->ob_refcnt);
+ }
+
+@@ -2074,7 +2074,7 @@
+
+ static PyMappingMethods
+ parray_as_mapping = {
+- (inquiry) parray_length, /* mp_length: len(x) */
++ (lenfunc) parray_length, /* mp_length: len(x) */
+ (binaryfunc) parray_getitem, /* mp_subscript: x[y] */
+ (objobjargproc) parray_setitem, /* mp_ass_subscript: x[y] = v */
+ };
+@@ -2204,13 +2204,13 @@
+
+ static PySequenceMethods
+ parray_as_sequence = {
+- (inquiry) 0, /* sq_length: len(x) */
++ (lenfunc) 0, /* sq_length: len(x) */
+ (binaryfunc) 0, /* sq_concat: x + y */
+- (intargfunc) 0, /* sq_repeat: n * x */
+- (intargfunc) 0, /* sq_item: x[i] */
+- (intintargfunc) parray_getslice, /* sq_slice: x[i:j] */
+- (intobjargproc) 0, /* sq_ass_item: x[i] = v */
+- (intintobjargproc) parray_setslice, /* sq_ass_slice: x[i:j] = v */
++ (ssizeargfunc) 0, /* sq_repeat: n * x */
++ (ssizeargfunc) 0, /* sq_item: x[i] */
++ (ssizessizeargfunc) parray_getslice, /* sq_slice: x[i:j] */
++ (ssizeobjargproc) 0, /* sq_ass_item: x[i] = v */
++ (ssizessizeobjargproc) parray_setslice, /* sq_ass_slice: x[i:j] = v */
+ };
+
+
+@@ -7386,7 +7386,7 @@
+
+ /* DEBUG: Print ref counts of arguments */
+ if (0) {
+- printf("Refcnts 1: %d, %d\n", self->ob_refcnt, filename->ob_refcnt);
++ printf("Refcnts 1: %zd, %zd\n", self->ob_refcnt, filename->ob_refcnt);
+ }
+
+ /* Paste self onto front of argument tuple. FIXME: This is really
+@@ -7400,7 +7400,7 @@
+
+ /* DEBUG: Print ref counts of arguments */
+ if (0) {
+- printf("Refcnts 2: %d, %d, %d\n", self->ob_refcnt, filename->ob_refcnt,
++ printf("Refcnts 2: %zd, %zd, %zd\n", self->ob_refcnt, filename->ob_refcnt,
+ newargs->ob_refcnt);
+ }
+
+@@ -7418,7 +7418,7 @@
+
+ /* DEBUG: Print ref counts of arguments */
+ if (0) {
+- printf("Refcnts 3: %d, %d, %d\n", self->ob_refcnt, filename->ob_refcnt,
++ printf("Refcnts 3: %zd, %zd, %zd\n", self->ob_refcnt, filename->ob_refcnt,
+ newargs->ob_refcnt);
+ }
+
diff --git a/science/pyvox/files/patch-src__pyvox.c b/science/pyvox/files/patch-src__pyvox.c
new file mode 100644
index 000000000000..07f056943e7d
--- /dev/null
+++ b/science/pyvox/files/patch-src__pyvox.c
@@ -0,0 +1,20 @@
+--- ./src/pyvox.c.orig 2006-02-24 16:33:41.000000000 -0500
++++ ./src/pyvox.c 2011-07-01 02:29:06.000000000 -0400
+@@ -1850,7 +1850,7 @@
+ if (0) {
+ fprintf(stderr, "Created new kernel object at %p\n", self);
+ if (0)
+- fprintf(stderr, "...reference count = %d\n",
++ fprintf(stderr, "...reference count = %zd\n",
+ ((PyObject *)self)->ob_refcnt);
+ }
+
+@@ -2273,7 +2273,7 @@
+
+ static PyMappingMethods
+ kernel_as_mapping = {
+- (inquiry) kernel_length, /* mp_length: len(x) */
++ (lenfunc) kernel_length, /* mp_length: len(x) */
+ (binaryfunc) kernel_getitem, /* mp_subscript: x[y] */
+ (objobjargproc) kernel_setitem, /* mp_ass_subscript: x[y] = v */
+ };
diff --git a/science/pyvox/files/patch-src__tkphoto.c b/science/pyvox/files/patch-src__tkphoto.c
new file mode 100644
index 000000000000..9be4a5503b5f
--- /dev/null
+++ b/science/pyvox/files/patch-src__tkphoto.c
@@ -0,0 +1,11 @@
+--- ./src/tkphoto.c.orig 2005-12-29 13:33:15.000000000 -0500
++++ ./src/tkphoto.c 2011-07-01 02:28:06.000000000 -0400
+@@ -632,7 +632,7 @@
+ if (0) {
+ fprintf(stderr, "Created new tkphoto object at %p\n", self);
+ if (0)
+- fprintf(stderr, "...reference count = %d\n",
++ fprintf(stderr, "...reference count = %zd\n",
+ ((PyObject *)pytk)->ob_refcnt);
+ }
+
diff --git a/science/pyvox/pkg-descr b/science/pyvox/pkg-descr
index 9753cc4f0d55..6daca94b72f2 100644
--- a/science/pyvox/pkg-descr
+++ b/science/pyvox/pkg-descr
@@ -1,10 +1,14 @@
-BBLimage is a set of software tools for medical image processing, particularly
-skull stripping and segmentation of MR brain images; tools to support other
-applications may be added later. These tools are intended to support
-researchers who need to prototype new image analysis algorithms or to develop
-automated image analysis tools for specific image analysis applications. The
-sequence of processing operations is specified through a scripting language
-which can be used interactively or in command files; the language used is an
-extension of Python.
+Pyvox (formerly known as BBLimage) is a set of software tools for medical
+image processing, particularly skull stripping and segmentation of MR brain
+images (tools to support other applications may be added later). These tools
+are intended to support researchers who need to prototype new image analysis
+algorithms or to develop automated image analysis tools for specific image
+analysis applications. The sequence of processing operations is specified
+through the scripting language Python, which can be used interactively or in
+command files.
-WWW: http://www.uphs.upenn.edu/bbl/software/bblimage/
+Pyvox scripts and date files are portable, easily extensible, and suitable
+both for rapid prototyping of new algorithms and analysis protocols, and also
+for efficient, automated processing of the finished analysis protocols.
+
+WWW: http://www.med.upenn.edu/bbl/downloads/pyvox/index.shtml
diff --git a/science/pyvox/pkg-plist b/science/pyvox/pkg-plist
index 114ca046c741..2d3ecb6c87dd 100644
--- a/science/pyvox/pkg-plist
+++ b/science/pyvox/pkg-plist
@@ -1,25 +1,26 @@
-bin/anonbblanz
-bin/binnseg
-bin/conseg
+bin/affreg
+bin/anonavw
+bin/bredit
bin/decomment
-bin/dumpbblanz
-bin/imstack
-bin/inleav2
-bin/lovar
-bin/qdv
-bin/rowcol
-bin/rpsamp
-bin/skmiv
-bin/swab
-bin/usb2uc
-bin/vibihist
-bin/vihist
-lib/libbbli.so
+bin/dumpavw
+bin/editavw
+bin/makeavw
+%%X11%%bin/qdv
+bin/regedit
+include/errm.h
+include/exim.h
+include/memm.h
+include/voxel.h
+lib/libpyvox.so
+lib/libvoxkit.so
%%PYTHON_SITELIBDIR%%/exim.so
%%PYTHON_SITELIBDIR%%/optim.py
%%PYTHON_SITELIBDIR%%/optim.pyc
%%PYTHON_SITELIBDIR%%/pyvox.py
%%PYTHON_SITELIBDIR%%/pyvox.pyc
%%PYTHON_SITELIBDIR%%/pyvoxC.so
+%%PYTHON_SITELIBDIR%%/reged.py
+%%PYTHON_SITELIBDIR%%/reged.pyc
%%PYTHON_SITELIBDIR%%/regis.py
%%PYTHON_SITELIBDIR%%/regis.pyc
+%%X11%%%%PYTHON_SITELIBDIR%%/tkphoto.so