aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-03-22 14:37:20 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-03-22 14:37:20 +0000
commitb72452ff32c8136dea308f64d29214f4b591b69d (patch)
tree13f24b0029add7907b33de69d6d206e0f85014d4 /science
parent1f937f095089abc55ac01d7e46c5605e5007be40 (diff)
downloadports-b72452ff32c8136dea308f64d29214f4b591b69d.tar.gz
ports-b72452ff32c8136dea308f64d29214f4b591b69d.zip
- Fix build on 4.x
- portlint(1) PR: 94805 Reported by: maintainer
Notes
Notes: svn path=/head/; revision=157964
Diffstat (limited to 'science')
-rw-r--r--science/minc/Makefile10
-rw-r--r--science/minc2/Makefile10
2 files changed, 8 insertions, 12 deletions
diff --git a/science/minc/Makefile b/science/minc/Makefile
index b933be9b67c0..ec961a33e97e 100644
--- a/science/minc/Makefile
+++ b/science/minc/Makefile
@@ -29,13 +29,11 @@ LIB_DEPENDS= netcdf.1:${PORTSDIR}/science/netcdf
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+USE_GCC= 3.2+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-static=yes --enable-shared=yes
-
-# Build parameters
-#WRKSRC= ${WRKDIR}/minc-${PORTVERSION}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= dcm2mnc.1 \
ecattominc.1 \
@@ -75,6 +73,6 @@ MAN1= dcm2mnc.1 \
MAN3= ParseArgv.3
post-install:
- ${CAT} ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/science/minc2/Makefile b/science/minc2/Makefile
index b933be9b67c0..ec961a33e97e 100644
--- a/science/minc2/Makefile
+++ b/science/minc2/Makefile
@@ -29,13 +29,11 @@ LIB_DEPENDS= netcdf.1:${PORTSDIR}/science/netcdf
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+USE_GCC= 3.2+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-static=yes --enable-shared=yes
-
-# Build parameters
-#WRKSRC= ${WRKDIR}/minc-${PORTVERSION}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= dcm2mnc.1 \
ecattominc.1 \
@@ -75,6 +73,6 @@ MAN1= dcm2mnc.1 \
MAN3= ParseArgv.3
post-install:
- ${CAT} ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>