aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-25 00:36:23 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-25 00:36:23 +0000
commite8a83905423ff45aae83bbe3327a1f3a8b2286ce (patch)
tree9e11efb52e8d0aedc4375659a3e605f42abf0aad /science
parentd6de6f8b7014abcb20977d3c6d2aedb4c62ed2fb (diff)
downloadports-e8a83905423ff45aae83bbe3327a1f3a8b2286ce.tar.gz
ports-e8a83905423ff45aae83bbe3327a1f3a8b2286ce.zip
Update to CAD/felt
A did some minor cleanup of the port, hopefully this will work on gcc-3.3. I suggest this port is moved to the science category, along with freefem and femlab. PR: ports/54964 Submitted by: Pedro F. Giffuni <giffunip@yahoo.com>
Notes
Notes: svn path=/head/; revision=87626
Diffstat (limited to 'science')
-rw-r--r--science/felt/Makefile13
-rw-r--r--science/felt/distinfo2
-rw-r--r--science/felt/files/patch-src+Patchwork+oogl+h720
-rw-r--r--science/felt/files/patch-src+Velvet+opengl+c10
-rw-r--r--science/felt/pkg-plist5
5 files changed, 741 insertions, 9 deletions
diff --git a/science/felt/Makefile b/science/felt/Makefile
index 73fb15b61bc9..6cdeb048382c 100644
--- a/science/felt/Makefile
+++ b/science/felt/Makefile
@@ -6,23 +6,24 @@
#
PORTNAME= felt
-PORTVERSION= 3.05
+PORTVERSION= 3.06
CATEGORIES= cad
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://symphony.clarku.edu/atkinson/felt/Binaries/ \
ftp://ftp.isd.uni-stuttgart.de/pub/src/FEM/FElt/
MASTER_SITE_SUBDIR= felt
-EXTRACT_SUFX= .src.tar.gz
+EXTRACT_SUFX= -devel.src.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= A system for Finite Element Analysis
LIB_DEPENDS= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
-WRKSRC= ${WRKDIR}/FElt-${PORTVERSION}
-GNU_CONFIGURE= yes
USE_X_PREFIX= yes
+USE_MESA= yes
USE_REINPLACE= yes
+WRKSRC= ${WRKDIR}/FElt-${PORTVERSION}
+GNU_CONFIGURE= yes
MAN1= burlap.1 corduroy.1 felt.1 patchwork.1 velvet.1 yardstick.1
MAN3= Drawing.3
@@ -34,8 +35,8 @@ post-patch:
${WRKSRC}/lib/Widgets/xwd.c ${WRKSRC}/lib/Matrix/data.c \
${WRKSRC}/lib/Matrix/factor.c ${WRKSRC}/lib/Matrix/eigen.c \
${WRKSRC}/lib/Matrix/c_data.c ${WRKSRC}/lib/Matrix/c_factor.c \
- ${WRKSRC}/include/allocate.h ${WRKSRC}/src/Velvet/error.c \
- ${WRKSRC}/src/Burlap/allocate.h ${WRKSRC}/src/Burlap/interactive.c \
+ ${WRKSRC}/src/Velvet/error.c \
+ ${WRKSRC}/src/Burlap/interactive.c \
${WRKSRC}/src/Burlap/parser.c \
${WRKSRC}/src/Corduroy/parser.c \
${WRKSRC}/src/Patchwork/util.c
diff --git a/science/felt/distinfo b/science/felt/distinfo
index 4fd54b6a954f..2d852461c414 100644
--- a/science/felt/distinfo
+++ b/science/felt/distinfo
@@ -1 +1 @@
-MD5 (felt-3.05.src.tar.gz) = 3cadb25d7039604b862a30df55bf49f8
+MD5 (felt-3.06-devel.src.tar.gz) = 799114a94713219fdf89ca33065f7d72
diff --git a/science/felt/files/patch-src+Patchwork+oogl+h b/science/felt/files/patch-src+Patchwork+oogl+h
new file mode 100644
index 000000000000..f944305caf1f
--- /dev/null
+++ b/science/felt/files/patch-src+Patchwork+oogl+h
@@ -0,0 +1,720 @@
+--- src/Patchwork/oogl.h.orig Mon Feb 21 17:44:31 2000
++++ src/Patchwork/oogl.h Sun Jul 27 17:02:55 2003
+@@ -2,370 +2,353 @@
+ symbols.h
+ **************************************************************************/
+
+-static char *cone = "\n\
+-unit { \n\
+- { OFF\n\
+-22 40 120\n\
+-0.000000 1.000000 0.000000\n\
+-0.000000 0.000000 0.000000\n\
+-0.500000 0.000000 0.000000\n\
+-0.475528 0.000000 0.154508\n\
+-0.404508 0.000000 0.293893\n\
+-0.293893 0.000000 0.404508\n\
+-0.154508 0.000000 0.475528\n\
+-0.000000 0.000000 0.500000\n\
+--0.154508 0.000000 0.475528\n\
+--0.293893 0.000000 0.404508\n\
+--0.404508 0.000000 0.293893\n\
+--0.475528 0.000000 0.154508\n\
+--0.500000 0.000000 0.000000\n\
+--0.475528 0.000000 -0.154508\n\
+--0.404508 0.000000 -0.293893\n\
+--0.293893 0.000000 -0.404508\n\
+--0.154508 0.000000 -0.475528\n\
+--0.000000 0.000000 -0.500000\n\
+-0.154508 0.000000 -0.475528\n\
+-0.293893 0.000000 -0.404508\n\
+-0.404508 0.000000 -0.293893\n\
+-0.475528 0.000000 -0.154508\n\
+-3 2 3 0\n\
+-3 3 2 1\n\
+-3 3 4 0\n\
+-3 4 3 1\n\
+-3 4 5 0\n\
+-3 5 4 1\n\
+-3 5 6 0\n\
+-3 6 5 1\n\
+-3 6 7 0\n\
+-3 7 6 1\n\
+-3 7 8 0\n\
+-3 8 7 1\n\
+-3 8 9 0\n\
+-3 9 8 1\n\
+-3 9 10 0\n\
+-3 10 9 1\n\
+-3 10 11 0\n\
+-3 11 10 1\n\
+-3 11 12 0\n\
+-3 12 11 1\n\
+-3 12 13 0\n\
+-3 13 12 1\n\
+-3 13 14 0\n\
+-3 14 13 1\n\
+-3 14 15 0\n\
+-3 15 14 1\n\
+-3 15 16 0\n\
+-3 16 15 1\n\
+-3 16 17 0\n\
+-3 17 16 1\n\
+-3 17 18 0\n\
+-3 18 17 1\n\
+-3 18 19 0\n\
+-3 19 18 1\n\
+-3 19 20 0\n\
+-3 20 19 1\n\
+-3 20 21 0\n\
+-3 21 20 1\n\
+-3 21 2 0\n\
+-3 2 21 1\n\
+- }\n\
+-}\n\
+-";
+-
+-static char *sphere = "\n\
+-unit { \n\
+- { MESH\n\
+-10 10\n\
+-0 0 1\n\
+-0 0 1\n\
+-0 0 1\n\
+-0 0 1\n\
+-0 0 1\n\
+-0 0 1\n\
+-0 0 1\n\
+-0 0 1\n\
+-0 0 1\n\
+-0 0 1\n\
+- \n\
+-0.34202 0 0.9396\n\
+-0.262003 0.219846 0.939693\n\
+-0.0593912 0.336824 0.939693\n\
+--0.17101 0.296198 0.939693\n\
+--0.321394 0.116978 0.939693\n\
+--0.321394 -0.116978 0.939693\n\
+--0.17101 -0.296198 0.939693\n\
+-0.0593912 -0.336824 0.939693\n\
+-0.262003 -0.219846 0.939693\n\
+-0.34202 -8.37708e-17 0.939693\n\
+- \n\
+-0.642788 0 0.766044\n\
+-0.492404 0.413176 0.766044\n\
+-0.111619 0.633022 0.766044\n\
+--0.321394 0.55667 0.766044\n\
+--0.604023 0.219846 0.766044\n\
+--0.604023 -0.219846 0.766044\n\
+--0.321394 -0.55667 0.766044\n\
+-0.111619 -0.633022 0.766044\n\
+-0.492404 -0.413176 0.766044\n\
+-0.642788 -1.57438e-16 0.766044\n\
+- \n\
+-0.866025 0 0.5\n\
+-0.663414 0.55667 0.5\n\
+-0.150384 0.852869 0.5\n\
+--0.433013 0.75 0.5\n\
+--0.813798 0.296198 0.5\n\
+--0.813798 -0.296198 0.5\n\
+--0.433013 -0.75 0.5\n\
+-0.150384 -0.852869 0.5\n\
+-0.663414 -0.55667 0.5\n\
+-0.866025 -2.12115e-16 0.5\n\
+- \n\
+-0.984808 0 0.173648\n\
+-0.754407 0.633022 0.173648\n\
+-0.17101 0.969846 0.173648\n\
+--0.492404 0.852868 0.173648\n\
+--0.925417 0.336824 0.173648\n\
+--0.925417 -0.336824 0.173648\n\
+--0.492404 -0.852869 0.173648\n\
+-0.17101 -0.969846 0.173648\n\
+-0.754407 -0.633022 0.173648\n\
+-0.984808 -2.41208e-16 0.173648\n\
+- \n\
+-0.984808 0 -0.173648\n\
+-0.754407 0.633022 -0.173648\n\
+-0.17101 0.969846 -0.173648\n\
+--0.492404 0.852868 -0.173648\n\
+--0.925417 0.336824 -0.173648\n\
+--0.925417 -0.336824 -0.173648\n\
+--0.492404 -0.852869 -0.173648\n\
+-0.17101 -0.969846 -0.173648\n\
+-0.754407 -0.633022 -0.173648\n\
+-0.984808 -2.41208e-16 -0.173648\n\
+- \n\
+-0.866025 0 -0.5\n\
+-0.663414 0.55667 -0.5\n\
+-0.150384 0.852868 -0.5\n\
+--0.433013 0.75 -0.5\n\
+--0.813798 0.296198 -0.5\n\
+--0.813798 -0.296198 -0.5\n\
+--0.433013 -0.75 -0.5\n\
+-0.150384 -0.852868 -0.5\n\
+-0.663414 -0.55667 -0.5\n\
+-0.866025 -2.12115e-16 -0.5\n\
+- \n\
+-0.642788 0 -0.766044\n\
+-0.492404 0.413176 -0.766044\n\
+-0.111619 0.633022 -0.766044\n\
+--0.321394 0.55667 -0.766044\n\
+--0.604023 0.219846 -0.766044\n\
+--0.604023 -0.219846 -0.766044\n\
+--0.321394 -0.55667 -0.766044\n\
+-0.111619 -0.633022 -0.766044\n\
+-0.492404 -0.413176 -0.766044\n\
+-0.642788 -1.57438e-16 -0.766044\n\
+- \n\
+-0.34202 0 -0.939693\n\
+-0.262003 0.219846 -0.939693\n\
+-0.0593912 0.336824 -0.939693\n\
+--0.17101 0.296198 -0.939693\n\
+--0.321394 0.116978 -0.939693\n\
+--0.321394 -0.116978 -0.939693\n\
+--0.17101 -0.296198 -0.939693\n\
+-0.0593912 -0.336824 -0.939693\n\
+-0.262003 -0.219846 -0.939693\n\
+-0.34202 -8.37708e-17 -0.939693\n\
+- \n\
+-1.22465e-16 0 -1\n\
+-9.38134e-17 7.87188e-17 -1\n\
+-2.12658e-17 1.20604e-16 -1\n\
+--6.12323e-17 1.06058e-16 -1\n\
+--1.15079e-16 4.18854e-17 -1\n\
+--1.15079e-16 -4.18854e-17 -1\n\
+--6.12323e-17 -1.06058e-16 -1\n\
+-2.12658e-17 -1.20604e-16 -1\n\
+-9.38134e-17 -7.87188e-17 -1\n\
+-1.22465e-16 -2.99952e-32 -1\n\
+- }\n\
+-}\n\
+-";
+-
+-static char *xyz = "{\n\
+-=\n\
+-VECT\n\
+-8 19 3\n\
+-2 2 2 2 2 3 2 4\n\
+-1 0 0 1 0 0 1 0\n\
+-\n\
+-0 0 0 1 0 0\n\
+-1 -.05 .05 1 .05 .25\n\
+-1 .05 .05 1 -.05 .25\n\
+-\n\
+-0 0 0 0 1 0\n\
+--.05 1 .25 0 1 .15\n\
+- .05 1 .25 0 1 .15 0 1 .05\n\
+-\n\
+-0 0 0 0 0 1\n\
+--.05 .25 1 .05 .25 1 -.05 .05 1 .05 .05 1\n\
+-\n\
+-1 0 0 1\n\
+-0 1 0 1\n\
+-0 .6 1 1\n}";
+-
+-static char *origin = "\n\
+-unit { \n\
+- { VECT\n\
+-8 19 3\n\
+-2 2 2 2 2 3 2 4\n\
+-1 0 0 1 0 0 1 0\n\
+-\n\
+-0 0 0 1 0 0\n\
+-1 -.05 .05 1 .05 .25\n\
+-1 .05 .05 1 -.05 .25\n\
+-\n\
+-0 0 0 0 1 0\n\
+--.05 1 .25 0 1 .15\n\
+- .05 1 .25 0 1 .15 0 1 .05\n\
+-\n\
+-0 0 0 0 0 1\n\
+--.05 .25 1 .05 .25 1 -.05 .05 1 .05 .05 1\n\
+-\n\
+-1 0 0 1\n\
+-0 1 0 1\n\
+-0 .6 1 1\n\
+- }\n\
+-}\n\
+-";
+-
+-static char *color1 = "\n\
+-0.26 0.7 0.7 1\
+-\n}\n";
+-
+-static char *fzold = "\n\
+-unit { \n\
+- { VECT\n\
+-3 6 1\n\
+-2 2 2\n\
+-1 0 0\n\
+-\n\
+-0 0 0 0 0 0.5\n\
+-.05 0 .4 0 0 0.5\n\
+-0 0 0.5 -.05 0 .4\n\
+-\n\
+-1 0 0 1\n\
+- }\n\
+-}\n\
+-";
+-
+-static char *fz = "\n\
+-unit { \n\
+- { VECT\n\
+-5 10 1\n\
+-2 2 2 2 2\n\
+-1 0 0 0 0\n\
+-\n\
+-0 0 0 0 0 0.5\n\
+-.05 0 .4 0 0 0.5\n\
+-0 0 0.5 -.05 0 .4\n\
+-0 .05 .4 0 0 0.5\n\
+-0 0 0.5 0 -.05 .4\n\
+-\n\
+-1 0 0 1\n\
+- }\n\
+-}\n\
+-";
+-
+-static char *constraint = "\n\
+-unit { \n\
+- { OFF\n\
+- 5 2 6\n\
+- 0 0 0\n\
+- -.1 0 .3\n\
+- .1 0 .3\n\
+- 0 -.1 .3\n\
+- 0 .1 .3\n\
+- 3 0 1 2 1 0 0 1\n\
+- 3 0 3 4 1 0 0 1\n\
+-\n\
+- }\n\
+-}\n\
+-";
+-
+-static char *constraintrot = "\n\
+-unit { \n\
+- { OFF\n\
+- 10 4 12\n\
+- 0 0 0\n\
+- -.07 -.07 .3\n\
+- .07 .07 .3\n\
+- -.07 .07 .3\n\
+- .07 -.07 .3\n\
+- 0 0 .3\n\
+- -.07 -.07 .6\n\
+- .07 .07 .6\n\
+- -.07 .07 .6\n\
+- .07 -.07 .6\n\
+- 3 0 1 2 0 1 0 1 \n\
+- 3 0 3 4 0 1 0 1 \n\
+- 3 5 6 7 0 1 0 1 \n\
+- 3 5 8 9 0 1 0 1 \n\
+-\n\
+- }\n\
+-}\n\
+-";
+-
+-static char *cross = "\n\
+-unit { \n\
+- { VECT\n\
+-3 6 1\n\
+-2 2 2\n\
+-1 0 0\n\
+-\n\
+--.1 0 0 .1 0 0\n\
+-0 -.1 0 0 .1 0\n\
+-0 0 -.1 0 0 .1\n\
+-\n\
+-1 1 1 1\n\
+- }\n\
+-}\n\
+-";
+-
+-static char *transformz = "\n\
+-INST\n\
+- transform\n\
+- 1 0 0 0\n\
+- 0 1 0 0\n\
+- 0 0 1 0\n\
+-";
+-static char *transformx = "\n\
+-INST\n\
+- transform\n\
+- 0 1 0 0\n\
+- 0 0 1 0\n\
+- 1 0 0 0\n\
+-";
+-static char *transformy = "\n\
+-INST\n\
+- transform\n\
+- 0 0 1 0\n\
+- 1 0 0 0\n\
+- 0 1 0 0\n\
+-";
++static char *cone = "\n"
++"unit { \n"
++" { OFF\n"
++"22 40 120\n"
++"0.000000 1.000000 0.000000\n"
++"0.000000 0.000000 0.000000\n"
++"0.500000 0.000000 0.000000\n"
++"0.475528 0.000000 0.154508\n"
++"0.404508 0.000000 0.293893\n"
++"0.293893 0.000000 0.404508\n"
++"0.154508 0.000000 0.475528\n"
++"0.000000 0.000000 0.500000\n"
++"-0.154508 0.000000 0.475528\n"
++"-0.293893 0.000000 0.404508\n"
++"-0.404508 0.000000 0.293893\n"
++"-0.475528 0.000000 0.154508\n"
++"-0.500000 0.000000 0.000000\n"
++"-0.475528 0.000000 -0.154508\n"
++"-0.404508 0.000000 -0.293893\n"
++"-0.293893 0.000000 -0.404508\n"
++"-0.154508 0.000000 -0.475528\n"
++"-0.000000 0.000000 -0.500000\n"
++"0.154508 0.000000 -0.475528\n"
++"0.293893 0.000000 -0.404508\n"
++"0.404508 0.000000 -0.293893\n"
++"0.475528 0.000000 -0.154508\n"
++"3 2 3 0\n"
++"3 3 2 1\n"
++"3 3 4 0\n"
++"3 4 3 1\n"
++"3 4 5 0\n"
++"3 5 4 1\n"
++"3 5 6 0\n"
++"3 6 5 1\n"
++"3 6 7 0\n"
++"3 7 6 1\n"
++"3 7 8 0\n"
++"3 8 7 1\n"
++"3 8 9 0\n"
++"3 9 8 1\n"
++"3 9 10 0\n"
++"3 10 9 1\n"
++"3 10 11 0\n"
++"3 11 10 1\n"
++"3 11 12 0\n"
++"3 12 11 1\n"
++"3 12 13 0\n"
++"3 13 12 1\n"
++"3 13 14 0\n"
++"3 14 13 1\n"
++"3 14 15 0\n"
++"3 15 14 1\n"
++"3 15 16 0\n"
++"3 16 15 1\n"
++"3 16 17 0\n"
++"3 17 16 1\n"
++"3 17 18 0\n"
++"3 18 17 1\n"
++"3 18 19 0\n"
++"3 19 18 1\n"
++"3 19 20 0\n"
++"3 20 19 1\n"
++"3 20 21 0\n"
++"3 21 20 1\n"
++"3 21 2 0\n"
++"3 2 21 1\n"
++" }\n"
++"}\n";
++
++static char *sphere = "\n"
++"unit { \n"
++" { MESH\n"
++"10 10\n"
++"0 0 1\n"
++"0 0 1\n"
++"0 0 1\n"
++"0 0 1\n"
++"0 0 1\n"
++"0 0 1\n"
++"0 0 1\n"
++"0 0 1\n"
++"0 0 1\n"
++"0 0 1\n"
++" \n"
++"0.34202 0 0.9396\n"
++"0.262003 0.219846 0.939693\n"
++"0.0593912 0.336824 0.939693\n"
++"-0.17101 0.296198 0.939693\n"
++"-0.321394 0.116978 0.939693\n"
++"-0.321394 -0.116978 0.939693\n"
++"-0.17101 -0.296198 0.939693\n"
++"0.0593912 -0.336824 0.939693\n"
++"0.262003 -0.219846 0.939693\n"
++"0.34202 -8.37708e-17 0.939693\n"
++" \n"
++"0.642788 0 0.766044\n"
++"0.492404 0.413176 0.766044\n"
++"0.111619 0.633022 0.766044\n"
++"-0.321394 0.55667 0.766044\n"
++"-0.604023 0.219846 0.766044\n"
++"-0.604023 -0.219846 0.766044\n"
++"-0.321394 -0.55667 0.766044\n"
++"0.111619 -0.633022 0.766044\n"
++"0.492404 -0.413176 0.766044\n"
++"0.642788 -1.57438e-16 0.766044\n"
++" \n"
++"0.866025 0 0.5\n"
++"0.663414 0.55667 0.5\n"
++"0.150384 0.852869 0.5\n"
++"-0.433013 0.75 0.5\n"
++"-0.813798 0.296198 0.5\n"
++"-0.813798 -0.296198 0.5\n"
++"-0.433013 -0.75 0.5\n"
++"0.150384 -0.852869 0.5\n"
++"0.663414 -0.55667 0.5\n"
++"0.866025 -2.12115e-16 0.5\n"
++" \n"
++"0.984808 0 0.173648\n"
++"0.754407 0.633022 0.173648\n"
++"0.17101 0.969846 0.173648\n"
++"-0.492404 0.852868 0.173648\n"
++"-0.925417 0.336824 0.173648\n"
++"-0.925417 -0.336824 0.173648\n"
++"-0.492404 -0.852869 0.173648\n"
++"0.17101 -0.969846 0.173648\n"
++"0.754407 -0.633022 0.173648\n"
++"0.984808 -2.41208e-16 0.173648\n"
++" \n"
++"0.984808 0 -0.173648\n"
++"0.754407 0.633022 -0.173648\n"
++"0.17101 0.969846 -0.173648\n"
++"-0.492404 0.852868 -0.173648\n"
++"-0.925417 0.336824 -0.173648\n"
++"-0.925417 -0.336824 -0.173648\n"
++"-0.492404 -0.852869 -0.173648\n"
++"0.17101 -0.969846 -0.173648\n"
++"0.754407 -0.633022 -0.173648\n"
++"0.984808 -2.41208e-16 -0.173648\n"
++" \n"
++"0.866025 0 -0.5\n"
++"0.663414 0.55667 -0.5\n"
++"0.150384 0.852868 -0.5\n"
++"-0.433013 0.75 -0.5\n"
++"-0.813798 0.296198 -0.5\n"
++"-0.813798 -0.296198 -0.5\n"
++"-0.433013 -0.75 -0.5\n"
++"0.150384 -0.852868 -0.5\n"
++"0.663414 -0.55667 -0.5\n"
++"0.866025 -2.12115e-16 -0.5\n"
++" \n"
++"0.642788 0 -0.766044\n"
++"0.492404 0.413176 -0.766044\n"
++"0.111619 0.633022 -0.766044\n"
++"-0.321394 0.55667 -0.766044\n"
++"-0.604023 0.219846 -0.766044\n"
++"-0.604023 -0.219846 -0.766044\n"
++"-0.321394 -0.55667 -0.766044\n"
++"0.111619 -0.633022 -0.766044\n"
++"0.492404 -0.413176 -0.766044\n"
++"0.642788 -1.57438e-16 -0.766044\n"
++" \n"
++"0.34202 0 -0.939693\n"
++"0.262003 0.219846 -0.939693\n"
++"0.0593912 0.336824 -0.939693\n"
++"-0.17101 0.296198 -0.939693\n"
++"-0.321394 0.116978 -0.939693\n"
++"-0.321394 -0.116978 -0.939693\n"
++"-0.17101 -0.296198 -0.939693\n"
++"0.0593912 -0.336824 -0.939693\n"
++"0.262003 -0.219846 -0.939693\n"
++"0.34202 -8.37708e-17 -0.939693\n"
++" \n"
++"1.22465e-16 0 -1\n"
++"9.38134e-17 7.87188e-17 -1\n"
++"2.12658e-17 1.20604e-16 -1\n"
++"-6.12323e-17 1.06058e-16 -1\n"
++"-1.15079e-16 4.18854e-17 -1\n"
++"-1.15079e-16 -4.18854e-17 -1\n"
++"-6.12323e-17 -1.06058e-16 -1\n"
++"2.12658e-17 -1.20604e-16 -1\n"
++"9.38134e-17 -7.87188e-17 -1\n"
++"1.22465e-16 -2.99952e-32 -1\n"
++" }\n"
++"}\n";
++
++static char *xyz = "{\n"
++"=\n"
++"VECT\n"
++"8 19 3\n"
++"2 2 2 2 2 3 2 4\n"
++"1 0 0 1 0 0 1 0\n"
++"\n"
++"0 0 0 1 0 0\n"
++"1 -.05 .05 1 .05 .25\n"
++"1 .05 .05 1 -.05 .25\n"
++"\n"
++"0 0 0 0 1 0\n"
++"-.05 1 .25 0 1 .15\n"
++" .05 1 .25 0 1 .15 0 1 .05\n"
++"\n"
++"0 0 0 0 0 1\n"
++"-.05 .25 1 .05 .25 1 -.05 .05 1 .05 .05 1\n"
++"\n"
++"1 0 0 1\n"
++"0 1 0 1\n"
++"0 .6 1 1\n}";
++
++static char *origin = "\n"
++"unit { \n"
++" { VECT\n"
++"8 19 3\n"
++"2 2 2 2 2 3 2 4\n"
++"1 0 0 1 0 0 1 0\n"
++"\n"
++"0 0 0 1 0 0\n"
++"1 -.05 .05 1 .05 .25\n"
++"1 .05 .05 1 -.05 .25\n"
++"\n"
++"0 0 0 0 1 0\n"
++"-.05 1 .25 0 1 .15\n"
++" .05 1 .25 0 1 .15 0 1 .05\n"
++"\n"
++"0 0 0 0 0 1\n"
++"-.05 .25 1 .05 .25 1 -.05 .05 1 .05 .05 1\n"
++"\n"
++"1 0 0 1\n"
++"0 1 0 1\n"
++"0 .6 1 1\n"
++" }\n"
++"}\n";
++
++static char *color1 = "\n"
++"0.26 0.7 0.7 1"
++"\n}\n";
++
++static char *fzold = "\n"
++"unit { \n"
++" { VECT\n"
++"3 6 1\n"
++"2 2 2\n"
++"1 0 0\n"
++"\n"
++"0 0 0 0 0 0.5\n"
++".05 0 .4 0 0 0.5\n"
++"0 0 0.5 -.05 0 .4\n"
++"\n"
++"1 0 0 1\n"
++" }\n"
++"}\n";
++
++static char *fz = "\n"
++"unit { \n"
++" { VECT\n"
++"5 10 1\n"
++"2 2 2 2 2\n"
++"1 0 0 0 0\n"
++"\n"
++"0 0 0 0 0 0.5\n"
++".05 0 .4 0 0 0.5\n"
++"0 0 0.5 -.05 0 .4\n"
++"0 .05 .4 0 0 0.5\n"
++"0 0 0.5 0 -.05 .4\n"
++"\n"
++"1 0 0 1\n"
++" }\n"
++"}\n";
++
++static char *constraint = "\n"
++"unit { \n"
++" { OFF\n"
++" 5 2 6\n"
++" 0 0 0\n"
++" -.1 0 .3\n"
++" .1 0 .3\n"
++" 0 -.1 .3\n"
++" 0 .1 .3\n"
++" 3 0 1 2 1 0 0 1\n"
++" 3 0 3 4 1 0 0 1\n"
++"\n"
++" }\n"
++"}\n";
++
++static char *constraintrot = "\n"
++"unit { \n"
++" { OFF\n"
++" 10 4 12\n"
++" 0 0 0\n"
++" -.07 -.07 .3\n"
++" .07 .07 .3\n"
++" -.07 .07 .3\n"
++" .07 -.07 .3\n"
++" 0 0 .3\n"
++" -.07 -.07 .6\n"
++" .07 .07 .6\n"
++" -.07 .07 .6\n"
++" .07 -.07 .6\n"
++" 3 0 1 2 0 1 0 1 \n"
++" 3 0 3 4 0 1 0 1 \n"
++" 3 5 6 7 0 1 0 1 \n"
++" 3 5 8 9 0 1 0 1 \n"
++"\n"
++" }\n"
++"}\n";
++
++static char *cross = "\n"
++"unit { \n"
++" { VECT\n"
++"3 6 1\n"
++"2 2 2\n"
++"1 0 0\n"
++"\n"
++"-.1 0 0 .1 0 0\n"
++"0 -.1 0 0 .1 0\n"
++"0 0 -.1 0 0 .1\n"
++"\n"
++"1 1 1 1\n"
++" }\n"
++"}\n";
++
++static char *transformz = "\n"
++"INST\n"
++" transform\n"
++" 1 0 0 0\n"
++" 0 1 0 0\n"
++" 0 0 1 0\n";
++
++static char *transformx = "\n"
++"INST\n"
++" transform\n"
++" 0 1 0 0\n"
++" 0 0 1 0\n"
++" 1 0 0 0\n";
++
++static char *transformy = "\n"
++"INST\n"
++" transform\n"
++" 0 0 1 0\n"
++" 1 0 0 0\n"
++" 0 1 0 0\n";
+
+-static char *zero = " \nunit { { VECT 2 11 1 2 9 1 0 0 20 0 28 56 0 24 0 0 8 0 0 0 8 0 0 48 0 8 64 0
+-24 64 0 32 52 0 32 12 0 24 0 0 1 1 1 1}} ";
++static char *zero = " \nunit { { VECT 2 11 1 2 9 1 0 0 20 0 28 56 0 24 0 0 8 0 0 0 8 0 0 48 0 8 64 0 24 64 0 32 52 0 32 12 0 24 0 0 1 1 1 1}} ";
+ static char *one = " \nunit { { VECT 2 5 1 2 3 1 0 4 0 0 28 0 0 4 44 0 16 64 0 16 0 0 1 1 1 1} } ";
+-static char *two = " \nunit { { VECT 1 7 1 7 1 0 56 0 8 64 0 24 64 0 32 56 0 32 40 0 0 0 0 32 0 0 1
+-1 1 1} } ";
+-static char *three = " \nunit { { VECT 2 13 1 2 11 1 0 8 36 0 24 36 0 0 56 0 8 64 0 24 64 0 32 56 0
+-32 44 0 24 36 0 32 24 0 32 8 0 24 0 0 8 0 0 0 8 0 1 1 1 1} } ";
+-static char *four = " \nunit { { VECT 2 5 1 2 3 1 0 28 64 0 28 0 0 12 64 0 0 36 0 36 36 0 1 1 1 1} }
+-";
+-static char *five = " \nunit { { VECT 1 9 1 9 1 28 64 0 4 64 0 0 36 0 24 36 0 32 24 0 32 8 0 24 0 0
+-8 0 0 0 8 0 1 1 1 1} } ";
+-static char *six = " \nunit { { VECT 1 12 1 12 1 32 56 0 24 64 0 8 64 0 0 56 0 0 8 0 8 0 0 24 0 0
+-32 8 0 32 28 0 24 36 0 8 36 0 0 28 0 1 1 1 1} } ";
++static char *two = " \nunit { { VECT 1 7 1 7 1 0 56 0 8 64 0 24 64 0 32 56 0 32 40 0 0 0 0 32 0 0 1 1 1 1} } ";
++static char *three = " \nunit { { VECT 2 13 1 2 11 1 0 8 36 0 24 36 0 0 56 0 8 64 0 24 64 0 32 56 0 32 44 0 24 36 0 32 24 0 32 8 0 24 0 0 8 0 0 0 8 0 1 1 1 1} } ";
++static char *four = " \nunit { { VECT 2 5 1 2 3 1 0 28 64 0 28 0 0 12 64 0 0 36 0 36 36 0 1 1 1 1} } ";
++static char *five = " \nunit { { VECT 1 9 1 9 1 28 64 0 4 64 0 0 36 0 24 36 0 32 24 0 32 8 0 24 0 0 8 0 0 0 8 0 1 1 1 1} } ";
++static char *six = " \nunit { { VECT 1 12 1 12 1 32 56 0 24 64 0 8 64 0 0 56 0 0 8 0 8 0 0 24 0 0 32 8 0 32 28 0 24 36 0 8 36 0 0 28 0 1 1 1 1} } ";
+ static char *seven = " \nunit { { VECT 1 4 1 4 1 0 56 0 4 64 0 32 64 0 8 0 0 1 1 1 1} } ";
+-static char *eight = " \nunit { { VECT 1 16 1 16 1 20 36 0 28 44 0 28 56 0 20 64 0 12 64 0 4 56 0 4
+-44 0 12 36 0 20 36 0 32 24 0 32 8 0 24 0 0 8 0 0 0 8 0 0 24 0 12 36 0 1 1 1 1} } ";
+-static char *nine = " \nunit { { VECT 1 12 1 12 1 32 44 0 24 36 0 8 36 0 0 44 0 0 56 0 8 64 0 24 64
+-0 32 56 0 32 8 0 24 0 0 8 0 0 0 8 0 1 1 1 1} } ";
++static char *eight = " \nunit { { VECT 1 16 1 16 1 20 36 0 28 44 0 28 56 0 20 64 0 12 64 0 4 56 0 4 44 0 12 36 0 20 36 0 32 24 0 32 8 0 24 0 0 8 0 0 0 8 0 0 24 0 12 36 0 1 1 1 1} } ";
++static char *nine = " \nunit { { VECT 1 12 1 12 1 32 44 0 24 36 0 8 36 0 0 44 0 0 56 0 8 64 0 24 64 0 32 56 0 32 8 0 24 0 0 8 0 0 0 8 0 1 1 1 1} } ";
diff --git a/science/felt/files/patch-src+Velvet+opengl+c b/science/felt/files/patch-src+Velvet+opengl+c
new file mode 100644
index 000000000000..1a01fc938dd9
--- /dev/null
+++ b/science/felt/files/patch-src+Velvet+opengl+c
@@ -0,0 +1,10 @@
+--- src/Velvet/opengl.c.orig Sun Jul 27 17:27:34 2003
++++ src/Velvet/opengl.c Sun Jul 27 17:27:45 2003
+@@ -35,7 +35,6 @@
+ #include <X11/Shell.h>
+ #include <X11/Xaw/Command.h>
+ #include <X11/Xaw/Toggle.h>
+-#include <GL/xmesa.h>
+ #include <GL/gl.h>
+ #include <GL/glu.h>
+ #include <GL/GLwDrawA.h>
diff --git a/science/felt/pkg-plist b/science/felt/pkg-plist
index 054672281479..d61d3a2beab2 100644
--- a/science/felt/pkg-plist
+++ b/science/felt/pkg-plist
@@ -5,11 +5,13 @@ bin/loom
bin/patchwork
bin/velvet
bin/yardstick
-lib/X11/app-defaults/Velvet.ad
share/doc/FElt/FAQ.html
@dirrm share/doc/FElt
share/examples/FElt/frame3.flt
share/examples/FElt/beam3d_b.flt
+share/examples/FElt/brick_ring.flt
+share/examples/FElt/brick_cap.flt
+share/examples/FElt/brick_beam.flt
share/examples/FElt/bridge.flt
share/examples/FElt/cube.flt
share/examples/FElt/iso.flt
@@ -103,4 +105,3 @@ share/felt/german.trn
share/felt/german_new.trn
share/felt/spanish.trn
@dirrm share/felt
-