aboutsummaryrefslogtreecommitdiff
path: root/security/Makefile
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@FreeBSD.org>2008-06-01 20:58:23 +0000
committerHenrik Brix Andersen <brix@FreeBSD.org>2008-06-01 20:58:23 +0000
commit5fbae18db0a0e0f07562b16d5e69000fc9ee476f (patch)
tree609a5c857d6bf4c628cadc4407b6042cd080ff33 /security/Makefile
parent5b499869dfc23cf44ee09c7c479a88a9033581b4 (diff)
downloadports-5fbae18db0a0e0f07562b16d5e69000fc9ee476f.tar.gz
ports-5fbae18db0a0e0f07562b16d5e69000fc9ee476f.zip
Eksblowfish is a variant of the Blowfish cipher, modified to make the
key setup very expensive. ("Eks" stands for "expensive key schedule".) This doesn't make it significantly cryptographically stronger, but is intended to hinder brute-force attacks. It also makes it unsuitable for any application requiring key agility. It was designed by Niels Provos and David Mazieres for password hashing in OpenBSD. Eksblowfish is a parameterised (family-keyed) cipher. It takes a cost parameter that controls how expensive the key scheduling is. It also takes a family key, known as the "salt". Cost and salt parameters together define a cipher family. Within each family, a key determines an encryption function in the usual way. This distribution also includes an implementation of "bcrypt", the Unix crypt() password hashing algorithm based on Eksblowfish. WWW: http://search.cpan.org/dist/Crypt-Eksblowfish/ Approved by: erwin (mentor)
Notes
Notes: svn path=/head/; revision=214152
Diffstat (limited to 'security/Makefile')
-rw-r--r--security/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 098865e5b024..5a61892b2f26 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -379,6 +379,7 @@
SUBDIR += p5-Crypt-DSA
SUBDIR += p5-Crypt-Dining
SUBDIR += p5-Crypt-ECB
+ SUBDIR += p5-Crypt-Eksblowfish
SUBDIR += p5-Crypt-Enigma
SUBDIR += p5-Crypt-GCrypt
SUBDIR += p5-Crypt-GOST