aboutsummaryrefslogtreecommitdiff
path: root/security/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-05 00:12:57 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-05 00:12:57 +0000
commit7e45300e38fd5feba84c6d4da0c94b81fe10df9a (patch)
treee7d2edf5d8cdca64b9e42d6137b56f8a52b6cf64 /security/Makefile
parent5596362958285b2f49963e19682ae48acde38690 (diff)
downloadports-7e45300e38fd5feba84c6d4da0c94b81fe10df9a.tar.gz
ports-7e45300e38fd5feba84c6d4da0c94b81fe10df9a.zip
Taking a hint from the similarly-named Java Cryptography Architecture,
QCA aims to provide a straightforward and cross-platform crypto API, using Qt datatypes and conventions. QCA separates the API from the implementation, using plugins known as Providers. The advantage of this model is to allow applications to avoid linking to or explicitly depending on any particular cryptographic library. This allows one to easily change or upgrade crypto implementations without even needing to recompile the application. QCA should work everywhere Qt does, including Windows/Unix/MacOSX. Capabilities: TLS, CMS, X.509, RSA, DSA, Diffie-Hellman, PKCS#7, PKCS#12, SHA0, SHA1, SHA224, SHA256, SHA384, SHA512, MD2, MD4, MD5, RIPEMD160, Blowfish, DES, 3DES, AES128, AES192, AES256, CAST5, HMAC(SHA1, MD5, RIPEMD160), PBKDF1(MD2, SHA1), PBKDF2(SHA1) WWW: http://delta.affinix.com/qca/
Notes
Notes: svn path=/head/; revision=218046
Diffstat (limited to 'security/Makefile')
-rw-r--r--security/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index ddbc5e8e227a..9a3b6807899f 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -645,6 +645,7 @@
SUBDIR += py-twistedConch
SUBDIR += py-twofish
SUBDIR += py-xmlsec
+ SUBDIR += qca-ossl
SUBDIR += qca-tls
SUBDIR += qident
SUBDIR += qtfw