aboutsummaryrefslogtreecommitdiff
path: root/security/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-12-21 15:40:50 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-12-21 15:40:50 +0000
commit89a50ab6386a57ca49265fc79f8f3251c0327686 (patch)
tree5463e92f28d14c2168c5eabee7343106cefe3ea2 /security/Makefile
parenta0ef1b0ad62b84dc70476e76dca9579ed72ef1b3 (diff)
downloadports-89a50ab6386a57ca49265fc79f8f3251c0327686.tar.gz
ports-89a50ab6386a57ca49265fc79f8f3251c0327686.zip
This module contains a simple S/Key calculator (as described in RFC
1760) implemented in Perl. It exports the function `key' by default, and may optionally export the function `compute'. `compute_md4', `compute_md5', `key_md4', and `key_md5' are provided as convenience functions for selecting either MD4 or MD5 hashes. The default is MD4; this may be changed with with the `$Crypt::SKey::HASH' variable, assigning it the value of `MD4' or `MD5'. You can access any of these functions by exporting them in the same manner as `compute' in the above example. Most S/Key systems use MD4 hashing, but a few (notably OPIE) use MD5. WWW: http://search.cpan.org/dist/Crypt-SKey PR: ports/90695 Submitted by: Gabor Kovesdan
Notes
Notes: svn path=/head/; revision=151763
Diffstat (limited to 'security/Makefile')
-rw-r--r--security/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 2946e072964a..1053c4736628 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -337,6 +337,7 @@
SUBDIR += p5-Crypt-RandPasswd
SUBDIR += p5-Crypt-Random
SUBDIR += p5-Crypt-Rijndael
+ SUBDIR += p5-Crypt-SKey
SUBDIR += p5-Crypt-SSLeay
SUBDIR += p5-Crypt-Serpent
SUBDIR += p5-Crypt-SmbHash