aboutsummaryrefslogtreecommitdiff
path: root/security/aide
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2004-03-11 21:48:10 +0000
committerCy Schubert <cy@FreeBSD.org>2004-03-11 21:48:10 +0000
commit6cb09956af342628f8fef2e93237cb2c15974d30 (patch)
tree7dd2502a6207acb8adbf3c211b94389462f19b0d /security/aide
parent77abf57463e13e3c05c46d19f2998b41e6b4acb9 (diff)
downloadports-6cb09956af342628f8fef2e93237cb2c15974d30.tar.gz
ports-6cb09956af342628f8fef2e93237cb2c15974d30.zip
Update aide 0.9 --> 0.10.
Notes
Notes: svn path=/head/; revision=103693
Diffstat (limited to 'security/aide')
-rw-r--r--security/aide/Makefile20
-rw-r--r--security/aide/distinfo2
-rw-r--r--security/aide/files/patch-config.h.in11
-rw-r--r--security/aide/files/patch-configure10
-rw-r--r--security/aide/files/patch-src::conf_yacc.y67
5 files changed, 33 insertions, 77 deletions
diff --git a/security/aide/Makefile b/security/aide/Makefile
index a5963004f302..3c585a99d9d7 100644
--- a/security/aide/Makefile
+++ b/security/aide/Makefile
@@ -6,17 +6,29 @@
#
PORTNAME= aide
-PORTVERSION= 0.9
-PORTREVISION= 1
+PORTVERSION= 0.10
CATEGORIES= security
-MASTER_SITES= http://www.cs.tut.fi/~rammer/ \
- ftp://ftp.cs.tut.fi/pub/src/gnu/
+MASTER_SITE_SOURCEFORGE+= http://unc.dl.sourceforge.net/%SUBDIR%/ \
+ http://umn.dl.sourceforge.net/%SUBDIR%/ \
+ http://twtelecom.dl.sourceforge.net/%SUBDIR%/ \
+ http://aleron.dl.sourceforge.net/%SUBDIR%/ \
+ http://easynews.dl.sourceforge.net/%SUBDIR%/ \
+ http://switch.dl.sourceforge.net/%SUBDIR%/ \
+ http://cesnet.dl.sourceforge.net/%SUBDIR%/ \
+ http://flow.dl.sourceforge.net/%SUBDIR%/ \
+ http://keihanna.dl.sourceforge.net/%SUBDIR%/ \
+ http://heanet.dl.sourceforge.net/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://www.cs.tut.fi/~rammer/ \
+
MAINTAINER= cy@FreeBSD.org
COMMENT= A replacement and extension for Tripwire
LIB_DEPENDS= mhash.2:${PORTSDIR}/security/mhash
+USE_GMAKE= yes
USE_BISON= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-mhash \
diff --git a/security/aide/distinfo b/security/aide/distinfo
index 73bce195d4ce..78ab0f1b76b8 100644
--- a/security/aide/distinfo
+++ b/security/aide/distinfo
@@ -1 +1 @@
-MD5 (aide-0.9.tar.gz) = 877b1f515a9e25afda75e06805d687fb
+MD5 (aide-0.10.tar.gz) = 39eb7d21064cac7b409c45d038b86cd8
diff --git a/security/aide/files/patch-config.h.in b/security/aide/files/patch-config.h.in
new file mode 100644
index 000000000000..7a08dddf8531
--- /dev/null
+++ b/security/aide/files/patch-config.h.in
@@ -0,0 +1,11 @@
+--- config.h.in.orig Fri Nov 28 07:14:07 2003
++++ config.h.in Sat Jan 3 20:28:39 2004
+@@ -56,7 +56,7 @@
+ #define AIDE_STAT_TYPE stat
+ #define AIDE_INO_TYPE ino_t
+ #define AIDE_OFF_TYPE off_t
+-#define AIDE_BLKCNT_TYPE blkcnt_t
++#define AIDE_BLKCNT_TYPE int32_t
+
+ /* Defines for READDIR64 */
+ #define AIDE_READDIR_FUNC readdir
diff --git a/security/aide/files/patch-configure b/security/aide/files/patch-configure
index 01cc535cc2c2..7bb06ca03a0a 100644
--- a/security/aide/files/patch-configure
+++ b/security/aide/files/patch-configure
@@ -1,11 +1,11 @@
---- configure.orig Tue Jun 4 01:31:27 2002
-+++ configure Fri Jul 12 06:13:48 2002
-@@ -2838,7 +2838,7 @@
+--- configure.orig Fri Nov 28 07:14:08 2003
++++ configure Sat Jan 3 20:21:15 2004
+@@ -2885,7 +2885,7 @@
EOF
- cat >> confdefs.h <<EOF
+ cat >> confdefs.h <<EOF
-#define AIDE_BLKCNT_TYPE blkcnt_t
+#define AIDE_BLKCNT_TYPE int32_t
EOF
- compoptionstring="${compoptionstring}WITH_LSTAT\\n"
+ cat >> confdefs.h <<EOF
diff --git a/security/aide/files/patch-src::conf_yacc.y b/security/aide/files/patch-src::conf_yacc.y
deleted file mode 100644
index a517d3cbb142..000000000000
--- a/security/aide/files/patch-src::conf_yacc.y
+++ /dev/null
@@ -1,67 +0,0 @@
---- src/conf_yacc.y.orig Wed May 29 01:04:27 2002
-+++ src/conf_yacc.y Wed Nov 6 17:27:11 2002
-@@ -180,7 +180,7 @@
- conferror("Error in expression");
- YYABORT;
- }
-- }
-+ } ;
-
- other : TRIGHTS { $$ =$1 ;} | TUSER {$$ =$1 ;}
- | TGROUP {$$ =$1 ;} | TINODE {$$ =$1 ;}
-@@ -242,11 +242,11 @@
- beginconfigstmt : TBEGIN_CONFIG TSTRING {
- conf->do_configmd=1;
- conf->old_confmdstr=strdup($2);
--}
-+} ;
-
- endconfigstmt : TEND_CONFIG {
- YYACCEPT;
--}
-+} ;
-
- acl_no_symlink_follow : TACLNOSYMLINKFOLLOW TTRUE {
- #ifdef WITH_ACL
-@@ -254,7 +254,7 @@
- #else
- error(0,"ACL-support not compiled in.\n");
- #endif
--}
-+} ;
-
- acl_no_symlink_follow : TACLNOSYMLINKFOLLOW TFALSE {
- #ifdef WITH_ACL
-@@ -262,15 +262,15 @@
- #else
- error(0,"ACL-support not compiled in.\n");
- #endif
--}
-+} ;
-
- warn_dead_symlinks : TWARNDEADSYMLINKS TTRUE {
- conf->warn_dead_symlinks=1;
--}
-+} ;
-
- warn_dead_symlinks : TWARNDEADSYMLINKS TFALSE {
- conf->warn_dead_symlinks=0;
--}
-+} ;
-
- gzipdbout : TGZIPDBOUT TTRUE {
- #ifdef WITH_ZLIB
-@@ -288,11 +288,11 @@
- recursion_stopper : TRECSTOP TSTRING {
- /* FIXME implement me */
-
--}
-+} ;
-
- config_version : TCONFIG_VERSION TSTRING {
- conf->config_version=strdup($2);
--}
-+} ;
-
- %%
-