aboutsummaryrefslogtreecommitdiff
path: root/security/barnyard/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-01-04 12:48:37 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-01-04 12:48:37 +0000
commitaffb1ff4f4e10620e0649fea3163734ce5aca72f (patch)
tree5a3964601b6cf45bf6b228846b71fcf583be643a /security/barnyard/Makefile
parente120719ae7e3e38c6b0b0c36805dbf5317e1f56b (diff)
downloadports-affb1ff4f4e10620e0649fea3163734ce5aca72f.tar.gz
ports-affb1ff4f4e10620e0649fea3163734ce5aca72f.zip
- Patches for 64-bit systems
- Toggle MySQL option to default to 'on' PR: ports/118873 Submitted by: Paul Schmehl <pauls@utdallas.edu> (maintainer)
Notes
Notes: svn path=/head/; revision=204981
Diffstat (limited to 'security/barnyard/Makefile')
-rw-r--r--security/barnyard/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/security/barnyard/Makefile b/security/barnyard/Makefile
index 08246b8fa412..ddb37d8abda3 100644
--- a/security/barnyard/Makefile
+++ b/security/barnyard/Makefile
@@ -7,7 +7,7 @@
PORTNAME= barnyard
PORTVERSION= 0.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= barnyard
@@ -17,7 +17,7 @@ COMMENT?= An output system for Snort
RUN_DEPENDS+= ${LOCALBASE}/bin/snort:${PORTSDIR}/security/snort
-OPTIONS= MYSQL "Enable MySQL support" off \
+OPTIONS= MYSQL "Enable MySQL support" on \
POSTGRESQL "Enable PostgreSQL support" off
USE_AUTOTOOLS= autoheader:261 aclocal:19
@@ -43,6 +43,14 @@ USE_PGSQL= yes
CONFIGURE_ARGS+= --enable-postgres
.endif
+.if ${ARCH} == "amd64" || ${ARCH} =="ia64" || ${ARCH} == "sparc64"
+EXTRA_PATCHES+= ${FILESDIR}/64-bit-barnyard.h \
+ ${FILESDIR}/64-bit-input-plugins-dp-alert.h \
+ ${FILESDIR}/64-bit-util.h \
+ ${FILESDIR}/64-bit-event.h \
+ ${FILESDIR}/64-bit-util.c
+.endif
+
post-install:
.for f in barnyard.conf