aboutsummaryrefslogtreecommitdiff
path: root/security/belier
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-06-25 10:18:14 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-06-25 10:18:14 +0000
commitd4095d062b90f8033e55dde830fec4e6e5440324 (patch)
treef137c2b9c1a96cc08ff4e4377e1c2074e8239602 /security/belier
parent9a1787d9c96a97135dab958fc78b9761cec658e5 (diff)
downloadports-d4095d062b90f8033e55dde830fec4e6e5440324.tar.gz
ports-d4095d062b90f8033e55dde830fec4e6e5440324.zip
Belier allows opening a shell or executing a command on a remote computer
through a SSH connection. The main feature of Belier is its ability to cross several intermediate computers before realizing the job. WWW: http://www.ohmytux.com/belier/index.html PR: ports/156757 Submitted by: rokaz
Notes
Notes: svn path=/head/; revision=276365
Diffstat (limited to 'security/belier')
-rw-r--r--security/belier/Makefile41
-rw-r--r--security/belier/distinfo2
-rw-r--r--security/belier/pkg-descr5
3 files changed, 48 insertions, 0 deletions
diff --git a/security/belier/Makefile b/security/belier/Makefile
new file mode 100644
index 000000000000..50aab664667b
--- /dev/null
+++ b/security/belier/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: belier
+# Date created: 1 May 2011
+# Whom: rokaz
+#
+# $FreeBSD$
+#
+
+PORTNAME= belier
+PORTVERSION= 1.2
+CATEGORIES= security net
+MASTER_SITES= http://www.ohmytux.com/belier/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= romain.garbage@gmail.com
+COMMENT= easily cross several machines with ssh
+
+RUN_DEPENDS= expect>=5.42.1:${PORTSDIR}/lang/expect
+
+PLIST_FILES= lib/${PYTHON_VERSION}/site-packages/belier/corps.pyo \
+ lib/${PYTHON_VERSION}/site-packages/belier/terminal.pyc \
+ lib/${PYTHON_VERSION}/site-packages/belier/options.pyo \
+ lib/${PYTHON_VERSION}/site-packages/belier/corps.py \
+ lib/${PYTHON_VERSION}/site-packages/belier/__init__.pyo \
+ lib/${PYTHON_VERSION}/site-packages/belier/optionstunnel.pyc \
+ lib/${PYTHON_VERSION}/site-packages/belier/terminal.py \
+ lib/${PYTHON_VERSION}/site-packages/belier/__init__.py \
+ lib/${PYTHON_VERSION}/site-packages/belier/corps.pyc \
+ lib/${PYTHON_VERSION}/site-packages/belier/optionstunnel.py \
+ lib/${PYTHON_VERSION}/site-packages/belier/terminal.pyo \
+ lib/${PYTHON_VERSION}/site-packages/belier/options.pyc \
+ lib/${PYTHON_VERSION}/site-packages/belier/__init__.pyc \
+ lib/${PYTHON_VERSION}/site-packages/belier/options.py \
+ lib/${PYTHON_VERSION}/site-packages/belier/optionstunnel.pyo \
+ bin/bel \
+ share/locale/fr/LC_MESSAGES/bel.mo
+PLIST_DIRS= lib/${PYTHON_VERSION}/site-packages/belier
+
+USE_PYTHON= 2.6+
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/security/belier/distinfo b/security/belier/distinfo
new file mode 100644
index 000000000000..a11dd824a071
--- /dev/null
+++ b/security/belier/distinfo
@@ -0,0 +1,2 @@
+SHA256 (belier-1.2.tar.gz) = 9fe20425d0e061112c38288ce105bc7905a55c22836e801b310541b56e4df409
+SIZE (belier-1.2.tar.gz) = 9774
diff --git a/security/belier/pkg-descr b/security/belier/pkg-descr
new file mode 100644
index 000000000000..a988f0787977
--- /dev/null
+++ b/security/belier/pkg-descr
@@ -0,0 +1,5 @@
+Belier allows opening a shell or executing a command on a remote computer
+through a SSH connection. The main feature of Belier is its ability to cross
+several intermediate computers before realizing the job.
+
+WWW: http://www.ohmytux.com/belier/index.html