aboutsummaryrefslogtreecommitdiff
path: root/security/bro
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1998-12-24 17:52:35 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1998-12-24 17:52:35 +0000
commit6f5d9a41a4255eca274b6923ab3d34c10165d615 (patch)
tree1f0daf4f24e8be78ac5ed8267447b6fea9c3a34e /security/bro
parentdee9bfa75a638eb84e7088692b33d71afae432d0 (diff)
downloadports-6f5d9a41a4255eca274b6923ab3d34c10165d615.tar.gz
ports-6f5d9a41a4255eca274b6923ab3d34c10165d615.zip
Attempt to not "exit 1" if the distfile is missing. Otherwise batch fetching
of distfiles is harder than I would like.
Notes
Notes: svn path=/head/; revision=15595
Diffstat (limited to 'security/bro')
-rw-r--r--security/bro/Makefile17
1 files changed, 5 insertions, 12 deletions
diff --git a/security/bro/Makefile b/security/bro/Makefile
index d508a405dc46..2a975fe04480 100644
--- a/security/bro/Makefile
+++ b/security/bro/Makefile
@@ -4,7 +4,7 @@
# Date created: Sat Feb 28, 1998
# Whom: David O'Brien (obrien@FreeBSD.org)
#
-# $Id: Makefile,v 1.5 1998/09/14 00:20:20 obrien Exp $
+# $Id: Makefile,v 1.6 1998/11/04 18:45:38 obrien Exp $
#
DISTNAME= vp-bro-0.4-alpha
@@ -16,22 +16,15 @@ MAINTAINER= obrien@FreeBSD.org
RESTRICTED= "Author wishes Alpha releases not to be distrubted."
+.if !exists(${DISTDIR}/vp-bro-0.4-alpha${EXTRACT_SUFX})
+IGNORE='Please contact Vern Paxson <vern@ee.lbl.gov> to obtain the obtain the Bro source. Put it in ${DISTDIR} as vp-bro-0.4-alpha${EXTRACT_SUFX} and run make again'
+.endif
+
IS_INTERACTIVE= "manual fetch"
WRKSRC= ${WRKDIR}/bro-0.4
CONFIGURE_ARGS= --libdir=${PREFIX}/share
GNU_CONFIGURE= yes
-do-fetch:
- @if [ ! -f ${DISTDIR}/vp-bro-0.4-alpha${EXTRACT_SUFX} ]; then \
- echo ""; \
- echo "Please contact Vern Paxson <vern@ee.lbl.gov>"; \
- echo "to obtain the obtain the Bro source. Put it in"; \
- echo "${DISTDIR} as vp-bro-0.4-alpha${EXTRACT_SUFX}"; \
- echo "and run make again"; \
- echo ""; \
- exit 1;\
- fi
-
post-patch:
@${MV} ${WRKSRC}/util.cc ${WRKSRC}/util.cc.in
@${SED} -e "s|/usr/src/rtsg/bro/policy:/usr/local/lib/bro|${PREFIX}/share/bro|" \