aboutsummaryrefslogtreecommitdiff
path: root/security/ccsrch
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-09-23 02:38:24 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-09-23 02:38:24 +0000
commit6b2d4ba937f633db0fbd609abfcc64ed875488e2 (patch)
tree6d3bbfe84a9ab605b9c51851e7cb64df03ae594f /security/ccsrch
parenta82cc513cc766dee89ab3bd5948f4ff4773d5c5b (diff)
downloadports-6b2d4ba937f633db0fbd609abfcc64ed875488e2.tar.gz
ports-6b2d4ba937f633db0fbd609abfcc64ed875488e2.zip
ccsrch is a tool that searches for and identifies unencrypted and
contiguous credit card numbers (PAN) and track data on windows and UNIX operating systems. It will also identify the location of the PAN data in the files and record MAC times. WWW: http://ccsrch.sourceforge.net/ PR: ports/148821 Submitted by: Pavel I Volkov <pavelivolkov at googlemail.com>
Notes
Notes: svn path=/head/; revision=261669
Diffstat (limited to 'security/ccsrch')
-rw-r--r--security/ccsrch/Makefile37
-rw-r--r--security/ccsrch/distinfo3
-rw-r--r--security/ccsrch/files/patch-Makefile13
-rw-r--r--security/ccsrch/pkg-descr6
4 files changed, 59 insertions, 0 deletions
diff --git a/security/ccsrch/Makefile b/security/ccsrch/Makefile
new file mode 100644
index 000000000000..c55373924d8c
--- /dev/null
+++ b/security/ccsrch/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: ccsrch
+# Date created: 2010-07-21
+# Whom: Pavel I Volkov <pavelivolkov@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ccsrch
+PORTVERSION= 1.0.3
+CATEGORIES= security
+MASTER_SITES= http://downloads.sourceforge.net/project/${MASTER_SITE_SUBDIR}/
+MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}/Version%20${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= pavelivolkov@googlemail.com
+COMMENT= Is a tool that searches for credit card numbers (PAN) and track data
+
+FETCH_ARGS= -pRr
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+PORTDOCS= README readme.html
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}; \
+ for f in ${PORTDOCS}; do \
+ ${INSTALL_DATA} ${WRKSRC}/$$f ${DOCSDIR}; \
+ done
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/ccsrch/distinfo b/security/ccsrch/distinfo
new file mode 100644
index 000000000000..d2a4da63e5b5
--- /dev/null
+++ b/security/ccsrch/distinfo
@@ -0,0 +1,3 @@
+MD5 (ccsrch-1.0.3.tgz) = a876d497b320b1d1ee36ff0f5ee36ee8
+SHA256 (ccsrch-1.0.3.tgz) = 07c0c1ad4952cf11ecd4e10ad3e5a9697891691e5963867de6f180592231ccfc
+SIZE (ccsrch-1.0.3.tgz) = 18047
diff --git a/security/ccsrch/files/patch-Makefile b/security/ccsrch/files/patch-Makefile
new file mode 100644
index 000000000000..83f1aeee659a
--- /dev/null
+++ b/security/ccsrch/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig 2010-07-21 17:35:58.000000000 +0400
++++ Makefile 2010-07-21 17:36:21.000000000 +0400
+@@ -29,8 +29,8 @@
+ #
+ # for *UNIX* the following tends to work
+ INCL = -I./
+-CFLAGS =-O2 -static
+-#CFLAGS =-O2 # for linux
++#CFLAGS =-O2 -static
++CFLAGS =-O2 # for linux
+ #CFLAGS =-DDEBUG # if you want a lot of noise
+ LDFLAGS =-s
+ OBJS= ccsrch.o
diff --git a/security/ccsrch/pkg-descr b/security/ccsrch/pkg-descr
new file mode 100644
index 000000000000..9b16fc4252db
--- /dev/null
+++ b/security/ccsrch/pkg-descr
@@ -0,0 +1,6 @@
+ccsrch is a tool that searches for and identifies unencrypted and
+contiguous credit card numbers (PAN) and track data on windows and
+UNIX operating systems. It will also identify the location of the
+PAN data in the files and record MAC times.
+
+WWW: http://ccsrch.sourceforge.net/