aboutsummaryrefslogtreecommitdiff
path: root/security/cfv
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-20 09:07:39 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-20 09:07:39 +0000
commit172b30f771b33acaa89cc6946d5a4f8897c4a218 (patch)
treecf818befc743b6d7e17500652d78046ebd237a8e /security/cfv
parent78405deff0a16ade45766d98071159105fecec7b (diff)
downloadports-172b30f771b33acaa89cc6946d5a4f8897c4a218.tar.gz
ports-172b30f771b33acaa89cc6946d5a4f8897c4a218.zip
add cfv
cfv is a utility to both test and create .sfv, .csv and md5sum files
Notes
Notes: svn path=/head/; revision=45272
Diffstat (limited to 'security/cfv')
-rw-r--r--security/cfv/Makefile28
-rw-r--r--security/cfv/distinfo1
-rw-r--r--security/cfv/files/patch-Makefile18
-rw-r--r--security/cfv/pkg-comment1
-rw-r--r--security/cfv/pkg-descr14
-rw-r--r--security/cfv/pkg-plist4
6 files changed, 66 insertions, 0 deletions
diff --git a/security/cfv/Makefile b/security/cfv/Makefile
new file mode 100644
index 000000000000..112cb0c060ee
--- /dev/null
+++ b/security/cfv/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# New ports collection makefile for: cfv
+# Date created: Jul 20, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= cfv
+PORTVERSION= 1.8
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/fchksum.so:${PORTSDIR}/security/py-fchksum
+
+USE_PYTHON= yes
+ALL_TARGET= cfv.wrapper
+INSTALL_TARGET= install-wrapper
+
+MAN1= cfv.1
+
+post-patch:
+ @${PERL} -pi -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/security/cfv/distinfo b/security/cfv/distinfo
new file mode 100644
index 000000000000..58cc643baea9
--- /dev/null
+++ b/security/cfv/distinfo
@@ -0,0 +1 @@
+MD5 (cfv-1.8.tar.gz) = ab9aeb688709187e42c995c97ef4411a
diff --git a/security/cfv/files/patch-Makefile b/security/cfv/files/patch-Makefile
new file mode 100644
index 000000000000..1a0d0e66a7ff
--- /dev/null
+++ b/security/cfv/files/patch-Makefile
@@ -0,0 +1,18 @@
+--- Makefile.orig Fri Jul 20 16:53:10 2001
++++ Makefile Fri Jul 20 16:53:53 2001
+@@ -1,5 +1,5 @@
+ PYTHON=python
+-prefix=/usr/local
++prefix=%%PREFIX%%
+ exec_prefix=${prefix}
+
+ #finds the site-packages dir that matches the selected prefix, or if none do, falls back to wherever it can find one..
+@@ -10,7 +10,7 @@
+ mandir=${prefix}/man
+ install=/usr/bin/install -c
+ user=root
+-group=root
++group=wheel
+
+ foo:
+ @echo 'to install cfv, type make install or install-wrapper.'
diff --git a/security/cfv/pkg-comment b/security/cfv/pkg-comment
new file mode 100644
index 000000000000..0083ca66ab60
--- /dev/null
+++ b/security/cfv/pkg-comment
@@ -0,0 +1 @@
+cfv is a utility to both test and create .sfv, .csv and md5sum files
diff --git a/security/cfv/pkg-descr b/security/cfv/pkg-descr
new file mode 100644
index 000000000000..f13da078eecf
--- /dev/null
+++ b/security/cfv/pkg-descr
@@ -0,0 +1,14 @@
+cfv is a utility to both test and create .sfv, .csv and md5sum files. These
+files are commonly used to ensure the correct retrieval or storage of data.
+
+Features:
+ - supports .sfv, .csv(2, 3, and 4 field variants) and md5sum file formats
+ - automatic checksum file naming ability in create mode
+ - recursive operation
+ - show unverified files option
+ - ignore case and fix path seperator options for cross platform use
+ - transparent gzip support for checksum files
+ - configurable renaming of bad files (with testing against previous bad
+ files, to save only unique differing copies)
+
+WWW: http://cfv.sourceforge.net/
diff --git a/security/cfv/pkg-plist b/security/cfv/pkg-plist
new file mode 100644
index 000000000000..a2d4790b08ee
--- /dev/null
+++ b/security/cfv/pkg-plist
@@ -0,0 +1,4 @@
+bin/cfv
+lib/%%PYTHON_VERSION%%/site-packages/cfv.py
+lib/%%PYTHON_VERSION%%/site-packages/cfv.pyc
+lib/%%PYTHON_VERSION%%/site-packages/cfv.pyo