aboutsummaryrefslogtreecommitdiff
path: root/security/chkrootkit
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2005-04-14 18:42:15 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2005-04-14 18:42:15 +0000
commitc002530ceca5fd5270e858111e0e8b1255b12911 (patch)
treedce29a76b8964ebebc6cc750e3bbbf921b781976 /security/chkrootkit
parent3589170715ad1c8b6b9ff45ae745d3e80e41196e (diff)
downloadports-c002530ceca5fd5270e858111e0e8b1255b12911.tar.gz
ports-c002530ceca5fd5270e858111e0e8b1255b12911.zip
- Update to chkrookit version 0.45 [1]
- utilize PORTDOCS, DOCSDIR and PLIST_FILES PR: [1] 79865 Submitted by: [1] Luiz Eduardo Roncato Cordeiro <cordeiro@nic.br>
Notes
Notes: svn path=/head/; revision=133357
Diffstat (limited to 'security/chkrootkit')
-rw-r--r--security/chkrootkit/Makefile31
-rw-r--r--security/chkrootkit/distinfo4
-rw-r--r--security/chkrootkit/pkg-descr1
-rw-r--r--security/chkrootkit/pkg-plist14
4 files changed, 24 insertions, 26 deletions
diff --git a/security/chkrootkit/Makefile b/security/chkrootkit/Makefile
index 8ff32169598d..b2e42cf7885e 100644
--- a/security/chkrootkit/Makefile
+++ b/security/chkrootkit/Makefile
@@ -6,28 +6,38 @@
#
PORTNAME= chkrootkit
-PORTVERSION= 0.44
+PORTVERSION= 0.45
CATEGORIES= security
-MASTER_SITES= ftp://ftp.pangeia.com.br/pub/seg/pac/
+MASTER_SITES= ftp://ftp.pangeia.com.br/pub/seg/pac/ \
+ ftp://gd.tuwien.ac.at/infosys/security/chkrootkit/ \
+ ftp://ftp.digitalvoodoo.org/pub/mirrors/chkrootkit/ \
+ http://www.spenneberg.org/chkrootkit-mirror/files/ \
+ http://www.mirrors.wiretapped.net/security/host-security/chkrootkit/ \
+ http://ftp.uni-stuttgart.de/pub/security/unix/forensics/chkrootkit/ \
+ http://ftp.bit.nl/mirror/chkrootkit/ \
+ http://chkrootkit.mirror.fr/
MAINTAINER= cordeiro@nic.br
COMMENT= A tool to locally check for signs of a rootkit
USE_REINPLACE= yes
-ALL_TARGET= chkrootkit chklastlog chkwtmp chkproc chkdirs ifpromisc check_wtmpx strings
+ALL_TARGET= chkrootkit chklastlog chkwtmp chkutmp chkproc chkdirs ifpromisc check_wtmpx strings
-DOCFILES= ACKNOWLEDGMENTS COPYRIGHT README README.chklastlog README.chkwtmp
+PLIST_FILES= ${ALL_TARGET:C,^,sbin/,}
-BINMODE= 0700
+.if !defined(NOPORTDOCS)
+PORTDOCS= ACKNOWLEDGMENTS COPYRIGHT README README.chklastlog README.chkwtmp
+.endif
-.include <bsd.port.pre.mk>
+BINMODE= 0700
pre-patch:
${REINPLACE_CMD} -e "s/^CC/#CC/; s/^CFLAGS/#CFLAGS/" ${WRKSRC}/Makefile
${REINPLACE_CMD} -e \
's#\./chklastlog#${PREFIX}/sbin/chklastlog#g; \
s#\./chkwtmp#${PREFIX}/sbin/chkwtmp#g; \
+ s#\./chkutmp#${PREFIX}/sbin/chkutmp#g; \
s#\./chkproc#${PREFIX}/sbin/chkproc#g; \
s#\./chkdirs#${PREFIX}/sbin/chkdirs#g; \
s#\./check_wtmpx#${PREFIX}/sbin/check_wtmpx#g; \
@@ -39,14 +49,15 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/chkrootkit ${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKSRC}/chklastlog ${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKSRC}/chkwtmp ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/chkutmp ${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKSRC}/chkproc ${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKSRC}/chkdirs ${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKSRC}/ifpromisc ${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKSRC}/check_wtmpx ${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKSRC}/strings ${PREFIX}/sbin
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/chkrootkit
- ${INSTALL_DATA} ${DOCFILES:C,^,${WRKSRC}/,} ${PREFIX}/share/doc/chkrootkit
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:C,^,${WRKSRC}/,} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/chkrootkit/distinfo b/security/chkrootkit/distinfo
index bf3c4baac808..89695a491a70 100644
--- a/security/chkrootkit/distinfo
+++ b/security/chkrootkit/distinfo
@@ -1,2 +1,2 @@
-MD5 (chkrootkit-0.44.tar.gz) = 8f6dbb3204c24e9b71490142cb2953ee
-SIZE (chkrootkit-0.44.tar.gz) = 34163
+MD5 (chkrootkit-0.45.tar.gz) = 57493e24ca81750a200d8bcb4049e858
+SIZE (chkrootkit-0.45.tar.gz) = 36359
diff --git a/security/chkrootkit/pkg-descr b/security/chkrootkit/pkg-descr
index d80c6438f8b5..482d1e734c8b 100644
--- a/security/chkrootkit/pkg-descr
+++ b/security/chkrootkit/pkg-descr
@@ -13,6 +13,7 @@
* chkproc.c: checks for signs of LKM trojans.
* chkdirs.c: checks for signs of LKM trojans.
* strings.c: quick and dirty strings replacement.
+ * chkutmp.c: checks for utmp deletions.
For an updated list of rootkits, worms and LKMs detected by
chkrootkit please visit: http://www.chkrootkit.org/
diff --git a/security/chkrootkit/pkg-plist b/security/chkrootkit/pkg-plist
deleted file mode 100644
index c8c6f2fa7c05..000000000000
--- a/security/chkrootkit/pkg-plist
+++ /dev/null
@@ -1,14 +0,0 @@
-sbin/chkdirs
-sbin/chklastlog
-sbin/chkproc
-sbin/chkrootkit
-sbin/chkwtmp
-sbin/ifpromisc
-sbin/check_wtmpx
-sbin/strings
-%%PORTDOCS%%share/doc/chkrootkit/ACKNOWLEDGMENTS
-%%PORTDOCS%%share/doc/chkrootkit/COPYRIGHT
-%%PORTDOCS%%share/doc/chkrootkit/README
-%%PORTDOCS%%share/doc/chkrootkit/README.chklastlog
-%%PORTDOCS%%share/doc/chkrootkit/README.chkwtmp
-%%PORTDOCS%%@dirrm share/doc/chkrootkit