aboutsummaryrefslogtreecommitdiff
path: root/security/clamav
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-02-09 09:19:54 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-02-09 09:19:54 +0000
commit088df5b0605845e4ac845b49bfe1adf31c01e998 (patch)
tree0cda92ebd3e087496965883da4156183bdf7032e /security/clamav
parent36b0cd4182aa67194dc4e2fc61afcb575aac3cce (diff)
downloadports-088df5b0605845e4ac845b49bfe1adf31c01e998.tar.gz
ports-088df5b0605845e4ac845b49bfe1adf31c01e998.zip
- Fix crashing of milter by turning off SESSION support [1]
- Fix build when libmilter was built with LDAP [2] PR: ports/77255 [1], ports/77235 [2] Submitted by: Sergey N. Voronkov <serg@tmn.ru> [1], Lewis Thompson <lewiz@compsoc.man.ac.uk> [2] Approved by: Rob Evers <rob@debank.tv> (maintainer)
Notes
Notes: svn path=/head/; revision=128353
Diffstat (limited to 'security/clamav')
-rw-r--r--security/clamav/Makefile11
-rw-r--r--security/clamav/files/patch-clamav-milter::clamav-milter.c11
2 files changed, 20 insertions, 2 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 790f9a1f4c06..3b9261871e5e 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -7,6 +7,7 @@
PORTNAME= clamav
PORTVERSION= ${DISTVERSION:C/([a-z])[a-z]*/.\1/g:S/-/./g}
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= clamav
@@ -56,6 +57,14 @@ CPPFLAGS+= -I${LOCALBASE}/include \
${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib \
${PTHREAD_LIBS}
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_LDAP) && exists(${LOCALBASE}/lib/libldap.so)
+USE_OPENLDAP= yes
+LDFLAGS+= -lldap
+.endif
+
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
MAN1= clamscan.1 freshclam.1 sigtool.1 clamdscan.1
@@ -101,8 +110,6 @@ SED_SCRIPT+= -e 's|%%RC_SUBR%%|${RC_SUBR}|g' \
PLIST_SUB+= RC_DIR=${RC_DIR} \
RC_SUFX=${RC_SUFX}
-.include <bsd.port.pre.mk>
-
.if defined(WITH_MILTER)
.if !exists(/usr/lib/libmilter.a)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libmilter.a:${PORTSDIR}/mail/sendmail
diff --git a/security/clamav/files/patch-clamav-milter::clamav-milter.c b/security/clamav/files/patch-clamav-milter::clamav-milter.c
new file mode 100644
index 000000000000..8a925a8b569f
--- /dev/null
+++ b/security/clamav/files/patch-clamav-milter::clamav-milter.c
@@ -0,0 +1,11 @@
+--- clamav-milter/clamav-milter.c.orig Sun Feb 6 21:35:29 2005
++++ clamav-milter/clamav-milter.c Wed Feb 9 10:00:06 2005
+@@ -643,7 +643,7 @@
+
+ #define VERSION_LENGTH 128
+
+-#define SESSION /*
++/* #define SESSION
+ * Keep one command connection open to clamd, otherwise a new
+ * command connection is created for each new email
+ *