aboutsummaryrefslogtreecommitdiff
path: root/security/cryptopp
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2011-09-06 20:01:05 +0000
committerXin LI <delphij@FreeBSD.org>2011-09-06 20:01:05 +0000
commit549f67f58abfa438f2b12cdd126727fe2a252978 (patch)
tree8c0cc408a6a30d983ebf3e41afdf67dd1e04f336 /security/cryptopp
parent1a6d4b4cae84fe0256ebcfb66aeb02f6d7165840 (diff)
downloadports-549f67f58abfa438f2b12cdd126727fe2a252978.tar.gz
ports-549f67f58abfa438f2b12cdd126727fe2a252978.zip
Fix clang build.
PR: ports/160509 Submitted by: h h <aakuusta gmail.com>
Notes
Notes: svn path=/head/; revision=281316
Diffstat (limited to 'security/cryptopp')
-rw-r--r--security/cryptopp/Makefile1
-rw-r--r--security/cryptopp/files/patch-clang97
2 files changed, 98 insertions, 0 deletions
diff --git a/security/cryptopp/Makefile b/security/cryptopp/Makefile
index 3e21a5ce7df0..621c77360721 100644
--- a/security/cryptopp/Makefile
+++ b/security/cryptopp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cryptopp
PORTVERSION= 5.6.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF \
http://www.cryptopp.com/
diff --git a/security/cryptopp/files/patch-clang b/security/cryptopp/files/patch-clang
new file mode 100644
index 000000000000..3616eab98d3a
--- /dev/null
+++ b/security/cryptopp/files/patch-clang
@@ -0,0 +1,97 @@
+--- ./algebra.cpp.orig 2010-08-06 18:44:32.000000000 -0700
++++ ./algebra.cpp 2011-09-06 12:55:41.351288757 -0700
+@@ -58,7 +58,7 @@
+ Element g[3]={b, a};
+ unsigned int i0=0, i1=1, i2=2;
+
+- while (!Equal(g[i1], this->Identity()))
++ while (!this->Equal(g[i1], this->Identity()))
+ {
+ g[i2] = Mod(g[i0], g[i1]);
+ unsigned int t = i0; i0 = i1; i1 = i2; i2 = t;
+--- ./eccrypto.cpp.orig 2010-08-06 18:44:28.000000000 -0700
++++ ./eccrypto.cpp 2011-09-06 12:55:41.355150164 -0700
+@@ -435,7 +435,7 @@
+ StringSource ssG(param.g, true, new HexDecoder);
+ Element G;
+ bool result = GetCurve().DecodePoint(G, ssG, (size_t)ssG.MaxRetrievable());
+- SetSubgroupGenerator(G);
++ this->SetSubgroupGenerator(G);
+ assert(result);
+
+ StringSource ssN(param.n, true, new HexDecoder);
+@@ -591,7 +591,7 @@
+ if (level >= 2 && pass)
+ {
+ const Integer &q = GetSubgroupOrder();
+- Element gq = gpc ? gpc->Exponentiate(this->GetGroupPrecomputation(), q) : ExponentiateElement(g, q);
++ Element gq = gpc ? gpc->Exponentiate(this->GetGroupPrecomputation(), q) : this->ExponentiateElement(g, q);
+ pass = pass && IsIdentity(gq);
+ }
+ return pass;
+@@ -629,7 +629,7 @@
+ typename EC::Point P;
+ if (!this->GetGroupParameters().GetCurve().DecodePoint(P, bt, size))
+ BERDecodeError();
+- SetPublicElement(P);
++ this->SetPublicElement(P);
+ }
+
+ template <class EC>
+--- ./eccrypto.h.orig 2010-08-06 18:46:24.000000000 -0700
++++ ./eccrypto.h 2011-09-06 12:55:41.355150164 -0700
+@@ -43,7 +43,7 @@
+ void Initialize(const EllipticCurve &ec, const Point &G, const Integer &n, const Integer &k = Integer::Zero())
+ {
+ this->m_groupPrecomputation.SetCurve(ec);
+- SetSubgroupGenerator(G);
++ this->SetSubgroupGenerator(G);
+ m_n = n;
+ m_k = k;
+ }
+@@ -145,9 +145,9 @@
+ typedef typename EC::Point Element;
+
+ void Initialize(const DL_GroupParameters_EC<EC> &params, const Element &Q)
+- {this->AccessGroupParameters() = params; SetPublicElement(Q);}
++ {this->AccessGroupParameters() = params; this->SetPublicElement(Q);}
+ void Initialize(const EC &ec, const Element &G, const Integer &n, const Element &Q)
+- {this->AccessGroupParameters().Initialize(ec, G, n); SetPublicElement(Q);}
++ {this->AccessGroupParameters().Initialize(ec, G, n); this->SetPublicElement(Q);}
+
+ // X509PublicKey
+ void BERDecodePublicKey(BufferedTransformation &bt, bool parametersPresent, size_t size);
+@@ -166,9 +166,9 @@
+ void Initialize(const EC &ec, const Element &G, const Integer &n, const Integer &x)
+ {this->AccessGroupParameters().Initialize(ec, G, n); this->SetPrivateExponent(x);}
+ void Initialize(RandomNumberGenerator &rng, const DL_GroupParameters_EC<EC> &params)
+- {GenerateRandom(rng, params);}
++ {this->GenerateRandom(rng, params);}
+ void Initialize(RandomNumberGenerator &rng, const EC &ec, const Element &G, const Integer &n)
+- {GenerateRandom(rng, DL_GroupParameters_EC<EC>(ec, G, n));}
++ {this->GenerateRandom(rng, DL_GroupParameters_EC<EC>(ec, G, n));}
+
+ // PKCS8PrivateKey
+ void BERDecodePrivateKey(BufferedTransformation &bt, bool parametersPresent, size_t size);
+--- ./panama.cpp.orig 2010-08-09 14:22:42.000000000 -0700
++++ ./panama.cpp 2011-09-06 12:55:41.356148062 -0700
+@@ -422,7 +422,7 @@
+ {
+ this->ThrowIfInvalidTruncatedSize(size);
+
+- PadLastBlock(this->BLOCKSIZE, 0x01);
++ this->PadLastBlock(this->BLOCKSIZE, 0x01);
+
+ HashEndianCorrectedBlock(this->m_data);
+
+--- ./secblock.h.orig 2010-08-06 18:46:20.000000000 -0700
++++ ./secblock.h 2011-09-06 12:55:41.357147916 -0700
+@@ -88,7 +88,7 @@
+
+ pointer allocate(size_type n, const void * = NULL)
+ {
+- CheckSize(n);
++ this->CheckSize(n);
+ if (n == 0)
+ return NULL;
+