aboutsummaryrefslogtreecommitdiff
path: root/security/cryptopp
diff options
context:
space:
mode:
authorFoxfair Hu <foxfair@FreeBSD.org>2003-04-12 03:23:03 +0000
committerFoxfair Hu <foxfair@FreeBSD.org>2003-04-12 03:23:03 +0000
commit732c8be689466b4a33e9a2613c36efd29ce41368 (patch)
tree7ea63ba366fc5ebcf620ede9c613cd771f3684e8 /security/cryptopp
parente0dc5dd5fdb4d647860560807256b7ee272febcb (diff)
downloadports-732c8be689466b4a33e9a2613c36efd29ce41368.tar.gz
ports-732c8be689466b4a33e9a2613c36efd29ce41368.zip
Upgrade cryptopp to 5.1, patch review timeout by MAINTAINER since March 26.
Notes
Notes: svn path=/head/; revision=78785
Diffstat (limited to 'security/cryptopp')
-rw-r--r--security/cryptopp/Makefile43
-rw-r--r--security/cryptopp/distinfo2
-rw-r--r--security/cryptopp/files/patch-aa31
-rw-r--r--security/cryptopp/pkg-descr27
-rw-r--r--security/cryptopp/pkg-plist26
5 files changed, 60 insertions, 69 deletions
diff --git a/security/cryptopp/Makefile b/security/cryptopp/Makefile
index 2214e25290f0..da0b889ecedb 100644
--- a/security/cryptopp/Makefile
+++ b/security/cryptopp/Makefile
@@ -6,15 +6,18 @@
#
PORTNAME= cryptopp
-PORTVERSION= 4.1
+PORTVERSION= 5.1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- http://www.eskimo.com/~weidai/
+ http://www.eskimo.com/~weidai/ \
+ http://gd.tuwien.ac.at/privacy/crypto/libs/cryptlib/ \
+ http://www.mirrors.wiretapped.net/security/cryptography/libraries/cryptolib/
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= crypto${PORTVERSION:S/.//g}
+EXTRACT_SUFX= .zip
MAINTAINER= greid@ukug.uk.freebsd.org
-COMMENT= A free C++ class library of cryptographic schemes
+COMMENT= A free C++ class library of Cryptographic Primitives
NO_WRKSUBDIR= yes
USE_ZIP= yes
@@ -22,24 +25,29 @@ EXTRACT_BEFORE_ARGS= -aq
USE_GMAKE= yes
MAKEFILE= GNUmakefile
-HEADERFILES= 3way.h adler32.h aes.h algebra.h arc4.h asn.h base64.h \
- bench.h blowfish.h blumgold.h blumshub.h cast.h cbc.h \
- cbcmac.h channels.h config.h crc.h cryptlib.h des.h \
- default.h dh.h dh2.h diamond.h dmac.h dsa.h ec2n.h \
- eccrypto.h ecp.h elgamal.h eprecomp.h files.h gf256.h \
- filters.h gf2_32.h gf2n.h gost.h gzip.h haval.h hex.h \
- hmac.h hrtimer.h ida.h idea.h integer.h iterhash.h \
- lubyrack.h luc.h mars.h md2.h md5.h md5mac.h mdc.h \
- misc.h modarith.h modes.h modexppc.h mqueue.h mqv.h \
+HEADERFILES= 3way.h adler32.h aes.h algebra.h algparam.h arc4.h \
+ argnames.h asn.h base64.h basecode.h bench.h \
+ blowfish.h blumshub.h cast.h cbcmac.h channels.h \
+ config.h crc.h cryptlib.h default.h des.h dh.h dh2.h \
+ diamond.h dmac.h dsa.h ec2n.h eccrypto.h ecp.h \
+ elgamal.h eprecomp.h esign.h factory.h files.h \
+ filters.h fips140.h fltrimpl.h gf256.h gf2_32.h gf2n.h \
+ gfpcrypt.h gost.h gzip.h haval.h hex.h hmac.h \
+ hrtimer.h ida.h idea.h integer.h iterhash.h lubyrack.h \
+ luc.h mars.h md2.h md4.h md5.h md5mac.h mdc.h misc.h \
+ modarith.h modes.h modexppc.h mqueue.h mqv.h \
nbtheory.h network.h nr.h oaep.h oids.h osrng.h \
panama.h pch.h pkcspad.h polynomi.h pssr.h pubkey.h \
- queue.h rabin.h randpool.h rc2.h rc5.h rc6.h \
- rijndael.h ripemd.h rng.h rsa.h rw.h safer.h \
- sapphire.h seal.h secshare.h serpent.h sha.h shark.h \
- skipjack.h smartptr.h socketft.h square.h tea.h \
- tiger.h twofish.h validate.h wake.h winpipes.h words.h \
+ pwdbased.h queue.h rabin.h randpool.h rc2.h rc5.h \
+ rc6.h rijndael.h ripemd.h rng.h rsa.h rw.h safer.h \
+ seal.h secblock.h seckey.h serpent.h sha.h shark.h \
+ simple.h skipjack.h smartptr.h socketft.h square.h \
+ strciphr.h tea.h tiger.h trdlocal.h trunhash.h \
+ twofish.h validate.h wait.h wake.h winpipes.h words.h \
xormac.h xtr.h xtrcrypt.h zdeflate.h zinflate.h zlib.h
+pre-install:
+ strip ${WRKSRC}/cryptest
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cryptest ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/libcryptopp.a ${PREFIX}/lib
@@ -50,6 +58,7 @@ do-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/cryptopp
${CP} ${WRKSRC}/README.txt ${PREFIX}/share/doc/cryptopp/README
+ ${CP} ${WRKSRC}/License.txt ${PREFIX}/share/doc/cryptopp/License
.endif
.include <bsd.port.mk>
diff --git a/security/cryptopp/distinfo b/security/cryptopp/distinfo
index c066f46a5d44..3066f858d371 100644
--- a/security/cryptopp/distinfo
+++ b/security/cryptopp/distinfo
@@ -1 +1 @@
-MD5 (crypto41.zip) = aaaa77cf49a8517d815862219feb4dcd
+MD5 (crypto51.zip) = f4bfd4ac39dc1b7f0764d61a1ec4df16
diff --git a/security/cryptopp/files/patch-aa b/security/cryptopp/files/patch-aa
index 72895cd799b4..bd88a3a0af22 100644
--- a/security/cryptopp/files/patch-aa
+++ b/security/cryptopp/files/patch-aa
@@ -1,32 +1,15 @@
---- GNUmakefile.orig Thu Jan 18 11:46:13 2001
-+++ GNUmakefile Thu Jan 18 12:36:40 2001
-@@ -1,4 +1,4 @@
--CXXFLAGS = -O2 -w
-+CXXFLAGS += -w
- ARFLAGS = cr
- RANLIB = ranlib
- UNAME = $(shell uname)
-@@ -6,7 +6,7 @@
- ifeq ($(UNAME),) # for DJGPP, where uname doesn't exist
- CXXFLAGS := $(CXXFLAGS) -mbnu210
- else
--CXXFLAGS := $(CXXFLAGS) -pipe
-+CXXFLAGS := $(CXXFLAGS)
- endif
-
- ifeq ($(UNAME),SunOS)
-@@ -28,16 +28,16 @@
- TESTOBJS = bench.o test.o validat1.o validat2.o validat3.o
+--- GNUmakefile.orig Wed Mar 26 17:21:24 2003
++++ GNUmakefile Wed Mar 26 17:22:16 2003
+@@ -47,7 +47,7 @@
+ TESTOBJS = bench.o test.o validat1.o validat2.o validat3.o adhoc.o datatest.o regtest.o
LIBOBJS = $(filter-out $(TESTOBJS),$(OBJS))
-all: cryptest.exe
+all: cryptest
clean:
-- $(RM) cryptest.exe libcryptopp.a $(LIBOBJS) $(TESTOBJS)
-+ $(RM) cryptest libcryptopp.a $(LIBOBJS) $(TESTOBJS)
-
- libcryptopp.a: $(LIBOBJS)
+ $(RM) cryptest.exe libcryptopp.a $(LIBOBJS) $(TESTOBJS)
+@@ -56,7 +56,7 @@
$(AR) $(ARFLAGS) $@ $(LIBOBJS)
$(RANLIB) $@
@@ -34,4 +17,4 @@
+cryptest: libcryptopp.a $(TESTOBJS)
$(CXX) -o $@ $(CXXFLAGS) $(TESTOBJS) -L. -lcryptopp $(LDFLAGS) $(LDLIBS)
- .SUFFIXES: .cpp
+ nolib: $(OBJS) # makes it faster to test changes
diff --git a/security/cryptopp/pkg-descr b/security/cryptopp/pkg-descr
index 175b19b36928..0b51ca1ac215 100644
--- a/security/cryptopp/pkg-descr
+++ b/security/cryptopp/pkg-descr
@@ -1,26 +1,11 @@
-Crypto++ is a free C++ class library of cryptographic schemes. Includes:
+Crypto++ Library is a free C++ class library of cryptographic schemes.
+One purpose of Crypto++ is to act as a repository of public domain (not
+copyrighted) source code. Although the library is copyrighted as a
+compilation, the individual files in it (except for a few exceptions listed
+in the license) are in the public domain.
-* A class hierarchy with an API defined by abstract base classes
-* Proposed AES (and RC6, MARS, Twofish, Serpent, CAST-256)
-* Symmetric block cipers: IDEA, DES/Triple DES,DESX, RC2, RC5, Blowfish,
- Diamond2, TEA, SAFER, 3-WAY, GOST, SHARK, CAST-128, Square, Skipjack
-* Generic cipher modes: CBC padded/ciphertext stealing (CTS), CFB, OFB
-* Stream cipher: Panama, ARC4, SEAL, WAKE, Sapphire, BlumBlumShub
-* Public key: RSA, DSA, ElGamal, NR, BlumGoldwasser, Rabin/RW, LUC, LUCELG
-* Padding schemes for PK systems: PKCS#1 v2, OAEP, PSSR, IEEE P1363 EMSA2
-* Key agreement schemes: DH, DH2, MQV, LUCDIF, XTR-DH
-* Elliptic curve cryptography: ECDSA, ENR, EIES, ECDHD, ECMQVC
-* One-way hash functions: SHA-1/2, MD2/5, HAVAL, RIPEMD-160, Tiger, Panama
-* Message authentication codes: MD5-MAC, HMAC, XOR-MAC, CBC-MAC, DMAC
-* Cipher constructions from hash functions: Luby-Rackoff, MD
-* Pseudorandom number generators: ANSI X9.17 appendix C, PGP's RandPool
-* Shamir's secret sharing scheme/Rabin's information dispersal algorithm (IDA)
-* gzip, DEFLATE and zlib format support
-* Fast multiprecision integer (bignum) and polynomial operations
-* Prime number generation/verification, base-64 and 32-bit CRC encoding
-* A high level interface for most of the above
-WWW: http://www.eskimo.com/~weidai/cryptlib.html
+WWW: http://www.cryptopp.com/
- George Reid
greid@ukug.uk.freebsd.org
diff --git a/security/cryptopp/pkg-plist b/security/cryptopp/pkg-plist
index 35a6fe2adc02..1a911d4389fc 100644
--- a/security/cryptopp/pkg-plist
+++ b/security/cryptopp/pkg-plist
@@ -4,22 +4,23 @@ include/cryptopp/3way.h
include/cryptopp/adler32.h
include/cryptopp/aes.h
include/cryptopp/algebra.h
+include/cryptopp/algparam.h
include/cryptopp/arc4.h
+include/cryptopp/argnames.h
include/cryptopp/asn.h
include/cryptopp/base64.h
+include/cryptopp/basecode.h
include/cryptopp/bench.h
include/cryptopp/blowfish.h
-include/cryptopp/blumgold.h
include/cryptopp/blumshub.h
include/cryptopp/cast.h
-include/cryptopp/cbc.h
include/cryptopp/cbcmac.h
include/cryptopp/channels.h
include/cryptopp/config.h
include/cryptopp/crc.h
include/cryptopp/cryptlib.h
-include/cryptopp/des.h
include/cryptopp/default.h
+include/cryptopp/des.h
include/cryptopp/dh.h
include/cryptopp/dh2.h
include/cryptopp/diamond.h
@@ -30,11 +31,16 @@ include/cryptopp/eccrypto.h
include/cryptopp/ecp.h
include/cryptopp/elgamal.h
include/cryptopp/eprecomp.h
+include/cryptopp/esign.h
+include/cryptopp/factory.h
include/cryptopp/files.h
-include/cryptopp/gf256.h
include/cryptopp/filters.h
+include/cryptopp/fips140.h
+include/cryptopp/fltrimpl.h
+include/cryptopp/gf256.h
include/cryptopp/gf2_32.h
include/cryptopp/gf2n.h
+include/cryptopp/gfpcrypt.h
include/cryptopp/gost.h
include/cryptopp/gzip.h
include/cryptopp/haval.h
@@ -49,6 +55,7 @@ include/cryptopp/lubyrack.h
include/cryptopp/luc.h
include/cryptopp/mars.h
include/cryptopp/md2.h
+include/cryptopp/md4.h
include/cryptopp/md5.h
include/cryptopp/md5mac.h
include/cryptopp/mdc.h
@@ -70,6 +77,7 @@ include/cryptopp/pkcspad.h
include/cryptopp/polynomi.h
include/cryptopp/pssr.h
include/cryptopp/pubkey.h
+include/cryptopp/pwdbased.h
include/cryptopp/queue.h
include/cryptopp/rabin.h
include/cryptopp/randpool.h
@@ -82,20 +90,25 @@ include/cryptopp/rng.h
include/cryptopp/rsa.h
include/cryptopp/rw.h
include/cryptopp/safer.h
-include/cryptopp/sapphire.h
include/cryptopp/seal.h
-include/cryptopp/secshare.h
+include/cryptopp/secblock.h
+include/cryptopp/seckey.h
include/cryptopp/serpent.h
include/cryptopp/sha.h
include/cryptopp/shark.h
+include/cryptopp/simple.h
include/cryptopp/skipjack.h
include/cryptopp/smartptr.h
include/cryptopp/socketft.h
include/cryptopp/square.h
+include/cryptopp/strciphr.h
include/cryptopp/tea.h
include/cryptopp/tiger.h
+include/cryptopp/trdlocal.h
+include/cryptopp/trunhash.h
include/cryptopp/twofish.h
include/cryptopp/validate.h
+include/cryptopp/wait.h
include/cryptopp/wake.h
include/cryptopp/winpipes.h
include/cryptopp/words.h
@@ -107,4 +120,5 @@ include/cryptopp/zinflate.h
include/cryptopp/zlib.h
@dirrm include/cryptopp
%%PORTDOCS%%share/doc/cryptopp/README
+%%PORTDOCS%%share/doc/cryptopp/License
%%PORTDOCS%%@dirrm share/doc/cryptopp