aboutsummaryrefslogtreecommitdiff
path: root/security/cryptopp
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2009-03-27 00:02:32 +0000
committerXin LI <delphij@FreeBSD.org>2009-03-27 00:02:32 +0000
commit46aae3401703f8edb6a98c17cdc0e22bd0735792 (patch)
tree39858c7a07828f9ba4a099a8b725abd46b26477d /security/cryptopp
parentb30d629c8f2af9aa92f7e70403ec16d2ebf83b09 (diff)
downloadports-46aae3401703f8edb6a98c17cdc0e22bd0735792.tar.gz
ports-46aae3401703f8edb6a98c17cdc0e22bd0735792.zip
Update to 5.6.0 and mark MAKE_JOBS_SAFE.
Notes
Notes: svn path=/head/; revision=231081
Diffstat (limited to 'security/cryptopp')
-rw-r--r--security/cryptopp/Makefile16
-rw-r--r--security/cryptopp/distinfo6
-rw-r--r--security/cryptopp/files/patch-GNUmakefile8
-rw-r--r--security/cryptopp/files/patch-aa27
-rw-r--r--security/cryptopp/pkg-plist13
5 files changed, 29 insertions, 41 deletions
diff --git a/security/cryptopp/Makefile b/security/cryptopp/Makefile
index eca2279441f8..81de628afda2 100644
--- a/security/cryptopp/Makefile
+++ b/security/cryptopp/Makefile
@@ -6,12 +6,10 @@
#
PORTNAME= cryptopp
-PORTVERSION= 5.4
+PORTVERSION= 5.6.0
CATEGORIES= security
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- http://www.cryptopp.com/ \
- http://www.mirrors.wiretapped.net/security/cryptography/libraries/cryptolib/
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF \
+ http://www.cryptopp.com/
DISTNAME= cryptopp${PORTVERSION:S/.//g}
MAINTAINER= delphij@FreeBSD.org
@@ -21,13 +19,15 @@ NO_WRKSUBDIR= yes
USE_ZIP= yes
EXTRACT_BEFORE_ARGS= -aq
USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
MAKEFILE= GNUmakefile
-pre-install:
- ${STRIP_CMD} ${WRKSRC}/cryptest
+.if !defined(WITH_DEBUG)
+CXXFLAGS+= -DNDEBUG
+.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/cryptest ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/cryptest.exe ${PREFIX}/bin/cryptest
${INSTALL_DATA} ${WRKSRC}/libcryptopp.a ${PREFIX}/lib
${MKDIR} ${PREFIX}/include/cryptopp
(for i in `${FIND} ${WRKSRC}/ -name '*.h' \
diff --git a/security/cryptopp/distinfo b/security/cryptopp/distinfo
index 6d6db3d51b23..61432d40ee63 100644
--- a/security/cryptopp/distinfo
+++ b/security/cryptopp/distinfo
@@ -1,3 +1,3 @@
-MD5 (cryptopp54.zip) = 40e760012d1b0b7e316676ef09e0a814
-SHA256 (cryptopp54.zip) = fa9aceb1b46c886b5c13fe5aa3d0cdbd74b4a2dd894e290cbdbfd17fe8a7fe5a
-SIZE (cryptopp54.zip) = 950582
+MD5 (cryptopp560.zip) = 36f35789ad60489d58003d3c849807e8
+SHA256 (cryptopp560.zip) = b522f0b5f850b50e9917823ea986f855295407380fafbe30f358875c41998bc5
+SIZE (cryptopp560.zip) = 1049029
diff --git a/security/cryptopp/files/patch-GNUmakefile b/security/cryptopp/files/patch-GNUmakefile
new file mode 100644
index 000000000000..4da1b1a4f76e
--- /dev/null
+++ b/security/cryptopp/files/patch-GNUmakefile
@@ -0,0 +1,8 @@
+--- ./GNUmakefile.orig 2009-03-15 02:48:02.000000000 -0700
++++ ./GNUmakefile 2009-03-26 16:26:05.337805000 -0700
+@@ -1,4 +1,4 @@
+-CXXFLAGS = -DNDEBUG -g -O2
++#CXXFLAGS = -DNDEBUG -g -O2
+ #CXXFLAGS = -g
+ # -fPIC is supported. Please report any breakage of -fPIC as a bug.
+ # CXXFLAGS += -fPIC
diff --git a/security/cryptopp/files/patch-aa b/security/cryptopp/files/patch-aa
deleted file mode 100644
index a50c365e4296..000000000000
--- a/security/cryptopp/files/patch-aa
+++ /dev/null
@@ -1,27 +0,0 @@
---- GNUmakefile.orig Sun Jun 20 11:22:24 2004
-+++ GNUmakefile Sun Jan 30 02:09:00 2005
-@@ -1,5 +1,5 @@
- # can't use -fno-rtti yet because it causes problems with exception handling in GCC 2.95.2
--CXXFLAGS = -g
-+CXXFLAGS ?= -g
- # Uncomment the following two lines to do a release build.
- # Note that you must define NDEBUG for your own application if you define it for Crypto++.
- # Make sure you run the validation tests and test your own program thoroughly
-@@ -75,7 +75,7 @@
- TESTIMPORTOBJS = $(TESTOBJS:.o=.import.o)
- DLLTESTOBJS = dlltest.dllonly.o
-
--all: cryptest.exe
-+all: cryptest
-
- clean:
- $(RM) cryptest.exe libcryptopp.a $(LIBOBJS) $(TESTOBJS) cryptopp.dll libcryptopp.dll.a libcryptopp.import.a cryptest.import.exe dlltest.exe $(DLLOBJS) $(LIBIMPORTOBJS) $(TESTIMPORTOBJS) $(DLLTESTOBJS)
-@@ -84,7 +84,7 @@
- $(AR) $(ARFLAGS) $@ $(LIBOBJS)
- $(RANLIB) $@
-
--cryptest.exe: libcryptopp.a $(TESTOBJS)
-+cryptest: libcryptopp.a $(TESTOBJS)
- $(CXX) -o $@ $(CXXFLAGS) $(TESTOBJS) -L. -lcryptopp $(LDFLAGS) $(LDLIBS)
-
- nolib: $(OBJS) # makes it faster to test changes
diff --git a/security/cryptopp/pkg-plist b/security/cryptopp/pkg-plist
index 5ef364f05974..b6c94029f542 100644
--- a/security/cryptopp/pkg-plist
+++ b/security/cryptopp/pkg-plist
@@ -7,6 +7,7 @@ include/cryptopp/algparam.h
include/cryptopp/arc4.h
include/cryptopp/argnames.h
include/cryptopp/asn.h
+include/cryptopp/authenc.h
include/cryptopp/base32.h
include/cryptopp/base64.h
include/cryptopp/basecode.h
@@ -16,8 +17,11 @@ include/cryptopp/blumshub.h
include/cryptopp/camellia.h
include/cryptopp/cast.h
include/cryptopp/cbcmac.h
+include/cryptopp/ccm.h
include/cryptopp/channels.h
+include/cryptopp/cmac.h
include/cryptopp/config.h
+include/cryptopp/cpu.h
include/cryptopp/crc.h
include/cryptopp/cryptlib.h
include/cryptopp/default.h
@@ -26,6 +30,7 @@ include/cryptopp/dh.h
include/cryptopp/dh2.h
include/cryptopp/dmac.h
include/cryptopp/dsa.h
+include/cryptopp/eax.h
include/cryptopp/ec2n.h
include/cryptopp/eccrypto.h
include/cryptopp/ecp.h
@@ -38,13 +43,13 @@ include/cryptopp/files.h
include/cryptopp/filters.h
include/cryptopp/fips140.h
include/cryptopp/fltrimpl.h
+include/cryptopp/gcm.h
include/cryptopp/gf256.h
include/cryptopp/gf2_32.h
include/cryptopp/gf2n.h
include/cryptopp/gfpcrypt.h
include/cryptopp/gost.h
include/cryptopp/gzip.h
-include/cryptopp/haval.h
include/cryptopp/hex.h
include/cryptopp/hmac.h
include/cryptopp/hrtimer.h
@@ -58,7 +63,6 @@ include/cryptopp/mars.h
include/cryptopp/md2.h
include/cryptopp/md4.h
include/cryptopp/md5.h
-include/cryptopp/md5mac.h
include/cryptopp/mdc.h
include/cryptopp/misc.h
include/cryptopp/modarith.h
@@ -95,7 +99,9 @@ include/cryptopp/salsa.h
include/cryptopp/seal.h
include/cryptopp/secblock.h
include/cryptopp/seckey.h
+include/cryptopp/seed.h
include/cryptopp/serpent.h
+include/cryptopp/serpentp.h
include/cryptopp/sha.h
include/cryptopp/shacal2.h
include/cryptopp/shark.h
@@ -103,6 +109,7 @@ include/cryptopp/simple.h
include/cryptopp/skipjack.h
include/cryptopp/smartptr.h
include/cryptopp/socketft.h
+include/cryptopp/sosemanuk.h
include/cryptopp/square.h
include/cryptopp/stdcpp.h
include/cryptopp/strciphr.h
@@ -113,12 +120,12 @@ include/cryptopp/trunhash.h
include/cryptopp/ttmac.h
include/cryptopp/twofish.h
include/cryptopp/validate.h
+include/cryptopp/vmac.h
include/cryptopp/wait.h
include/cryptopp/wake.h
include/cryptopp/whrlpool.h
include/cryptopp/winpipes.h
include/cryptopp/words.h
-include/cryptopp/xormac.h
include/cryptopp/xtr.h
include/cryptopp/xtrcrypt.h
include/cryptopp/zdeflate.h