aboutsummaryrefslogtreecommitdiff
path: root/security/cryptopp
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-03-07 12:42:58 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-03-07 12:42:58 +0000
commit6d17ec20dd4428d2cf09fed59b1a2bb6a465ffca (patch)
treef3ab1e0d32e3162eaefbcedaa5e9162b6d8e99be /security/cryptopp
parent282fec824b65c14098e55fae220805f5830f7d4f (diff)
downloadports-6d17ec20dd4428d2cf09fed59b1a2bb6a465ffca.tar.gz
ports-6d17ec20dd4428d2cf09fed59b1a2bb6a465ffca.zip
BROKEN on !i386 and !alpha: Does not compile
Notes
Notes: svn path=/head/; revision=103192
Diffstat (limited to 'security/cryptopp')
-rw-r--r--security/cryptopp/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/security/cryptopp/Makefile b/security/cryptopp/Makefile
index 0835d4cc6d2c..8a2356bf5210 100644
--- a/security/cryptopp/Makefile
+++ b/security/cryptopp/Makefile
@@ -47,6 +47,12 @@ HEADERFILES= 3way.h adler32.h aes.h algebra.h algparam.h arc4.h \
twofish.h validate.h wait.h wake.h winpipes.h words.h \
xormac.h xtr.h xtrcrypt.h zdeflate.h zinflate.h zlib.h
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386" && ${ARCH} != "alpha"
+BROKEN= "Does not compile on !i386 and !alpha"
+.endif
+
pre-install:
${STRIP_CMD} ${WRKSRC}/cryptest
do-install:
@@ -62,4 +68,4 @@ do-install:
${CP} ${WRKSRC}/License.txt ${PREFIX}/share/doc/cryptopp/License
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>