aboutsummaryrefslogtreecommitdiff
path: root/security/denyhosts
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-11-23 06:43:34 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-11-23 06:43:34 +0000
commitcd991849d75d1d2b1fec708234e5163f51502be8 (patch)
tree0ad2ed2233604a3e64a6b82c081c96ffccda884c /security/denyhosts
parent91a9c66859d1fb2063363bf8b8df301db4888324 (diff)
downloadports-cd991849d75d1d2b1fec708234e5163f51502be8.tar.gz
ports-cd991849d75d1d2b1fec708234e5163f51502be8.zip
- Move patch from pre-configure to post-patch.
- Use denyhost.conf (FreeBSD's default config file) instead of denyhost.cfg. - Bump PORTREVISION. PR: ports/105305 Submitted by: Gea-Suan Lin <gslin_AT_gslin dot org> Approved by: maintainer (Mohacsi Janos)
Notes
Notes: svn path=/head/; revision=177866
Diffstat (limited to 'security/denyhosts')
-rw-r--r--security/denyhosts/Makefile9
-rw-r--r--security/denyhosts/pkg-plist6
2 files changed, 8 insertions, 7 deletions
diff --git a/security/denyhosts/Makefile b/security/denyhosts/Makefile
index 9a9f067ec448..36fb4c998d9a 100644
--- a/security/denyhosts/Makefile
+++ b/security/denyhosts/Makefile
@@ -7,6 +7,7 @@
PORTNAME= denyhosts
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -22,16 +23,16 @@ USE_RC_SUBR= denyhosts
PORTDOCS= CHANGELOG.txt LICENSE.txt README.txt
-pre-configure:
+post-patch:
@${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' \
${WRKSRC}/daemon-control-dist \
${WRKSRC}/denyhosts.cfg-dist \
${WRKSRC}/setup.py
post-install:
- ${INSTALL_DATA} ${WRKSRC}/denyhosts.cfg-dist ${PREFIX}/etc
- [ -f ${PREFIX}/etc/denyhosts.cfg ] || \
- ${INSTALL_DATA} ${WRKSRC}/denyhosts.cfg-dist ${PREFIX}/etc/denyhosts.cfg
+ ${INSTALL_DATA} ${WRKSRC}/denyhosts.cfg-dist ${PREFIX}/etc/denyhosts.conf-dist
+ [ -f ${PREFIX}/etc/denyhosts.conf ] || \
+ ${INSTALL_DATA} ${WRKSRC}/denyhosts.cfg-dist ${PREFIX}/etc/denyhosts.conf
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
. for f in ${PORTDOCS}
diff --git a/security/denyhosts/pkg-plist b/security/denyhosts/pkg-plist
index c15df5e9df22..0c62442287ca 100644
--- a/security/denyhosts/pkg-plist
+++ b/security/denyhosts/pkg-plist
@@ -1,7 +1,7 @@
bin/denyhosts.py
-@unexec if cmp -s %D/etc/denyhosts.cfg %D/etc/denyhosts.cfg-dist; then rm -f %D/etc/denyhosts.cfg; fi
-etc/denyhosts.cfg-dist
-@exec [ -f %B/denyhosts.cfg ] || cp -f %B/%f %B/denyhosts.cfg
+@unexec if cmp -s %D/etc/denyhosts.conf %D/etc/denyhosts.conf-dist; then rm -f %D/etc/denyhosts.conf; fi
+etc/denyhosts.conf-dist
+@exec [ -f %B/denyhosts.conf ] || cp -f %B/%f %B/denyhosts.conf
%%DATADIR%%/daemon-control-dist
%%DATADIR%%/denyhosts.cfg-dist
%%DATADIR%%/setup.py