aboutsummaryrefslogtreecommitdiff
path: root/security/destroy
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2014-02-28 16:36:59 +0000
committerRene Ladan <rene@FreeBSD.org>2014-02-28 16:36:59 +0000
commit28536a96ad548b1ab3ef4e4531b3adbb6749be7c (patch)
treee1e7f3f76b80caeb20e34e8d9c770e376a1c3aa0 /security/destroy
parent1e137b9b4607c3e1d4e8d8d717341ed50ac160b1 (diff)
downloadports-28536a96ad548b1ab3ef4e4531b3adbb6749be7c.tar.gz
ports-28536a96ad548b1ab3ef4e4531b3adbb6749be7c.zip
security/destroy: fix build on DragonflyBSD. The distribution Makefile
includes bsd.port.mk at the end (!), which causes an infinite loop there while FreeBSD is fine. As the build consists of one target only, just define it in the port Makefile. Noticed by: marino
Notes
Notes: svn path=/head/; revision=346557
Diffstat (limited to 'security/destroy')
-rw-r--r--security/destroy/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/security/destroy/Makefile b/security/destroy/Makefile
index 14d2ecb5d6d0..093b08be1e20 100644
--- a/security/destroy/Makefile
+++ b/security/destroy/Makefile
@@ -14,6 +14,9 @@ LICENSE= BSD4CLAUSE
PLIST_FILES= bin/destroy man/man1/destroy.1.gz
+do-build:
+ (cd ${WRKSRC} ; ${CC} ${CFLAGS} ${LDFLAGS} -o ${PORTNAME} destroy.c)
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/destroy ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/destroy.1 ${STAGEDIR}${MAN1PREFIX}/man/man1