aboutsummaryrefslogtreecommitdiff
path: root/security/dropbear
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-08 09:09:36 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-08 09:09:36 +0000
commit785f2e6305d6e59c34a91b783dcd16782eeb4df2 (patch)
treec2eab93d616b84b565fb1fbd6cfafca264c346a5 /security/dropbear
parent7c7f149cf5b0f5c49fc53de2873ab466ca830541 (diff)
downloadports-785f2e6305d6e59c34a91b783dcd16782eeb4df2.tar.gz
ports-785f2e6305d6e59c34a91b783dcd16782eeb4df2.zip
[new port] security/dropbear: a lightweight SSH2 server
Dropbear is an SSH 2 server, designed to be usable in small memory environments. It supports: * Main features of SSH 2 protocol * Implements X11 forwarding, and authentication-agent forwarding for OpenSSH clients * Compatible with OpenSSH ~/.ssh/authorized_keys public key authentication WWW: http://matt.ucc.asn.au/dropbear/dropbear.html PR: ports/55795 Submitted by: Clement Laforet <sheepkiller@cultdeadsheep.org>
Notes
Notes: svn path=/head/; revision=88769
Diffstat (limited to 'security/dropbear')
-rw-r--r--security/dropbear/Makefile39
-rw-r--r--security/dropbear/distinfo1
-rw-r--r--security/dropbear/pkg-descr10
-rw-r--r--security/dropbear/pkg-plist5
4 files changed, 55 insertions, 0 deletions
diff --git a/security/dropbear/Makefile b/security/dropbear/Makefile
new file mode 100644
index 000000000000..8a7546119f24
--- /dev/null
+++ b/security/dropbear/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: dropbear
+# Date created: 20 August 2003
+# Whom: Clement Laforet <sheepkiller@cultdeadsheep.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dropbear
+PORTVERSION= 0.36
+CATEGORIES= security ipv6
+MASTER_SITES= http://matt.ucc.asn.au/dropbear/
+
+MAINTAINER= sheepkiller@cultdeadsheep.org
+COMMENT= An SSH 2 server, designed to be usable in small memory environments
+
+GNU_CONFIGURE= YES
+USE_GMAKE= YES
+USE_REINPLACE= YES
+
+.if defined(IS_STATIC)
+CONFIGURE_ENV= LDFLAGS=-static
+.endif
+
+BIN= dropbear dropbearkey dropbearconvert
+
+post-configure:
+ @${REINPLACE_CMD} -e "s,/etc/,${PREFIX}/etc/,g" ${WRKSRC}/options.h
+ @${REINPLACE_CMD} -e "s,/usr/bin/X11/,${X11BASE}/,g" ${WRKSRC}/options.h
+
+do-install:
+.for bin in ${BIN}
+ @${INSTALL_PROGRAM} ${WRKSRC}/${bin} ${PREFIX}/bin
+.endfor
+.if !defined(NOPORTDOC)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/dropbear/distinfo b/security/dropbear/distinfo
new file mode 100644
index 000000000000..94c061015cd4
--- /dev/null
+++ b/security/dropbear/distinfo
@@ -0,0 +1 @@
+MD5 (dropbear-0.36.tar.gz) = 37b38670235c4cdd37e3833919bcf53f
diff --git a/security/dropbear/pkg-descr b/security/dropbear/pkg-descr
new file mode 100644
index 000000000000..b46954afeac4
--- /dev/null
+++ b/security/dropbear/pkg-descr
@@ -0,0 +1,10 @@
+Dropbear is an SSH 2 server, designed to be usable in small memory environments.
+It supports:
+
+ * Main features of SSH 2 protocol
+ * Implements X11 forwarding, and authentication-agent forwarding
+ for OpenSSH clients
+ * Compatible with OpenSSH ~/.ssh/authorized_keys public key
+ authentication
+
+WWW: http://matt.ucc.asn.au/dropbear/dropbear.html
diff --git a/security/dropbear/pkg-plist b/security/dropbear/pkg-plist
new file mode 100644
index 000000000000..fa82866934c6
--- /dev/null
+++ b/security/dropbear/pkg-plist
@@ -0,0 +1,5 @@
+bin/dropbear
+bin/dropbearkey
+bin/dropbearconvert
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%