aboutsummaryrefslogtreecommitdiff
path: root/security/fragroute
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-12-05 12:36:15 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-12-05 12:36:15 +0000
commit0ef340877c0d22d69fb3dc53281bded0f3340f03 (patch)
treeb9a2f4ea841514d5b9e3205688241aebdf3ff643 /security/fragroute
parent5b2560de4dacccc93d4f0a2aa923c3d8aed85657 (diff)
downloadports-0ef340877c0d22d69fb3dc53281bded0f3340f03.tar.gz
ports-0ef340877c0d22d69fb3dc53281bded0f3340f03.zip
- add patch to fix breakage caused by recent libnet changes
- bump portrevision - pass maintainership to submitter PR: 89951 Submitted by: Jonathan <onatan@gmail.com>
Notes
Notes: svn path=/head/; revision=150464
Diffstat (limited to 'security/fragroute')
-rw-r--r--security/fragroute/Makefile4
-rw-r--r--security/fragroute/files/patch-pcaputil.h13
2 files changed, 15 insertions, 2 deletions
diff --git a/security/fragroute/Makefile b/security/fragroute/Makefile
index f872646f947d..9e34afb824f3 100644
--- a/security/fragroute/Makefile
+++ b/security/fragroute/Makefile
@@ -7,13 +7,13 @@
PORTNAME= fragroute
PORTVERSION= 1.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security net
MASTER_SITES= http://monkey.org/~dugsong/fragroute/ \
${MASTER_SITE_PACKETSTORM}
MASTER_SITE_SUBDIR= UNIX/security
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= onatan@gmail.com
COMMENT= A tool for intercepting, modifying and rewriting egress traffic
BUILD_DEPENDS= ${LOCALBASE}/lib/libdnet.a:${PORTSDIR}/net/libdnet \
diff --git a/security/fragroute/files/patch-pcaputil.h b/security/fragroute/files/patch-pcaputil.h
new file mode 100644
index 000000000000..a219d79384ae
--- /dev/null
+++ b/security/fragroute/files/patch-pcaputil.h
@@ -0,0 +1,13 @@
+--- pcaputil.h.orig Thu Jan 17 22:33:55 2002
++++ pcaputil.h Mon Dec 5 13:26:13 2005
+@@ -9,6 +9,10 @@
+ #ifndef PCAPUTIL_H
+ #define PCAPUTIL_H
+
++#ifndef BIOCIMMEDIATE
++#define BIOCIMMEDIATE _IOW('B',112,u_int)
++#endif
++
+ pcap_t *pcap_open(char *device);
+ int pcap_dloff(pcap_t *pcap);
+ int pcap_filter(pcap_t *pcap, const char *fmt, ...);