aboutsummaryrefslogtreecommitdiff
path: root/security/fwlogwatch/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-20 07:02:41 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-20 07:02:41 +0000
commitdd56201cc7d7c85a447afb17d6cfdf8d07cc7671 (patch)
tree1cea039e30c7e357ff9ede159408d4f860e6a66e /security/fwlogwatch/Makefile
parentef28dd30a227257ff3973bee2b2b00c81af5fcb6 (diff)
downloadports-dd56201cc7d7c85a447afb17d6cfdf8d07cc7671.tar.gz
ports-dd56201cc7d7c85a447afb17d6cfdf8d07cc7671.zip
add fwlogwatch
A packet filter and firewall log analyzer
Notes
Notes: svn path=/head/; revision=50248
Diffstat (limited to 'security/fwlogwatch/Makefile')
-rw-r--r--security/fwlogwatch/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/security/fwlogwatch/Makefile b/security/fwlogwatch/Makefile
new file mode 100644
index 000000000000..7dd470c1d989
--- /dev/null
+++ b/security/fwlogwatch/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# New ports collection makefile for: fwlogwatch
+# Date created: Nov 20, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= fwlogwatch
+PORTVERSION= 0.5.1
+CATEGORIES= security
+MASTER_SITES= http://www.kyb.uni-stuttgart.de/boris/sw/
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= autob5:${PORTSDIR}/chinese/autoconvert
+LIB_DEPENDS= intl:${PORTSDIR}/devel/gettext
+
+INSTALL_TARGET= install install-i18n
+MANCOMPRESSES= no
+MAN8= fwlogwatch.8
+
+post-patch:
+ @${PERL} -pi -e "s,%%LOCALBASE%%,${LOCALBASE},g ; \
+ s,/etc,${PREFIX}/etc,g ; \
+ s,/usr/local,${PREFIX},g ; \
+ s,/usr/share,${PREFIX}/share,g" ${WRKSRC}/Makefile
+ @${PERL} -pi -e "s,/etc,${PREFIX}/etc,g ; \
+ s,/usr/share,${PREFIX}/share,g ; \
+ s,/usr/local,${PREFIX},g" ${WRKSRC}/main.h
+ @${PERL} -pi -e "s,/etc,${PREFIX}/etc,g" ${WRKSRC}/${MAN8}
+
+.include <bsd.port.mk>