aboutsummaryrefslogtreecommitdiff
path: root/security/gnomekeyringmanager/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
commit798e9bed2a389dce8a970e15b68176fd49f442db (patch)
tree9dc5597aab073298ec381964f72cd853b3dd366c /security/gnomekeyringmanager/Makefile
parent48b92584b0722f7f6ca412e6cfe16f1381e043cc (diff)
downloadports-798e9bed2a389dce8a970e15b68176fd49f442db.tar.gz
ports-798e9bed2a389dce8a970e15b68176fd49f442db.zip
Presenting GNOME 2.14.1 for FreeBSD! Checkout
http://www.gnome.org/start/2.14/ for the official release notes, and a list of all the gooides in this new release. In particular, GNOME 2.14 focused on performance, and they did not miss the mark. There's some new eye candy, but most of the big things are waiting until GNOME 2.16. On the FreeBSD side, we tried to clean up all the crashers we could. In particular, we really improved GNOME's 64-bit support. The good news is that this release does not bring any big shared library version bumps, so you can almost do a simple portupgrade to get to 2.14. There are a few minor gotchas that will be documented in UPDATING shortly. The FreeBSD GNOME Team would like th thank the following users for their patches, feedback, and sometimes incessant complaing about crashes (you know who you are). Yasuda Keisuke <kysd@po.harenet.ne.jp> Pascal Hofstee <caelian@gmail.com> rmgls@wanadoo.fr tmclaugh Yuri Pankov <yuri.pankov@gmail.com> sajd on #freebsd-gnome ade ankon on #FreeBSD-Gnome mux Pascal Hofstee <caelian@gmail.com> QuiRK on #freebsd-gnome Vladimir Timofeev <vovkasm@gmail.com>
Notes
Notes: svn path=/head/; revision=160863
Diffstat (limited to 'security/gnomekeyringmanager/Makefile')
-rw-r--r--security/gnomekeyringmanager/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/security/gnomekeyringmanager/Makefile b/security/gnomekeyringmanager/Makefile
index 19454ad0b488..4f91104654a0 100644
--- a/security/gnomekeyringmanager/Makefile
+++ b/security/gnomekeyringmanager/Makefile
@@ -3,29 +3,29 @@
# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/security/gnomekeyringmanager/Makefile,v 1.14 2005/09/07 14:54:53 adamw Exp $
+# $MCom: ports/security/gnomekeyringmanager/Makefile,v 1.19 2006/04/13 07:52:37 bland Exp $
#
PORTNAME= gnomekeyringmanager
-PORTVERSION= 2.12.0
+PORTVERSION= 2.14.0
CATEGORIES= security gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-keyring-manager/2.12
+MASTER_SITE_SUBDIR= sources/gnome-keyring-manager/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DISTNAME= gnome-keyring-manager-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME keyring manager
-BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/gnome-doc-utils.pc:${PORTSDIR}/textproc/gnomedocutils
LIB_DEPENDS= gnome-keyring:${PORTSDIR}/security/gnomekeyring
USE_X_PREFIX= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
+USE_GETTEXT= yes
USE_GMAKE= yes
INSTALLS_OMF= yes
-USE_GNOME= gnomehack gnomeprefix intlhack libgnomeui
+USE_GNOME= gnomehack gnomeprefix intlhack libgnomeui gnomedocutils
CONFIGURE_ARGS= --with-help-dir=${PREFIX}/share/gnome/help
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"