aboutsummaryrefslogtreecommitdiff
path: root/security/gnupg20/Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2018-01-01 11:41:37 +0000
committerRene Ladan <rene@FreeBSD.org>2018-01-01 11:41:37 +0000
commit9088acc2a4aa0ba267e1339fec9b8a15bf4eb11f (patch)
tree53c715320475b8180249742e862934b5f9c7aa28 /security/gnupg20/Makefile
parent7b393d7885ed94fe1b3448a5fd328a7f1f87ebd4 (diff)
downloadports-9088acc2a4aa0ba267e1339fec9b8a15bf4eb11f.tar.gz
ports-9088acc2a4aa0ba267e1339fec9b8a15bf4eb11f.zip
Remove expired ports:
2017-12-31 security/gnupg20: Will reach EOL upstream on 2017-12-31 2018-01-01 dns/dualserver: Please migrate to dns/dnsmasq. Over the years dualserver becomes unmaintenaible. 2018-01-01 devel/p5-Parse-Pidl44: yes 2018-01-01 sysutils/DTraceToolkit: Now maintained as part of the base system
Notes
Notes: svn path=/head/; revision=457766
Diffstat (limited to 'security/gnupg20/Makefile')
-rw-r--r--security/gnupg20/Makefile77
1 files changed, 0 insertions, 77 deletions
diff --git a/security/gnupg20/Makefile b/security/gnupg20/Makefile
deleted file mode 100644
index 142c38161a7f..000000000000
--- a/security/gnupg20/Makefile
+++ /dev/null
@@ -1,77 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= gnupg
-PORTVERSION= 2.0.30
-PORTREVISION= 2
-CATEGORIES= security
-MASTER_SITES= GNUPG
-PKGNAMESUFFIX= 20
-
-MAINTAINER= adamw@FreeBSD.org
-COMMENT= The GNU Privacy Guard (stable version)
-
-LICENSE= GPLv3 LGPL3
-LICENSE_COMB= multi
-LICENSE_FILE_GPLv3= ${WRKSRC}/COPYING
-LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING.LIB
-
-LIB_DEPENDS= libassuan.so:security/libassuan \
- libgcrypt.so:security/libgcrypt \
- libgpg-error.so:security/libgpg-error \
- libksba.so:security/libksba \
- libpth.so:devel/pth
-BUILD_DEPENDS= libgpg-error>=1.11:security/libgpg-error
-RUN_DEPENDS= pinentry:security/pinentry
-
-CONFLICTS= gnupg-2.1.* gnupg-2.2.*
-CPE_VENDOR= gnupg
-
-DEPRECATED= Will reach EOL upstream on 2017-12-31
-EXPIRATION_DATE=2017-12-31
-
-USES= cpe gmake iconv readline tar:bzip2
-USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-symcryptrun
-INFO= gnupg
-
-OPTIONS_DEFINE= LDAP SCDAEMON CURL GPGSM KDNS STD_SOCKET NLS DOCS SUID_GPG
-OPTIONS_DEFAULT=CURL SCDAEMON
-NO_OPTIONS_SORT=yes
-OPTIONS_SUB= yes
-
-GPGSM_DESC= Enable GPGSM (requires LDAP)
-LDAP_DESC= LDAP keyserver interface
-KDNS_DESC= Use DNS CERT helper
-SCDAEMON_DESC= Enable Smartcard daemon (with libusb)
-STD_SOCKET_DESC=Use standard socket for agent
-SUID_GPG_DESC= Install GPG setuid
-
-CURL_LIB_DEPENDS= libcurl.so:ftp/curl
-CURL_CONFIGURE_WITH= libcurl=${LOCALBASE}
-
-GPGSM_RUN_DEPENDS= dirmngr:security/dirmngr
-GPGSM_CONFIGURE_ENABLE= gpgsm
-GPGSM_IMPLIES= LDAP
-
-KDNS_LIB_DEPENDS= libadns.so:dns/adns
-KDNS_CONFIGURE_WITH= adns=${LOCALBASE}
-
-LDAP_USE= OPENLDAP=yes
-LDAP_CONFIGURE_WITH= ldap=${LOCALBASE}
-
-NLS_USES= gettext
-NLS_CONFIGURE_ENABLE= nls
-
-SCDAEMON_CONFIGURE_ENABLE= scdaemon
-
-STD_SOCKET_CONFIGURE_ENABLE= standard-socket
-
-post-patch:
- @${REINPLACE_CMD} -e "/#include <utmp.h>/d" \
- ${WRKSRC}/tools/symcryptrun.c
-
-post-install:
- @${MV} ${STAGEDIR}${DATADIR}/*.txt ${STAGEDIR}${DOCSDIR}
-
-.include <bsd.port.mk>