aboutsummaryrefslogtreecommitdiff
path: root/security/gnupg
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2007-01-14 07:03:52 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2007-01-14 07:03:52 +0000
commit53838794ea83f3fbbaeaa36a444bd9020de743b7 (patch)
tree38b3b06bd3a7e527149ba7de82e49406e95acf03 /security/gnupg
parente0f5e99dea8e15c495f99e839a2ebfcb5ad242eb (diff)
downloadports-53838794ea83f3fbbaeaa36a444bd9020de743b7.tar.gz
ports-53838794ea83f3fbbaeaa36a444bd9020de743b7.zip
- Make GPGSM dependency optional (then we can use this port without LDAP
dependency). [1] - Remove libpth hack in configure since this problem was fixed in 2.0.1. [2] - Remove silly conflict detections which breaks BATCH building [2],[3] - Check libassuan package version (to avoid using old lib) [4] PR: ports/107185 (I'm still working on NLS problem) [2], ports/107349 [3] Submitted by: Brian Minard <bminard@flatfoot.ca> [1], dougb [2], Ulrich Spoerlein <uspoerlein@gmail.com> [3], Ian Lister <freebsd-ports@lister.dnsalias.net> [4]
Notes
Notes: svn path=/head/; revision=182343
Diffstat (limited to 'security/gnupg')
-rw-r--r--security/gnupg/Makefile27
-rw-r--r--security/gnupg/pkg-plist4
2 files changed, 16 insertions, 15 deletions
diff --git a/security/gnupg/Makefile b/security/gnupg/Makefile
index 4ac1d71bbdba..febb9ad395d7 100644
--- a/security/gnupg/Makefile
+++ b/security/gnupg/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnupg
PORTVERSION= 2.0.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= gnupg
@@ -16,12 +17,11 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= The GNU Privacy Guard
-BUILD_DEPENDS= ${LOCALBASE}/lib/libassuan.a:${PORTSDIR}/security/libassuan
+BUILD_DEPENDS= libassuan>=1.0.1:${PORTSDIR}/security/libassuan
LIB_DEPENDS= gcrypt.13:${PORTSDIR}/security/libgcrypt \
gpg-error:${PORTSDIR}/security/libgpg-error \
ksba.17:${PORTSDIR}/security/libksba \
pth.20:${PORTSDIR}/devel/pth
-RUN_DEPENDS= dirmngr:${PORTSDIR}/security/dirmngr
CONFLICTS= gnupg-devel-[0-9]*
@@ -33,7 +33,7 @@ USE_LDCONFIG= YES
USE_GETTEXT= YES
CONFIGURE_TARGET=# empty
CONFIGURE_ARGS+= --infodir=${PREFIX}/info --mandir=${PREFIX}/man \
- --enable-nls --with-libpth-prefix=${LOCALBASE}/lib/pth
+ --enable-nls
MAN1= gpg2.1 gpgsm.1 gpgv2.1 gpg-agent.1 scdaemon.1 watchgnupg.1 \
gpgconf.1 gpg-preset-passphrase.1 gpg-connect-agent.1 \
gpgparsemail.1 symcryptrun.1 gpgsm-gencert.sh.1
@@ -42,18 +42,25 @@ INFO= gnupg
OPTIONS= LDAP "LDAP keyserver interface" off \
SCDAEMON "Enable Smartcard daemon (with libusb)" off \
- CURL "Use the real curl library (worked around if no)" on
+ CURL "Use the real curl library (worked around if no)" on \
+ GPGSM "Enable GPGSM" on
PLIST_SUB= NLS=""
.include <bsd.port.pre.mk>
+.if defined(WITHOUT_GPGSM)
+CONFIGURE_ARGS+=--disable-gpgsm
+PLIST_SUB+= GPGSM="@comment "
+.else
+RUN_DEPENDS= dirmngr:${PORTSDIR}/security/dirmngr
+WITH_LDAP= YES
+PLIST_SUB+= GPGSM=""
+.endif
+
.if defined(WITH_LDAP)
USE_OPENLDAP= YES
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
PLIST_SUB+= LDAP=""
-.if defined(WITHOUT_LDAP)
-BROKEN= Conflict options: WITHOUT_LDAP/WITH_LDAP
-.endif
.else
CONFIGURE_ARGS+=--disable-ldap
PLIST_SUB+= LDAP="@comment "
@@ -63,9 +70,6 @@ PLIST_SUB+= LDAP="@comment "
CONFIGURE_ARGS+=--enable-scdaemon
LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
PLIST_SUB+= SCDAEMON=""
-.if defined(WITHOUT_SCDAEMON)
-BROKEN= Conflict options: WITHOUT_SCDAEMON/WITH_SCDAEMON
-.endif
.else
CONFIGURE_ARGS+=--disable-scdaemon
PLIST_SUB+= SCDAEMON="@comment "
@@ -73,9 +77,6 @@ PLIST_SUB+= SCDAEMON="@comment "
.if defined(WITHOUT_CURL)
CONFIGURE_ARGS+=--without-libcurl
-.if defined(WITH_CURL)
-BROKEN= Conflict options: WITHOUT_CURL/WITH_CURL
-.endif
.else
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+=--with-libcurl=${LOCALBASE}
diff --git a/security/gnupg/pkg-plist b/security/gnupg/pkg-plist
index a2258ae63a42..ff4227428c44 100644
--- a/security/gnupg/pkg-plist
+++ b/security/gnupg/pkg-plist
@@ -4,10 +4,10 @@ bin/gpg2
bin/gpgconf
bin/gpgkey2ssh
bin/gpgparsemail
-bin/gpgsm
+%%GPGSM%%bin/gpgsm
bin/gpgsm-gencert.sh
bin/gpgv2
-bin/kbxutil
+%%GPGSM%%bin/kbxutil
%%SCDAEMON%%bin/scdaemon
bin/watchgnupg
%%SCDAEMON%%libexec/gnupg-pcsc-wrapper