aboutsummaryrefslogtreecommitdiff
path: root/security/gringotts/Makefile
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2002-07-06 16:54:46 +0000
committerAnders Nordby <anders@FreeBSD.org>2002-07-06 16:54:46 +0000
commit000c89ee2ea50a57623fd5554053da50e10696c4 (patch)
treee0300b6981c1476a4bf8b9e494379561911b46cf /security/gringotts/Makefile
parent7219c6847f410344c3d7fedf5f9aaebecd04b8b0 (diff)
downloadports-000c89ee2ea50a57623fd5554053da50e10696c4.tar.gz
ports-000c89ee2ea50a57623fd5554053da50e10696c4.zip
Add gringotts, a GTK application for securely storing sensitive data.
Notes
Notes: svn path=/head/; revision=62522
Diffstat (limited to 'security/gringotts/Makefile')
-rw-r--r--security/gringotts/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/security/gringotts/Makefile b/security/gringotts/Makefile
new file mode 100644
index 000000000000..321a5b674985
--- /dev/null
+++ b/security/gringotts/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: gringotts
+# Date created: 02 July 2002
+# Whom: Anders Nordby <anders@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gringotts
+PORTVERSION= 0.5.9
+CATEGORIES= security
+MASTER_SITES= http://devel.pluto.linux.it/projects/Gringotts/current/ \
+ ftp://ftp.nuug.no/pub/anders/distfiles/
+
+MAINTAINER= anders@FreeBSD.org
+
+LIB_DEPENDS= mcrypt.7:${PORTSDIR}/security/libmcrypt \
+ mhash.2:${PORTSDIR}/security/mhash \
+ gtk-x11-2.0.0:${PORTSDIR}/x11-toolkits/gtk20 \
+ popt.0:${PORTSDIR}/devel/popt
+
+USE_BZIP2= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include"
+CONFIGURE_ARGS+= --disable-env-check
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.pre.mk>
+
+WANT_GNOME= yes
+.if defined(HAVE_GNOME)
+USE_GNOME= yes
+.else
+
+post-patch:
+ @${PATCH} < ${FILESDIR}/gnomeless-Makefile.in \
+ ${WRKSRC}/Makefile.in >/dev/null 2>&1
+.endif
+
+.include <bsd.port.post.mk>