aboutsummaryrefslogtreecommitdiff
path: root/security/heimdal/Makefile
diff options
context:
space:
mode:
authorJacques Vidrine <nectar@FreeBSD.org>2000-10-31 17:26:41 +0000
committerJacques Vidrine <nectar@FreeBSD.org>2000-10-31 17:26:41 +0000
commit10f93da3a0547d0a5d43e4117b48cdd1a3a01dd5 (patch)
treeb1bb3b4f26c22fe4b3c8278273365ba5ddf6c68f /security/heimdal/Makefile
parent0921a27eb9e00d113124bb0d1201d09cf49e4acb (diff)
downloadports-10f93da3a0547d0a5d43e4117b48cdd1a3a01dd5.tar.gz
ports-10f93da3a0547d0a5d43e4117b48cdd1a3a01dd5.zip
Add a knob (WITH_LDAP) to enable compiling with support for LDAP as a
backend database for the KDC.
Notes
Notes: svn path=/head/; revision=34502
Diffstat (limited to 'security/heimdal/Makefile')
-rw-r--r--security/heimdal/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/security/heimdal/Makefile b/security/heimdal/Makefile
index 730cdc0080d0..454ba68692a7 100644
--- a/security/heimdal/Makefile
+++ b/security/heimdal/Makefile
@@ -15,6 +15,10 @@ MASTER_SITES= ftp://ftp.pdc.kth.se/pub/heimdal/src/ \
MAINTAINER= nectar@FreeBSD.ORG
+.if defined(WITH_LDAP)
+LIB_DEPENDS= ldap.2:${PORTSDIR}/net/openldap2
+.endif
+
RESTRICTED= "Crypto; export-controlled"
MAN1= ftp.1 kdestroy.1 kf.1 kgetcred.1 kinit.1 klist.1 kpasswd.1 \
@@ -35,6 +39,9 @@ MAN8= ftpd.8 hprop.8 hpropd.8 kadmind.8 kdc.8 kfd.8 kpasswdd.8 \
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --enable-shared
+.if defined(WITH_LDAP)
+CONFIGURE_ARGS+= --with-openldap=${LOCALBASE}
+.endif
.if defined(HEIMDAL_HOME)
PREFIX= ${HEIMDAL_HOME}