aboutsummaryrefslogtreecommitdiff
path: root/security/hpn-ssh/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-06-26 12:22:25 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-06-26 12:22:25 +0000
commit18f285a18d7146d3c79b0bfc2a27712c37cadc86 (patch)
tree9476ea322b17b070f33ca6c0aee02eea314618d2 /security/hpn-ssh/Makefile
parent157749c1150f4f3b03f52c89c74bd7d3013bc468 (diff)
downloadports-18f285a18d7146d3c79b0bfc2a27712c37cadc86.tar.gz
ports-18f285a18d7146d3c79b0bfc2a27712c37cadc86.zip
Thanks to max@wide.ad.jp, maxim, obraun@informatik.unibw-muenchen.de, fjoe
Patch from current, noted by drs@rucus.ru.ac.za: environment variables in the 'setenv' field of login.conf are set now.
Notes
Notes: svn path=/head/; revision=62015
Diffstat (limited to 'security/hpn-ssh/Makefile')
-rw-r--r--security/hpn-ssh/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/security/hpn-ssh/Makefile b/security/hpn-ssh/Makefile
index a37a28004dc5..d4f6705dfbb8 100644
--- a/security/hpn-ssh/Makefile
+++ b/security/hpn-ssh/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openssh
PORTVERSION= 3.3p1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
ftp://ftp.op.net/pub/OpenBSD/OpenSSH/portable/ \
@@ -98,7 +98,11 @@ post-configure:
${FILESDIR}/sshd.sh > ${WRKSRC}/sshd.sh
pre-install:
+.if defined(OPENSSH_OVERWRITE_BASE)
+ -${MKDIR} ${EMPTYDIR}
+.else
-${MKDIR} ${PREFIX}/empty
+.endif
if ! pw groupshow sshd; then pw groupadd sshd -g 22; fi
if ! pw usershow sshd; then pw useradd sshd -g sshd -u 22 \
-h - -d ${EMPTYDIR} -s /nonexistent -c "sshd privilege separation"; fi
@@ -110,7 +114,7 @@ pre-install:
.endfor
post-install:
-.if defined(OPENSSH_OVERWRITE_BASE)
+.if !defined(OPENSSH_OVERWRITE_BASE)
${INSTALL_SCRIPT} ${WRKSRC}/sshd.sh ${PREFIX}/etc/rc.d/sshd.sh.sample
.endif
${INSTALL_DATA} -c ${WRKSRC}/ssh_config.out ${ETCSSH}/ssh_config-dist