aboutsummaryrefslogtreecommitdiff
path: root/security/hpn-ssh/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-02-17 15:00:25 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-02-17 15:00:25 +0000
commitf90e5def7fe54a3cdab2df7fee006f1e3aa22dbb (patch)
tree0cddc2431be3ffde4d7d86c2033e631e3fa2bbb6 /security/hpn-ssh/Makefile
parent1872f119c59ca5e4e974cfadcbdd19627f7ee23e (diff)
downloadports-f90e5def7fe54a3cdab2df7fee006f1e3aa22dbb.tar.gz
ports-f90e5def7fe54a3cdab2df7fee006f1e3aa22dbb.zip
Add option to support patches:
OpenSSH supports Kerberos v5 authentication, but this is not enabled in the portable version. A patch is available to correct this deficiency for those wishing to use this port with Kerberos. In addition, a patch is also available from Simon Wilkinson to implement the GSS-API key-exchange mechanism for SSHv2, which is currently being standardized. Use of this mechanism with Kerberos v5 obviates the need for manual management of host keys, a considerable improvement for large Kerberos sites. PR: 34363 Submitted by: wollman@hergotha.lcs.mit.edu
Notes
Notes: svn path=/head/; revision=54819
Diffstat (limited to 'security/hpn-ssh/Makefile')
-rw-r--r--security/hpn-ssh/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/security/hpn-ssh/Makefile b/security/hpn-ssh/Makefile
index ead7b3a3db01..8d6fe1acf548 100644
--- a/security/hpn-ssh/Makefile
+++ b/security/hpn-ssh/Makefile
@@ -48,6 +48,30 @@ CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man \
EXTRA_PATCHES+= ${FILESDIR}/batch.patch
.endif
+.if defined(KRB5_HOME)
+MASTER_SITES+= ${PATCH_SITES}
+DISTFILES= ${EXTRACT_ONLY} ${PORTNAME}-${PORTVERSION}-gssapi.patch
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
+PATCH_SITES= http://www.sxw.org.uk/computing/patches/
+PATCHFILES= ${PORTNAME}-${PORTVERSION}-krb5.patch
+BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
+# USE_AUTOCONF_VER= 252 # broken
+CONFIGURE_ARGS+= --with-kerberos5=${KRB5_HOME}
+AUTOCONF= autoconf
+AUTOHEADER= autoheader
+
+post-patch:
+ @${ECHO_MSG} Applying extra patch for GSS-API key-exchange...
+ @${PATCH} ${PATCH_DIST_ARGS:S/-p0/-p1/} \
+ < ${DISTDIR}/${PORTNAME}-${PORTVERSION}-gssapi.patch
+
+pre-configure:
+ @${ECHO_MSG} !!!! Warning this option uses autoconf/autoheader !!!
+ (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOCONF_ENV} ${AUTOCONF} \
+ ${AUTOCONF_ARGS})
+ (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOCONF_ENV} ${AUTOHEADER})
+.endif
+
post-install:
@${CAT} ${PKGMESSAGE}