aboutsummaryrefslogtreecommitdiff
path: root/security/ifd-gempc410/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2005-04-20 12:42:06 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2005-04-20 12:42:06 +0000
commit384c2bae3b94d68ec15491eba4dc6c00acfb93ea (patch)
treefa1875a4f3aa5c20bbc367e43e857f6c786b914f /security/ifd-gempc410/Makefile
parent2a7193c97879226f0631d791aecbcac01770058f (diff)
downloadports-384c2bae3b94d68ec15491eba4dc6c00acfb93ea.tar.gz
ports-384c2bae3b94d68ec15491eba4dc6c00acfb93ea.zip
pcsc-lite:
- Upgrade to 1.2.9.b.7 - Use libtool15 - make hier(7)-compliant by moving the pcsc/drivers to lib/pcsc/drivers - Compile with USB support per default. Use WITHOUT_USB to disable usb support - Chase libusb shared library version (Forgotten by leeym) Based on: PR 76068 Reviewed by: maintainer, sem (earlier patch) ifd-devkit: - Chase pcsclite sharedlibrary version ifd-gempc410: - Unbreak by updating to 0.9.3 - Move library to lib/pcsc/drivers - Chase pcsclite sharedlibrary version NOTE: This was not tested, I don't own the specific hardware ifd-gpr400: - Chase pcsclite sharedlibrary version - Fix build with new pcsc-lite - Chase new pcsclite drivers location ifd-slb_rf60: - Chase pcsclite sharedlibrary version ifd-test: - Chase pcsclite sharedlibrary version - Fix build with new pcsclite libchipcard: - Update to 0.9.1[1] - Chase pcsclite shared library version - Fix build with new pcsclite [1]PR: 78815 [1]Submitted by: lofi opensc: - Chase pcsclite shared library version - Fix build on CURRENT opensc-esteid - Chase pcsclite shared library version - Fix build with new pcsclite p5-PCSC-Card: - Update to 1.4.2 - Chase pcsclite shared library version - Fix build with new pcsclite ruby-pcsc-lite - Mark broken, does not compile with new pcsc-lite Maintainer will work on new version Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=133752
Diffstat (limited to 'security/ifd-gempc410/Makefile')
-rw-r--r--security/ifd-gempc410/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/security/ifd-gempc410/Makefile b/security/ifd-gempc410/Makefile
index ef59cc040603..964d8326178c 100644
--- a/security/ifd-gempc410/Makefile
+++ b/security/ifd-gempc410/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ifd-gempc410
-PORTVERSION= 0.8.2
-PORTREVISION= 1
+PORTVERSION= 0.9.3
CATEGORIES= security
MASTER_SITES= http://ludovic.rousseau.free.fr/softwares/ifd-GemPC/
DISTNAME= ifd-gempc-${PORTVERSION}
@@ -16,9 +15,7 @@ MAINTAINER= des@freebsd.org
COMMENT= PC/SC Lite driver for the GemPC 410 serial smart card reader
BUILD_DEPENDS= ${LOCALBASE}/include/ifdhandler.h:${PORTSDIR}/security/ifd-devkit
-LIB_DEPENDS= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
-
-BROKEN= "Does not fetch"
+LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
USE_GMAKE= yes
USE_REINPLACE= yes
@@ -38,6 +35,11 @@ post-configure:
${SED} -e 's|%%PREFIX%%|${PREFIX}|g' <${FILESDIR}/message >${PKGMESSAGE}
${TOUCH} ${WRKSRC}/GemPC410/dep_stamp ${WRKSRC}/common/dep_stamp
+do-install:
+ ${MKDIR} ${PREFIX}/lib/pcsc/drivers/serial
+ ${INSTALL_DATA} ${WRKSRC}/GemPC410/libGemPC410.so* \
+ ${PREFIX}/lib/pcsc/drivers/serial
+
post-install:
@${CAT} ${PKGMESSAGE}